Recent content by RobNorthcott

  1. R

    Can't watch any channels, but scan works

    Well I gave in and reinstalled the machine from scratch. All working properly again now, which is good, but a shame I couldn't find out what was actually wrong. Windows updates turned off for now just in case...
  2. R

    Can't watch any channels, but scan works

    OK, digging through the source now :/ It seems like the TvSetup doesn't actually check if the port is available - it reads TvControl.RemoteControl.Instance.StreamingPort from the current tvservice instance and if that returns 0 (presumably because it didn't get as far as setting the port up when...
  3. R

    Can't watch any channels, but scan works

    The MP TvServer setup seems to "think" all ports are bound, but I'm convinced they aren't really. I suspect that whatever MP uses to check if the port is available is failing, and the failsafe behaviour is to show the "port already bound" message. I wonder what it's trying to do to check if...
  4. R

    Can't watch any channels, but scan works

    It looks like there is no option to change that in the TvServer setup. It always listens on RTSP, but the MP front-end uses UNC by default for single-seat. So I don't think there's a way to stop the tvservice setting up the RTSP port. I can't find any evidence of 554 being used by anything on...
  5. R

    Can't watch any channels, but scan works

    Right... I've had a bit more time to investigate and it seems like the first difference in the tvservice log between when it was working and now is where it should say "Controller: setup streaming", but instead we get the "invalid class" error. On the "3rd party checks" page of Tv Server Config...
  6. R

    Can't watch any channels, but scan works

    I'm not recording straight to the NAS (recordings directory is on a local SSD), but there are some old files that were moved to the NAS that for "family acceptance" reasons had to stay visible in the recordings menu in MP. But I couldn't give the system user that tvservice was running under...
  7. R

    Can't watch any channels, but scan works

    Well it's not disabled performance counters on this machine, but it seems there are all sorts of causes of that error. It definitely wasn't happening before, so worth a bit more poking around I reckon before giving up and reinstalling the lot.
  8. R

    Can't watch any channels, but scan works

    @CyberSimian , the tvservice runs as a system user by default, but I changed it a couple of years ago to run as the normal user so it access (and delete) files on my nas. Yes, reinstalling from scratch is the brute-force solution... I haven't quite given up yet though :) @doskabouter , you may...
  9. R

    Can't watch any channels, but scan works

    OK, had the machine apart and reseated everything. I'm convinced it's not a problem with the tuner now because exactly the same thing happens with the USB DVB-T tuner as with the PCIe DVB-S. All tuners can run a channel scan but fail to start graph when trying to watch or record anything...
  10. R

    Can't watch any channels, but scan works

    Things are getting freakier now... the tuner card has disappeared completely from Windows and rebooting doesn't bring it back (can't power off because I'm connected remotely). I wonder if the card's connection to the PCIe slot is a bit flaky - I'll try taking it out and reseating it later when...
  11. R

    Can't watch any channels, but scan works

    Thanks @CyberSimian - that does tend to support my theory that the hardware and tuner driver are OK and it's "just" a codec/some other software problem. I'll keep poking around...
  12. R

    Can't watch any channels, but scan works

    Disabling IPV6 didn't make any difference unfortunately. I'll try removing a few more updates next time I get a chance, unless I can find a definite cause for the problem. Does anybody know what "start graph" is actually trying to do? Not knowing anything about these sorts of drivers, it...
  13. R

    Can't watch any channels, but scan works

    Worth a try - not had any luck yet with rolling back updates.
  14. R

    Can't watch any channels, but scan works

    Thanks @CyberSimian - there have been a few Windows updates recently, so possibly one of those has broken something. I'll have a check of the codecs and see if any recent update may have changed something. Thanks for the hints... (unfortunately I haven't made a complete system drive image of...
  15. R

    Can't watch any channels, but scan works

    I've got a weird problem with my single-seat MP installation. Recently (a few days ago) it stopped being able to receive any channels. I assumed the dish had moved in the wind but checked it today and it's fine. Both my DVB-S tuners are able to run a channel scan, but channel preview fails...
Top Bottom