0.2.0 -> 0.1.3 ?? Downgrade (1 Viewer)

jeffp

Portal Pro
October 4, 2005
66
0
USA
What is the easiest way to move from 0.2.0 back to 0.1.3? I've only ever used 0.2.0 but would like to move back to 0.1.3 to see how much more stable it really is? I like a lot of what 0.2.0 has to offer but there just seems to be a lot of little qwerks that are really starting to annoy the wife and well we all know what that can lead to.

I want to be able to maintain all my channel configurations, movie info, etc. I spent a lot of time getting everything set the way I like it and would hate to have to do that all over again.


Thanks!
 

FlipGer

Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    47
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    hmmm. I think it could be done this way:

    1) Make a copy of your current installation! Just to be sure to get back to 0.2 if needed. You can eg. compress the whole MediaPortal directory.*
    2) Uninstall 0.2
    3) Install 0.1.3
    4) Run Configure, before starting MP!
    5) Play around with 0.1.3

    Rollback if needed:
    1) Uninstall 0.1.3
    2) Delete all contents of the MediaPortal directory
    3) Install 0.2
    4) Uncompress your backup
    5) Run Configure
    6) Welcome back 0.2

    * You even can use both versions at the same time. Copy 0.2. to eg. to a directory called MediaPortal_0.2. It will still run from there!


    HTH, Flip.
     

    TheVideoViking

    Portal Pro
    November 30, 2004
    62
    0
    Groningen, Netherlands
    Most information is stored in the databases in the "database" dir. You could try to make a copy of them, uninstall 0.2.0 install 0.1.3 and overwrite the new databases with the old ones. You should do the same with the "thumbs" dir. I don't know where the movie info is installed, but you could try yhe same with that file. The trick with the databases will only work if they havent't changed between 0.1.3 and 0.2.0, but I don't think it has.
     

    jeffp

    Portal Pro
    October 4, 2005
    66
    0
    USA
    so like flipger mentioned, can I just install 0.1.3 right over top of the exsisting dir and all the db's will stay? as long as they are compatible of course.
     

    FlipGer

    Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    47
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    jeffp said:
    so like flipger mentioned, can I just install 0.1.3 right over top of the exsisting dir and all the db's will stay? as long as they are compatible of course.

    Yep, that is what i ment. Uninstall does not delete your databases or *.xml settings.

    Flip.
     

    jeffp

    Portal Pro
    October 4, 2005
    66
    0
    USA
    well I finally performed this and as suspected I was able to just remove 0.2.0 and install 0.1.3 over top of the exsisting directory and all seems to be working fine. All the settings were kept and the DB's were intact.

    I wanted to see how much more stable it is than 0.2.0, and I have a couple questions.

    1. I remember reading in a few places but couldn't find it now that I needed it that there is one particular CVS for 0.1.3 that is considered the most stable. Which one is that? Does anyone recall?

    2. When in the TV Guide the page up and down doesn't work, instead it changes the day you are looking at. Is there a way to make this page up and down through the guide instead?

    3. When first starting MP it sits at the "Loading Skin" phase for at least a good 20 seconds before going to the main menu. Is this normal for 0.1.3?

    Other than that so far I'm finding it to be much more stable than 0.2.0 and a lot of the issues I was having are now gone. I am looking forward to getting back to 0.2.0 when an oficial realease comes out.
     

    FlipGer

    Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    47
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    1) Afaik this was 08-26-2005, but there may be other opinions
    2) Look into Setup->General->Keys & Sounds
    3) That is a known problem with 0.1.3. and big EPGs. This is solved in one of the CVSs (should be in the one mentioned above).

    Flip.
     

    jeffp

    Portal Pro
    October 4, 2005
    66
    0
    USA
    Thanks,

    I'll take a look at the setup and I'll start with that CVS and see where I go from there.
     

    Users who are viewing this thread

    Top Bottom