0.2.0.0 RC1 and CVS My Tv visual defects and problems (1 Viewer)

knutinh

Portal Pro
September 4, 2005
558
2
Hi. Im not quite ready to write an extensive bug-report, but I thought I`d describe my problems to see of others have similar probs.

Tested MP versions: 0.2.0.0 RC1 and perhaps 50% of the later CVS-es.
I have combo of DVB-T and analog cable tv. Connected to a 50Hz PAL CRT tv. Windows XP pro sp2 with all bugfixes and hotfixes. Latest drivers all over.

Main problem:
*A horisontal "line" that slowly scans through my tv picture. It almost seems as if vsync was switched off. Especially on fast horisontal pans, a disturbed section consisting of a few lines is clearly (and frustratingly) visible. It seems to be there regardless of codec, renderer etc. Only affects My tv (DVB and analog), not my movies etc. Does not affect the tv playback software that accompanied my DVB card.


Other problems:
*My Tv works great for one or two channel "zaps", then it halts, and I cant change channel (or do anything) for a minute or two, then all my remote commands are exectuted all at once (ctr-alt-del shows that cpu-load is 10%). Seems to have improved with the CVSes the last couple of days.

*Error message ("no available cards to decode this channel"), even though no recording is done, so all cards should be free.

Funny thing is, it seems that there are less problems with my 60Hz lcd PC-display than using my 50Hz PAL CRT TV. That is using MediaPortal, using any other software, the performance on both is flawless :-(


-k
 

wewe

Portal Pro
August 3, 2005
362
0
60
Herxheim
Home Country
Germany Germany
Hi knutinh,

I had also this thing that they call "tearing" (as I learned). That means a horizontal line or "cut" in the picture.

I also have a 50Hz PAL. So I changed the frequency of my graphics card to explicitly 50HZ. Then it was gone ...

(I am on 0.2. RC1 + CVS, I am having a PVR150 and a GForce 6200)

The other problems (MP "hanging" a certain time and message "no signal detected" and some things more) I also have. I am hoping that MP gets more stable when going towards 0.2.Release, because my wife begins is complaining more and more ...


thanks+regards
wewe
 

Callifo

Retired Team Member
  • Premium Supporter
  • December 7, 2004
    1,439
    21
    Adelaide, Australia
    Home Country
    Country flag
    What fixed tearing for me (was mentioned by someone else) was to turn on use exclusive DirectX mode.... in setup and in my Nvidia drivers I forced vsync ON for all DirectX apps.
     

    knutinh

    Portal Pro
    September 4, 2005
    558
    2
    Callifo:
    I have tried exclusive direct X, but didnt find it to be very stable. I have also tried forced v-synk. But I havent tried both at once. Will try tonight...

    wewe:
    I didnt find a "normal" setting that would allow 50Hz desktop, but I have tried 60Hz and 100Hz desktop refreshrates. Most of the time, I have used a "custom timing" of 50Hz interlaced together with 720x576 PAL resolution - thinking that it would be ideal to use a desktop resolution matching the tv out. I have also tried other standard reolutions such as 1024x768 just for the heck of it.

    What I dont get is what makes tv viewing so unique and difficult compared to playing back movies? I thought it was just a matter of pushing frames to a fram buffer?

    I have the same problem of MP "hanging", but mostly in "My Tv"

    BTW, no negativity towards the developers, I think they are doing a great job. I just want to see how many share my probs.

    regards
    Knut
     

    knutinh

    Portal Pro
    September 4, 2005
    558
    2
    Also, the tuning now detects DVB-radio channels. I can find those channels in "My radio" and select one. However, after selection, MP stops to react and only ctrl-alt-del will get me back to the OS.

    I have now put "taskmgr.exe" as the only application quick start on my remote control. As I have no keyboard/mouse in my living room, this saves me a LOT of running to my bedroom, sstarting VNC and forcing ctrl-alt-del to force close MP, which happens once or twice every night :)

    regards
    Knut Inge
     

    wewe

    Portal Pro
    August 3, 2005
    362
    0
    60
    Herxheim
    Home Country
    Germany Germany
    Hi knutinh,

    my 50Hz setting is also a custom one.

    First I also used 720x576 as this should be the "original" PAL resolution. But this is very inconvenient when u have to mess around in Windows. Meanwhile I think that anyways plays no role as u have to overscan by 10% or more in order to get a square picture (at least with my old TV).

    So meanwhile I am on 800x600, 50Hz.

    The effect of hanging MP in MyTV in my opinion is related to the video codec. Tryin' out different ones the effect was stronger or less strong. Meanwhile I am back on mpeg2dec which seems to be the robusted one - at least togehter with PVR 150. But that one has problems with fast scenes - unsharp shapes.

    Hanging MP I don't have in fullscreen. But when beeing in MyTV main menu or EPG or Timer and so on then the little preview picture "hangs" for a second or sometimes 10 seconds and in that time I can not navigate in the menu.

    I also do not want to blame the developers ... I am a real fan of the project MP. The problem is that there are incredible many combinations of hardware and software. And my problem is to find good working settings for MY combination.

    thanks + regards
    wewe
     

    knutinh

    Portal Pro
    September 4, 2005
    558
    2
    Yes. Ideally, I would have thought that the windows environment should provide a kind of "sandbox" where individual hardware implementations (and also software module implementations) presented an interface properly described by some documentation, so that software developers could focus on developing functionality around that API. Of course, things are never ideal in the windows world :)

    But seriously, I think that very few developers of software mp3 players have to focus a lot on audio hardware in order to make their players work. And if there is an error in their code, it will be debuggable on any system. Perhaps tv-cards will be like that? in 10 years :-D

    regards
    Knut
     

    knutinh

    Portal Pro
    September 4, 2005
    558
    2
    Its working!!!

    After patching with yesterdays CVS and switching to exclusive direct x, I was able to view live tv without teraing for the first time since the first 0.2.0.0 RC1 !

    Now I only have the following problems:
    *pressing "-" (Im using it for navigating teletext) anywhere else than in teletextr modus causes a spontaneous application exit
    *Navigating channels is still buggy. Sometimes it will go into a "loop", where pressing channel+ will cycle through 2-3 channels. Also, some problems with "no available decoder for this channel"

    Great news!

    -k
     

    Users who are viewing this thread

    Similar threads

    for it can record, many channel from the same transponder. but thank you for confirming your asking
    for it can record, many channel from the same transponder. but thank you for confirming your asking
    I'm currently using a TBS6985 DVB-S2 quad tuner, but we have reception issues - seems to be caused internally in the server - I...
    Replies
    2
    Views
    684
    Today I did send a reminder to DD, since 09-2020 no news from them about new drivers. 3.0.2.211 x64 seems to work for me to, but DD told me, those where beta drivers, and some cards did have problems with them. Here you can find stable older drivers, Digital Devices Store But 3.0.3.224 did not work for me, so the latest stable...
    Today I did send a reminder to DD, since 09-2020 no news from them about new drivers. 3.0.2.211 x64 seems to work for me to, but...
    I recently upgraded my somewhat ancient 1.16 installation to the latest version, 1.25, and have a couple of problems, but the most...
    Replies
    16
    Views
    5K
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this year, in march 2020) the Telenet provider will stop broadcasting Analog TV and Radio signals on their cable, and make the switch to Digital (DVB-C). The radio signals will disappear completely, so you'll...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    Replies
    0
    Views
    910
    Hello!!! I use a handy app called catchin' sync to roughly check the AV sync of audio/video on my HTPC/TV. It's not as accurate as a dedicated opto-electronic calibrator but it's more than adequate for this application and much better than trying to do things by eye (even when the lack of sync is massively obvious, subjective...
    Hello!!! I use a handy app called catchin' sync to roughly check the AV sync of audio/video on my HTPC/TV. It's not as accurate as...
    Hello!!! I use a handy app called catchin' sync to roughly check the AV sync of audio/video on my HTPC/TV. It's not as accurate as...
    Replies
    0
    Views
    402
    Hello Mediaportal-Forum, I have a problem with my technotrend S2-3200 cards. After a while the card loses all signal information. The first one work for years without problems. Suddenly mediaportal didn't show a program, no signal. All my efforts to find signal by rebooting, rescanning of channels or reinstalling driver toke no...
    Hello Mediaportal-Forum, I have a problem with my technotrend S2-3200 cards. After a while the card loses all signal information...
    Hello Mediaportal-Forum, I have a problem with my technotrend S2-3200 cards. After a while the card loses all signal information...
    Replies
    0
    Views
    504
    Top Bottom