Accessing TV-server from the internet? (1 Viewer)

erazmuz

New Member
May 2, 2009
3
0
Home Country
Denmark Denmark
Hi there,

I've been trying to set up my TV-server to be accessable from the internet for days now and I'm about to give up.

I've been searching the forums for help but can't seem to find any.

So, is it even possible? Has anyone got this working? If so, I could use some help configuring my setup.
 

funkstar

Retired Team Member
  • Premium Supporter
  • August 9, 2005
    771
    28
    Home
    Home Country
    Scotland Scotland
    I don't think this is a very good idea to be honest.

    you will need to open all the ports detailed in this Wiki page (TV-Server/Configuration/Firewall - MediaPortal Manual Documentation) on your router and forward them to your TVserver box.

    For streaming video you are going to be limited to whatever format they were recorded in, so for DVB streams thats most likey MPEG2 at a very high bitrate, far, far higher than broadband can handle. MediaPortal doesn't have any provision for on the fly transcoding to facilitate remote access.

    This is a fairly regular feature request, and we might see something like it in MP2, but who knows really :)
     

    erazmuz

    New Member
    May 2, 2009
    3
    0
    Home Country
    Denmark Denmark
    Thanks for your reply ;)

    I'm fully aware of the rinks for opening up for the internet, but I have set up a filter in my router to only accept connections from specific IP's.

    The idea of the whole thing is, to be able to connect to the TV-server at home from our summerhouse and also to grant my parants house access, so that my dad can watch Champions league from my TV-server.

    I've already got it working from the summerhouse using VPN (Hamachi) and it's perfectly fine quality wise. But using VPN opens up more than good is, in regards to my parents house. I don't want them to be able to access all my windows shares etc.

    So if I could use VPN in the summerhouse and have access to all the music- picture- and videoshares and have access to live-TV using the IP-filter in my router at home, it would be perfect :cool:
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    Home Country
    South Africa South Africa
    Maybe you should play a bit with the PiipTV plugin. Although intended for Nokia, it also has a web User Interface:
    webui.jpg

    Maybe it can help you.

    https://forum.team-mediaportal.com/plugins-47/piiptv-livetv-remote-pvr-nokia-video-center-38598/
    Freeware PiipTv XMLTV / IPTV plugin for Mediaportal & Nokia N95
     

    adamu

    New Member
    May 2, 2009
    3
    0
    Home Country
    I have tried this and it doesn't work so well, due to bandwidth limitations on my end.

    Since my work connection has a vpn ipsec tunnel setup between home (tv server).
    Tried to stream at work from home.

    At work I can login to the tv server, by using the mptv
    No need to forward ports since I have access to local lan through tunneling.
    All four green OK's come up on the mptv client
    EPG loads
    Double click a channel, vlc opens but nothing ever plays.

    Is it possible to get this going with limited upstream bandwidth ie lowering the quality?

    Will the Piip tv plugin in the above post work in my situation?
     

    adamu

    New Member
    May 2, 2009
    3
    0
    Home Country
    I'm still struggling with this. Anyone know if it's possible or not?


    Yes I don't see why not, if you can open the necessary ports on your tvserver it should be reachable from wherever.
    Bandwidth is the only thing restricting me other than that I can open mptv client, connect, read EPG for the channels and open vlc, but no audio and video cause my upstream on the tvserver is 384k (6-10kb/s up, pathetic :()
     

    mxnerd

    New Member
    January 1, 2011
    1
    0
    I also wanted to put a low power HTPC at my sister's house so I can watch one or two cable channel over internet.

    At first it didn't work at all and MediaPortal complains that it can't connect to database, etc. Then I open up port 3306, 31456, and 554. But still no vail.

    I then diabled firewall on both WIndows 7 machine, installed Hamachi. Even added Hamachi IP in hosts file. I finally was able to run MediaPortal and connect to MediaPortal TV server on her side. I can see the connection on MediaPortal TV Server being established and channel being started. But the MediaPortal TV client on my side will comlain no video and no audio.

    Is it because the not enough bandwidth? I actually don't need a big display of the TV channel, all I need is only a tiny one, like 320x240 or even smaller. So I wonder if I did anything wrong or it's just that MediaPortal requires a minimum bandwidth to work?

    *EDIT*

    forgot to mention that her upload speed is about 700K.
     

    Users who are viewing this thread

    Similar threads

    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my office machine MP client. Same exact network, firewall, Defender settings. It's a slightly older version of Win 10 though - I haven't updated to 20Hx on it yet. Maybe I shouldn't (or maybe I should image it...
    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my...
    Let me start by asking if anyone has TV Server running PROPERLY on a Windows 10 machine, and if so are you using RTSP or UNC share...
    Replies
    9
    Views
    840
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM] "EnableEvents"="0" As soon as I set it back to the default value 1, TV server did no longer say port 554 is bound and TV was working. On MediaPortal 1.4.0 and earlier the reg value could be set to 0 without any problem...
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM]...
    I've described my problem here: https://forum.team-mediaportal.com/threads/satellite-tv-not-working-in-mediaportal-1-28.140530/ And...
    Replies
    1
    Views
    710
    Well it's been a couple of days and we've had no more unable to play errors .
    Well it's been a couple of days and we've had no more unable to play errors .
    I've just upgraded the motherboard, CPU, ram, boot drives and PSU in my TV Server (always on), and am now having intermittent...
    Replies
    8
    Views
    1K
    FYI: I now got TV Server running also under Windows system user while being able to write to a network share (this means without having to start the service as a different user). The reason for me trying this out was that using the "different user for service" approach, there was one minor issue where TV Service could not write to the...
    FYI: I now got TV Server running also under Windows system user while being able to write to a network share (this means without...
    Hi everybody, after recently setting up a Xen hypervisor with MediaPortal 1 TV Backend on Windows Server 2012 as a virtual machine...
    Replies
    2
    Views
    676
    Very odd. Thank you for looking. I am mystified then. If ever I find a solution I will post it. Thank you RH
    Very odd. Thank you for looking. I am mystified then. If ever I find a solution I will post it. Thank you RH
    Good evening all, I am getting an error dialog when Online Videos opens : "Error in update: "Automatic update disabled. Check your...
    Replies
    8
    Views
    729
    Top Bottom