almost perfect... still some fanart issues though (2 Viewers)

ftothe3

Portal Pro
January 13, 2008
178
17
Home Country
United States of America United States of America
Thanks for the great plugin zebons. After editing the xmls a little i think myfilms looks great now. (https://forum.team-mediaportal.com/361687-post144.html) one thing though: I have some fanart issues.

1) there's about 1s of lag in loading the fanart while scrolling through the list (i don't get lag in mytvseries)
2) sometimes if i move too fast through the list the fanart will flicker until i move to a different movie

thanks for looking into this
 

STuNZ

MP Donator
  • Premium Supporter
  • December 25, 2008
    101
    10
    Home Country
    New Zealand New Zealand
    Thanks for the great plugin zebons. After editing the xmls a little i think myfilms looks great now. (https://forum.team-mediaportal.com/361687-post144.html) one thing though: I have some fanart issues.

    1) there's about 1s of lag in loading the fanart while scrolling through the list (i don't get lag in mytvseries)
    2) sometimes if i move too fast through the list the fanart will flicker until i move to a different movie

    thanks for looking into this

    Same flickering issue here. It seems that when you scroll too fast through listed movies (in detail view) My Films seems to "sometimes" get stuck flickering between two different movie images until you move focus through the list again. THis is regardless of skin from Blue 3 wide, Aeon or StreamedMP.

    Also I find that in Filmstrip mode, focus can sometimes be returned to the right most movie of the 5 displayed rather than the centre one, when returning form a movie details screen or resuming the plugin. In this case you cannot scroll the filmstrip to the right until you move focus back to the centre movie. Only then can you scroll the filmstrip to the right again.

    That said, MyFilms is by far my preferred movie manager as it integrates with DVD Profiler exports allowing alot of flexibility to how I choose to manage my collection. Thanx Zebons
     

    ftothe3

    Portal Pro
    January 13, 2008
    178
    17
    Home Country
    United States of America United States of America
    Also I find that in Filmstrip mode, focus can sometimes be returned to the right most movie of the 5 displayed rather than the centre one, when returning form a movie details screen or resuming the plugin. In this case you cannot scroll the filmstrip to the right until you move focus back to the centre movie. Only then can you scroll the filmstrip to the right again.

    i have this issue too.
     

    doom9

    Portal Member
    April 7, 2008
    13
    11
    Home Country
    Slovakia Slovakia
    Thanks for the great plugin zebons. After editing the xmls a little i think myfilms looks great now. (https://forum.team-mediaportal.com/361687-post144.html) one thing though: I have some fanart issues.

    1) there's about 1s of lag in loading the fanart while scrolling through the list (i don't get lag in mytvseries)
    2) sometimes if i move too fast through the list the fanart will flicker until i move to a different movie

    thanks for looking into this

    I have this issue too.
    Mytvseries and Moving Pictures plugin use delay 250ms before loading new fanart image but in My Films I don't where is option to set delay and fix this problem.:(
     

    ftothe3

    Portal Pro
    January 13, 2008
    178
    17
    Home Country
    United States of America United States of America
    i was thinking since mytvseries and moving pics are open source (and both use the same code for fan art) maybe zebons could just use their code? then we'd have fanart fading too.
     

    fforde

    Community Plugin Dev
    June 7, 2007
    2,667
    1,702
    43
    Texas
    Home Country
    United States of America United States of America
    You are right ftothe3, the backdrop (fanart) logic in Moving Pictures is actually intentionally abstracted so it can be reused by other plug-ins. TV-Series already uses the enhanced backdrop logic that will be included in Moving Pictures 0.7. Zebons, if you are interested in talking about reusing some of this code, send me a PM and I can point you to the classes you would need, and how to use them.
     

    Redfuture

    Portal Member
    June 26, 2006
    14
    2
    Indiana, USA
    Home Country
    United States of America United States of America
    Same problem here:( (1 Second lag)

    I love Myfilms and all of the hard work that goes into making these plugins:)

    It is very much appreciated!!
     

    Kefner

    Portal Member
    December 13, 2007
    7
    1
    I was wondering if this had been resolved yet? I'm using 4.8.0c and I'm getting this error. Also it will crash MP after about 4 flips back and forth?

    Thanks!
     

    ftothe3

    Portal Pro
    January 13, 2008
    178
    17
    Home Country
    United States of America United States of America
    Also I find that in Filmstrip mode, focus can sometimes be returned to the right most movie of the 5 displayed rather than the centre one, when returning form a movie details screen or resuming the plugin. In this case you cannot scroll the filmstrip to the right until you move focus back to the centre movie. Only then can you scroll the filmstrip to the right again.

    i have this issue too.

    this somehow got fixed when i updated to MP 1.0.1
     

    Users who are viewing this thread

    Top Bottom