Another Problem with Playback Stopping

Discussion in 'ASIO music player' started by appleyk, March 16, 2008.

  1. appleyk

    appleyk Portal Member

    Joined:
    November 20, 2007
    Messages:
    16
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United Kingdom United Kingdom
    Hi

    I had a problem a while back with playback stopping after each song, when opened from a network drive using this plugin, using ASIO4ALL which I posted here. It was resolved by moving all music to a local USB drive. I've been having some problems with ASIO4ALL since then, like it varying the volume of songs on playback. So now ASUS have finally released some drivers that solve the ASIO not working problem on my XONAR card, I have switched to using your plugin directly configured to use the cards ASIO drivers.

    However, I now have the same problem, with playback stopping after each song. I have noticed that after hitting play on any song, it now takes a couple of seconds to start playing, which I'm assuming is something to do with the card taking a little while to respond, as all the music is still on a local drive, and doesnt have this delay when starting playback using anything other than ASIO. I also assume that from your previous comments, this delay is probably whats stopping the playback from continuing with the next song? I've attached a log in case that points to anything else. But if it is the delay thats causing th problem, is there any way of changing the default behaviour, so MP will wait a few more seconds for the song to start, before timing out?

    Any help would be much appreciated.



    Kevin
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I remember that rather mysterious problem. What you have now is even more mysterious, because the log does not show any signs of delay in opening the file.
    Remarkable is there's only 0.2 seconds between MP launching track #2 and PureAudio attempting to switch to it. This should normally be 1.5 - 2 seconds... This looks like there is delay now between track #1 ending and MP picking this up.

    What you can try is setting the playback buffersize to its max of 3 seconds (Plugin config - Advanced settings)

    Don't have an real explanation for the delays you get though...
     
  4. appleyk

    appleyk Portal Member

    Joined:
    November 20, 2007
    Messages:
    16
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United Kingdom United Kingdom
    Hi Symphy

    Thanks for the reply, even though the delays are rather mysterious, your suggestion has solved the problem. I changed the buffersize to 3 seconds from 2, and although I can see now see MP switch to the next song just before the current one finishes, the problem has gone, and playback continues from one song to the next just fine.

    Thanks again for the suggestion, and for the plugin. Although its been problematical so far, my system now sounds fantastic, and is well worth the waiting :)

    Cheers

    Kevin
     
  5. phusg

    phusg Portal Member

    Joined:
    April 1, 2008
    Messages:
    8
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Netherlands Netherlands
    Hi Symphy,

    The above solved my playback stopping problem too! I can now playback DJ mix CDs with mediaportal without the annoying gaps between tracks, many thanks.

    I have found one small disadvantage though, when I eject the CD whilst it is playing mediaportal (0.2.3) crashes, something that it does not do with just the BASS player active. If you could fix this whilst adding the feature whereby when the CD is ejected the buffer is emptied and the sound is faded out, that would be fantastic! If the buffer could also be made larger this would allow you to 'hot' change CDs, what do you think?
     
  6. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Will look into it. It should not crash.

    Interesting idea. Will see what is required to make that work. In that case the player should not stop as described above when ejecting. Will cost a few MB memory though.

    Just saw this in the changelog:
    Could this be related to the problems you are experiencing?

    Symphy
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!