Audio Codec Error on YouTube (1 Viewer)

mp_lover

MP Donator
  • Premium Supporter
  • November 8, 2009
    41
    0
    Some of the videos i try to play from Youtube are giving me Audio Codec Error and don't play them. Below is the log.
    Any idea or help would be appreciated.:D

    WindowManager: unroute to MediaPortal.Dialogs.GUIDialogOK:2002->OnlineVideos.GUIOnlineVideos:4755
    2010-01-10 16:01:21.546875 [Info.][MPMain]: Set the stopDownload to true 2
    2010-01-10 16:01:23.734375 [Info.][3]: youtube video url=http://youtube.com/get_video?video_id=ZXQfztKZ2Pg&t=&fmt=18&ext=.mp4
    2010-01-10 16:01:24.218750 [Info.][MPMain]: RefreshRateChanger.AdaptRefreshRate: 'auto refreshrate changer' disabled
    2010-01-10 16:01:24.218750 [Info.][MPMain]: g_Player.Play(http://youtube.com/get_video?video_id=ZXQfztKZ2Pg&t=&fmt=18&ext=.mp4 Video)
    2010-01-10 16:01:24.218750 [Info.][MPMain]: VideoPlayer:play http://youtube.com/get_video?video_id=ZXQfztKZ2Pg&t=&fmt=18&ext=.mp4
    2010-01-10 16:01:24.359375 [Info.][MPMain]: OnlineVideosPlayer: Enabling DX9 exclusive mode
    2010-01-10 16:01:24.359375 [Debug][MPMain]: Main: Received DX exclusive mode switch message. Fullscreen && maximized == False
    2010-01-10 16:01:24.406250 [Info.][MPMain]: VMR9: added Video Mixing Renderer 9 to graph
    2010-01-10 16:01:24.453125 [Debug][MPMain]: VMR9: SetDeinterlacePrefs()
    2010-01-10 16:01:24.453125 [Debug][MPMain]: VMR9: Enabled YUV mixing - No DX Error
    2010-01-10 16:01:24.453125 [Debug][MPMain]: VRM9: Turning on nonsquare mixing - No DX Error
    2010-01-10 16:01:24.453125 [Debug][MPMain]: VRM9: Set filter mode - None No DX Error
    2010-01-10 16:01:24.453125 [Debug][MPMain]: VMR9: Now active
    2010-01-10 16:01:24.453125 [Debug][MPMain]: VMR9: Renderer successfully added
    2010-01-10 16:01:24.453125 [Info.][MPMain]: DirectShowUtils: First try to insert new audio renderer Default DirectSound Device
    2010-01-10 16:01:24.453125 [Info.][MPMain]: DirectShowUtils: Found audio renderer
    2010-01-10 16:01:24.453125 [Debug][MPMain]: DirectShowUtils: added filter:Default DirectSound Device to graph
    2010-01-10 16:01:24.453125 [Info.][MPMain]: added filter:File Source (URL) to graph
    2010-01-10 16:01:25.218750 [Info.][MPMain]: g_Player: ended
    2010-01-10 16:01:25.218750 [Info.][MPMain]: VideoPlayer9:cleanup DShow graph
    2010-01-10 16:01:25.218750 [Debug][MPMain]: VMR9: Dispose
    2010-01-10 16:01:25.218750 [Debug][MPMain]: VMR9: Inactive
    2010-01-10 16:01:25.218750 [Info.][MPMain]: VMR9: ReleaseComObject(): 0
    2010-01-10 16:01:25.218750 [Info.][MPMain]: VideoPlayerVMR9: Exception while cleanuping DShow graph - Object reference not set to an instance of an object. at MediaPortal.Player.VideoPlayerVMR9.Cleanup()
    2010-01-10 16:01:25.218750 [Info.][MPMain]: VideoPlayerVMR9: Disabling DX9 exclusive mode
    2010-01-10 16:01:25.218750 [Debug][MPMain]: Main: Received DX exclusive mode switch message. Fullscreen && maximized == False
    2010-01-10 16:01:25.218750 [Info.][MPMain]: Updating View State
    2010-01-10 16:01:25.218750 [Debug][MPMain]: Showing Filter buttons
    2010-01-10 16:01:25.218750 [Debug][MPMain]: Hiding Search buttons
    2010-01-10 16:01:25.218750 [Debug][MPMain]: Hiding Favorite buttons
    2010-01-10 16:01:25.406250 [Debug][MPMain]: WindowManager: route OnlineVideos.GUIOnlineVideos:4755->MediaPortal.Dialogs.GUIDialogOK:2002
    2010-01-10 16:01:25.437500 [Debug][MPMain]: DialogWindow: MediaPortal.Dialogs.GUIDialogOK init

    i have SAF 2.2 and FLV splitter installed. Most of the videos are being played...
     

    DreadFury

    Portal Pro
    June 28, 2009
    252
    14
    United States of America United States of America
    this sounds like the same problem I had..

    are you SURE it says Audio Codec?

    When I get the problem with the missing 't' variable on youtube such as you are, it simply says it cannot play the video and does not mention anything about audio codec.
    Please check again and see what the error says.

    Also, have a look at this thread: https://forum.team-mediaportal.com/...dont-work-youtube-not-codec-plugin-bug-75145/

    If this turns out to be your problem, it is an issue with incorrect urls, not a codec issue. (looking at your logs, this seems to be the case)
    Supposedly the issue has been fixed and should be working in the next release.
     

    mp_lover

    MP Donator
  • Premium Supporter
  • November 8, 2009
    41
    0
    The Exact message is as below:
    "Unable to play : get_video?video_id=ZXQfztKZ2Pg&t=&fmt=1
    Audio codec:"

    but looking at the wiki you have provided i guess it is the same problem i have. It is annoying to see once in a while the Error message pop-up, would wait for 0.16 then. thanks DreadFury:D
     

    DreadFury

    Portal Pro
    June 28, 2009
    252
    14
    United States of America United States of America
    odd, I tried the URLs in your logs and indeed they were invalid, however for me I don't get the audio codec error...

    Here is hoping the new version fixes both of our issues!
     

    Sabbe

    Portal Pro
    January 7, 2007
    56
    2
    Västerås
    Sweden Sweden
    The t-bug results from Video not being available in all formats. Maybe you guys do not have the same preference in the config? I have HD choosen.
     

    DreadFury

    Portal Pro
    June 28, 2009
    252
    14
    United States of America United States of America
    I no longer get the codec error in onlinevideos.

    When I get the error now it simply says "Unable to play : get_video?video_id=XXXXX".
    This is on about 1 in 4 videos I try, from channels/feeds/searches.
    They all result in broken links in the logs.

    I have also tried all settings in the options for quality, all result in the same error for me.
    I believe all codecs are setup correctly now, so nothing left to do but wait ^^.
     

    leftfield

    MP Donator
  • Premium Supporter
  • July 23, 2008
    29
    0
    This wrong Audio Codec Error message is 99.9% caused by broken link.
    I get the error message on every video I try and play. When you say broken link, do you mean the url it's trying to got is wrong or something else?

    I've attached the log file if it helps.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A [solved] No audio on certain codecs Codecs, External Players 4
    Sebastiii [WiP] Audio delay when using LAV Audio codec Area 51 - Testing Area 6
    bta489 HEVC Video, DTSX, ATMOS, DD+ Audio Codecs Moving Pictures 14
    R Delay in audio output over HDMI OffTopic 11
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    Similar threads

























    Top Bottom