audio not synced, stutter problems when refreshrate is 24hz (1 Viewer)

anvandarnamn

Portal Pro
February 15, 2007
84
3
36
Sweden Sweden
seems like mediaportal is giving false information to the renderer (in my case EVR)
the reported framerate in the EVR properties while playing a movie in mediaportal is like 60000 or something like that, while in windows mediaplayer it is reported at 23.976 like it should be....

this makes the audio get out of sync pretty bad when outputting 24hz to my tv.
 

Snader

MP Donator
  • Premium Supporter
  • September 5, 2007
    270
    10
    Aalsmeer
    Netherlands Netherlands
    Same here... Lots of people have problems with audiosync in 24Hz mode. Always thought is was caused by the codecs used. If not, hopefully someone can fix this.
     

    Jeditrav

    Portal Pro
    May 17, 2007
    319
    20
    New Zealand New Zealand
    Hi,

    been using (well, trying to) the refresh rate changer since it's inclusion in latest svn. Everything seems to be working correctly, except 23.976fps files. These files, all .avi format, when played back with the screen changed to a 24hz refresh rate, keep getting further and further out of sync with the audio. This happens whether I use the refresh rate changer or set the refresh rate in the nVidia control panel. These files play back fine (barring the judder) when screen is set to 50hz.
    Is this a codec issue? I've been using ffdshow for .avi files.
    Any thoughts on how to deal with this issue would be greatly appreciated.:D

    I'm having this problem too - reported here

    Any progress on fixing this?
     

    anvandarnamn

    Portal Pro
    February 15, 2007
    84
    3
    36
    Sweden Sweden
    there seems to be a bug in mediaportal as a lot of people is having problems with 23,976 material playing at the correct hz

    seems like mediaportal is giving false information to the renderer (EVR)
    the reported framerate in the EVR properties while playing a movie in mediaportal is like 60000 (should be 23.976) or something like that, when playing the same file in windows mediaplayer it is reported at 23.976 like it should be....


    so theres certainly a bug in mediaportal preventing the EVR renderer to retreive the correct framerate.
    Oddly enough there is no sync problem while keeping your refreshrate at 60hz, but mediaportal still gives the incorrect framerate though...

    please, anyone? i know alot of people are having this issue (Everyone using the EVR as the renderer)
     

    Snader

    MP Donator
  • Premium Supporter
  • September 5, 2007
    270
    10
    Aalsmeer
    Netherlands Netherlands
    post your 24p content out of sync problems here.

    TV-Server Version: 1.0
    MediaPortal Version: 1.0
    MediaPortal Skin: Blue 3, StreamedMP, doesn't mather really
    Windows Version: Windows VISTA all updates
    CPU Type: AMD CPU Athlon 64 X2 5700
    HDD: Samsung SpinPoint F1 1 TB, 7200 Rpm, 32 MB, S-ATA II/300 Memory: GeIL Black Dragon Dual Channel 2 GB, PC6400, 800 MHz, 4, Kit Of 2
    Motherboard: GIGABYTE GA-MA78GM-S2H
    Video Card: IGP ATI HD3200
    Video Card Driver: 8.7
    Sound Card: Integrated
    Sound Card AC3: Integrated
    MPEG2 Video Codec: Cyberlink PowerDVD 8
    MPEG2 Audio Codec: AC3Filter
    h.264 Video Codec: CoreAVC, MPC, tried several, same problem with all.
    TV Card: FlopptyDTV 2x
    Renderer: EVR

    Fellow MP users; a lot of you are having these troubles with 24p content in this wonderfull software! ; me too! Problem for the developers is that there are about 10 threads about this problem everywhere in the MP forums. Please use this topic to show the developers that this is really a problem which should not be forgotten.

    I myself have problems with a/v sync in all 24p content I have (not much though); but only in mediaportal. Tried several other mediaplayers and the problem does not occur in those. I also succesfully have produced exactly the same findings as the guy in this post did. I have done a couple of installations since the refresh rate changer arrived. Since then i was able to put my TV in 24p mode; it is since then that this problem could be noticed! Several installations of vista have passed; with all I experimented a lot with codecs and media files. In all installations I had the problem of a/v being out of sync in 24p mode showing 24p footage.
     

    anvandarnamn

    Portal Pro
    February 15, 2007
    84
    3
    36
    Sweden Sweden
    Ok here we go again :)

    have also got problems with A/V Sync playing 24p material at 24hz




    MediaPortal Version: 1.0 / 1.01SVN
    MediaPortal Skin: Any ;-)
    Windows Version: Windows VISTA x64 , x32 .all updates . latest directx.
    CPU Type: Intel Q6600 (quad core 3,01Ghz)
    HDD: 4x Samsung SpinPoint F1 1 TB, 7200 Rpm, 32 MB, S-ATA II/300 Memory: Corsair Dual Channel 4 GB, PC6400, 800 MHz
    Motherboard: Asus p5n7a (geforce 9400) and a intel G35
    Video Card: have tested Nvidia geforce 9400, ATI Radeon 4670
    Video Card Driver: ? / 9.1
    Sound Card: HDMI AUDIO
    Sound Card AC3: HDMI
    MPEG2 Video Codec:
    MPEG2 Audio Codec:
    h.264 Video Codec: tried PDVD8, PDVD 7, FFDSHOW, ARCSOFT.

    Renderer: EVR / (get a blank screen from vmr9)
    TV/DISPLAY: Pioneer plasma 6090.

    everything is working as it should with any other player except mediaportals internal ...:mad:

    After some extended testing i have come up with a temp. solution:

    with FFDSHOW audio decoder the sync is OK (not perfect) . But as soon as you start to use SPDIF-out or any other audio-decoder the audio/video sync problem will occur again.

    as the audiophile i am ;-), I have stored all my Bluray-audio as FLAC.
    To decode the flac, the best codec currently is MADFLAC. (FFDSHOW does not properly play 24bit audio)

    so at the moment (ihope ;)) im stuck with ffdshow without spdif-out or 24bit audio, but on the other hand silky smooth Video output at 1080p24 without any significant Audio-delay.

    I am still certain this problem is because mediaportal feeds the evr renderer with the wrong fps info.
    i really hope this problem will get the attention it deserves and will be sorted out over time (wish i had the programming skills)

    clearly mediaportal is the problem ( still the best HTPC software ever made though :p) as every other directshowplayer manages to get the AV synced without the need for FFDSHOW-audio


    EDIT: The audio is NOT in sync with ffdshow audio decoder, back to square one again :-(
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Please post some 24fps files that can be used to trigger the issue (few minute samples are enough).
     

    anvandarnamn

    Portal Pro
    February 15, 2007
    84
    3
    36
    Sweden Sweden
    Please post some 24fps files that can be used to trigger the issue (few minute samples are enough).
    no problem, but any 23.976/24fps material will do. Remember, there is no audio sync problems when refreshrate is 60hz

    here is a x264 file with DTS audio: SAMPLE
     

    Snader

    MP Donator
  • Premium Supporter
  • September 5, 2007
    270
    10
    Aalsmeer
    Netherlands Netherlands
    The sample you supplied doesn't play here at all in Mplayer. It plays in MP but not in sync. When skipping back the sample simple seemed paused; only a stop on my remote helped.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    A Audio sync problems on LAV filters 1.21 Pre Release 31
    B PC not waking from sleep and TV (only) audio out of sync with new TCL 4K TV Watch / Listen Media 5
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    T Moving Pictures...seem to have 'lost' ability to display Movie info. (eg Resolution/Audio) Moving Pictures 2
    Similar threads

























    Top Bottom