Autoplay screen pops up no matter what (1 Viewer)


Portal Member
January 16, 2008
TV-Server Version: non
MediaPortal Version: 1.0
MediaPortal Skin: Blue3Wide
Windows Version: Vista 64 Ultimate
CPU Type: Quad 6600
HDD: 4x1TB Hitachi
Memory: 4GB OCZ Reaper
Motherboard: Intel DP35
Video Card: Evga 8600GT
Video Card Driver: Latest WCHL
Sound Card: Auzentech Xplosion 7.1

OK... reinstalled 1.0 after having issues. Got it to work as it should, with one annoying problem. Everytime an ISO file is loaded in Daemon Tools, the autoplay window pops up in MediaPortal stating there is a disk in the drive, and asks if I'd like to open it. I found the autoplay option in the DVD setup area (i think it was DVD?), and no matter what option I choose - take no action, ask for action or automatically load, it always pops up with this screen. If I ignore it, the ISO movie loads and plays in MediaTheater without a problem, but the popup window is waiting for me after the movie is done and MediaTheater window closes.

What did I miss?

Paranoid Delusion

Moderation Manager
  • Premium Supporter
  • June 13, 2005
    Home Country
    United Kingdom United Kingdom
    You sure its not windows autoplay you are seeing, if so go to control panel\autoplay and select no action for your cd\dvd drives.


    Portal Member
    January 16, 2008
    I seriously doubt it is Windows' popup... this happened before I had MediaTheater, when there was no autoplay option for HD DVD or BluRay. That was the whole reason I bought MediaTheater, since it was better integrated with Windows. When it happened before, I had the settings set to "do nothing" and yet I still got this screen. However, since then I have them set to use MediaTheater, so I'll try playing with those again.

    Using Daemon Tools 4.30.3
    ISO's made with IMGBURN
    MediaTheater x.128
    moving picture .65 or MyFilms 4.79a

    Ok... did some testing. OUTSIDE of MediaPortal, all works as it should. All ISO's load and autoplay accordingly, and no screens pop up asking what to do. In the Vista autoplay control panel I have all set to what I want... either start this program or that one, or do nothing. For all movie/video content, MediaTheater is the option and it works as it should.

    INSIDE MediaPortal, after loading the ISO I get a popup window asking if I want to open the inserted disk. Yes opens the disk in the videos window, showing the files and folders of the disk. No closes the window and nothing else happens. IF YOU IGNORE the popup, MediaTheater will still launch and play the movie. But if you click on the screen before the movie starts, then the MediaTheater window will be behind MediaPortal and you won't know it's there until the sound starts.

    All options in MediaPortal are correct, as far as I can tell. The DVD option for autoplay has been tested with all three options - do nothing, ask and autoplay. I've tried the Daemon Tools option of ASk Before Autoloading with no change.

    This was not an issue in .2.3.0! It only started once I updated to 1.0. Otherwise everything on my system is the same as it was with .2.3.0

    It's not horrible, but it is annoying and I can see the wife clicking NO then not seeing MediaTheater loading up behind the main MediaPortal window. Then I'll get a phone call at work asking why I screwed everything up! :mad:

    I'm reverting back to .2.3.0 unless someone has a magical fix. I even looked thru the config XML file and the autoplay option for DVD's was in fact set to no.


    Tried disabling the Videos section plugin... same problem happens.

    Users who are viewing this thread

    Top Bottom