Bad colors in video playback (1 Viewer)

mps279

New Member
January 9, 2006
3
0
rea: Media Portal Program
MediaPortal Version: 0.2.0.0 RC1 (2005-09-01)
MediaPortal Skin: BlueTwo
Windows Version: Windows XP Professional SP2
.NET CLR Version: 2.0.50727
DirectX Version: 4.09.00.0904 (9.0c)
Audio Codec: AC3Filter
Video Codec: Mpeg2Dec Filter
CPU Type: Pentium 4 2.4GHz (Rev. A)
Memory: 512MB
TV Card Model: Hauppauge PVR250
TV Card Type: Hardware
TV Card Driver: Driver Release 2.0.35.23258.PreRelease (09/15/05)
Video Card Model: ATI AIW Radeon 8500DV
Video Card Driver: Latest Catalyst
Video Card Resolution: 800x600
Video Render Type: VMR7
Audio Card Model: Creative Soundblaster Live

Regardless of the video codec I use, and regardless of the render type (VMR7/9) all video playback (TV, recorded video, DVD) is tinted incorrectly, and the tint changes noticibly and rapidly. I can play back the same video (or access the capture card for TV) in media player classic and VLC and have no trouble. I gave up trying to get it to work for video and DVDs so I just replaced the player with MPC which fixed that issue, but of course that won't work for recording or watching TV. I assume people have had this issue before but I simply can't find any reference to it. Any thoughts? Thanks.
 

FlipGer

Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    47
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    this is a known issue of the Radeon 8500 (have it also). The graphics card does not work correct if the colorspace is set to YUV. You have to set it to RGB. This can only be done in the codec / filter settings:

    - MPEG2Dec (TV, DVD, MPEG playback)
    Setup (MP)->Filters->MPEG2Dec
    * Uncheck YUV output

    - ffdshow (if used for AVI playback)
    Start->Programs->ffdshow->Settings
    * Select the output-tab and uncheck all YUV. Just keep eg. RGB32

    HTH, Flip.
     

    Users who are viewing this thread

    Top Bottom