BlackGold BGT3620 DVB-T2 card - Where are the HD channels? (2 Viewers)

allanp81

Portal Pro
October 24, 2006
917
41
Hmm I'm sure that the CPU was at 2-3% when on the HD channel.
I think the CPU on its own could handle 1080i content maybe I could turn off hardware decode and see. Thing is my system plays back high bitrate 1080p stuff with no problems

I also have the same problems on my gaming rig with i7920 and 295gtx!

As far as I'm aware, there is no hardware decoding when using 1080i material. 1080p will be fine but apparently Microsoft didn't include 1080i DXVA acceleration.
 

Alphathon

Portal Pro
July 15, 2010
64
8
Home Country
Scotland Scotland
The EPG grabbing shouldn't really make any difference unless the host computer is significantly lacking in RAM or CPU or something, and it isn't something that is done constantly anyway. Is there any particular reason you're wanting to try the PowerDVD codecs?

Honestly I don't think the issue is codec related anyway if it's "shut down" channels that cause the problem; it could conceivably be an innate problem with MP, or something to do with how your tuner/driver handles "empty" streams. As I understand it, the video/audio decoding occurs when a stream which uses that type of encoding is detected (hence why switching between HD and SD channels works despite the different codecs). For "shut down" channels there generally isn't a video or audio stream (although often there is an MHEG stream which on set-top-boxes display a "this channel is shut down" message, but that's not related to the video/audio codecs and MP doesn't support MHEG anyway), so no codec is used.

EDIT: Also, the fact that you are having the same issue on two different clients certainly suggests that it could be something server-side.
 

Bucky O'Hare

Portal Member
April 24, 2008
35
2
Home Country
United Kingdom United Kingdom
Power DVD 11 is the only codec I know that supports the Intel Core i CPU's for hardware video decoding the LAV one doesn't at the moment. I would use PowerDVD for the x264 codec for live TV and LAV for the LiveTV ACC LATM/LOAS codec.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Hi m0t0k0

    I find if I flick to a channel which is currently closed down MePo is freezes and is unresponsive for 10 seconds
    Unfortunately this is normal right now - TV Server is not able to detect that the channel is off air. You should be able to reduce the delay by reducing the "wait for timeshifting file" setting in the "timeshifting" section of TV Server configuration. A value as low as 2 or 3 seconds may be safe but trial and error will be required. We hope to fix detection of off air channels properly in the future but right at the moment there is just too much other stuff to do.

    I now use a updated version of the TsWriter.ax file which fixed the HD epg problems but do you think my system may be more responsive/stable using a third party downloaded epg?
    No.

    mm
     

    m0t0k0

    Portal Pro
    November 25, 2010
    108
    9
    Bicester
    Home Country
    United Kingdom United Kingdom
    Power DVD 11 is the only codec I know that supports the Intel Core i CPU's for hardware video decoding the LAV one doesn't at the moment. I would use PowerDVD for the x264 codec for live TV and LAV for the LiveTV ACC LATM/LOAS codec.

    The audio is fine just the vid people have reported success with this video codec I just dont know how to get a copy of it. Can I liberate a copy of it from the free trial?
     

    Bucky O'Hare

    Portal Member
    April 24, 2008
    35
    2
    Home Country
    United Kingdom United Kingdom
    Power DVD 11 is the only codec I know that supports the Intel Core i CPU's for hardware video decoding the LAV one doesn't at the moment. I would use PowerDVD for the x264 codec for live TV and LAV for the LiveTV ACC LATM/LOAS codec.

    The audio is fine just the vid people have reported success with this video codec I just dont know how to get a copy of it. Can I liberate a copy of it from the free trial?


    I think Shark007 codec pack has PowerDVD11 and an unlocked version of SAF may have it as well not looked at it for a while so not to sure.
     

    m0t0k0

    Portal Pro
    November 25, 2010
    108
    9
    Bicester
    Home Country
    United Kingdom United Kingdom
    OK so I tried installing the PowerDVD11 trial but this still did not give me the ability to select PDVD11 for TV.

    So tried uninstalling Power DVD and then registering the 2 codecs in system32 using regsvr32 filename.ax but it would not work

    Installed Shark007 this gave me the ability to use PDVD11 I did a quick couple minutes test and video seemed much smoother no artifacting and the occasional freeze

    I decided to use graphedit to see if it was correctly being selected and as such had to register the propage.dll which if found worked by placing it in the system folder not system32

    But as shark007 installed so much other codecs and crud on my system I decided to remove it (this deleted LAV from my system as well as it is included in the pack as well)

    So reinstalled LAV registered the PDVD1 codecs selected them in MePo and played HD TV
    But I'm back to where is was before its all blocky

    Ran graphedit which confirms MS codec is being used again for vid.

    So I think PDVD11 will not completely fix my problems but will go a good way in that direction, but not I have borked my system by installing shark007 and Power DVD 11.

    I think I will either have to try forcing PDVD11 via filter tweaker or do a fresh install
    I would try just registering the PDVD11 codecs on my other machine but its not accessible right now as I'm building a desk

    When searching the forum for entries about continuity errors I found this thread
    https://forum.team-mediaportal.com/...stuttering-corrupted-streaming-live-tv-91214/

    From reading it sounded really hopeful but right near the end it is said that the patch is included in 1.2.0 beta

    I assume it means that the build I'm using 1.2.2 should already have this implemented?
     

    m0t0k0

    Portal Pro
    November 25, 2010
    108
    9
    Bicester
    Home Country
    United Kingdom United Kingdom
    I would say yes as I'm getting the same problems on two clients one running i3 2100 HD2000 and one with i7 920 with 295GTX

    I do have a huge check list of things to try tonight which I wave written up from browsing these forums

    fresh MePo server/client install
    sorting my codecs (I have not installed any codecs on the server as there is no need for this? Its not playing any media just streaming)
    Trying a RAMdisk
    make tvservice.exe a scanning exception
    make streaming/recording folders a scanning exception
    check .ts files are a scanning exception
    edit TV card properties to "stop" not "pause" card
    Tryin not using RSTP for streaming TV
    Record a show and play it back in another player
     

    Owlsroost

    Retired Team Member
  • Premium Supporter
  • October 28, 2008
    5,540
    5,038
    Cambridge
    Home Country
    United Kingdom United Kingdom
    I would say yes as I'm getting the same problems on two clients one running i3 2100 HD2000 and one with i7 920 with 295GTX

    I do have a huge check list of things to try tonight which I wave written up from browsing these forums

    fresh MePo server/client install
    sorting my codecs (I have not installed any codecs on the server as there is no need for this? Its not playing any media just streaming)
    Trying a RAMdisk
    make tvservice.exe a scanning exception
    make streaming/recording folders a scanning exception
    check .ts files are a scanning exception
    edit TV card properties to "stop" not "pause" card
    Tryin not using RSTP for streaming TV
    Record a show and play it back in another player

    You could also try using UNC paths (instead of RTSP) for TV - see https://forum.team-mediaportal.com/general-support-51/tvplugin-avoiding-rtsp-multiseat-mode-test-plz-36735/index27.html#post809720 (this changes the client config - the server is unchanged)

    Tony
     

    Users who are viewing this thread

    Top Bottom