BUG? Importing deletes all local filenames on EVERY episode. Update, happened again. (1 Viewer)

Tibbs

New Member
August 14, 2010
3
0
I have some issues with imports.
Sometime, when I do a new import, it doesn't come up any new episodes in the import list, even if I just added a few new files in my scanned dirs.
After that, I try again, same result.
But when I go to "details", all info on local files are gone, and all episodes are greyed out.
As you can see from the attached screenshot, "Local Filename" is empty. And if you see in the log (Got SQL logging turned on), you can see that the importer executed a SQL that dropped that episode from the table "local_episodes".
The SQL was executed for every episode I had, 447 of them.
Now I have to remove everything again from database, and import all 447 episodes again.
This have happened about 5-6 times the last month. That's why I had SQL loggning turned on.
Also attached a zip with my log, from when this happened.

I think I did it in this order:
1. Copied 3 new episodes into the right directories.
2. Started config tool
3. Open import tab, clicked "start import wizard". Realized that it didn't get any hits on the 3 new files.
4. Clicked "cancel".
5. Clicked "start import wizard" again. Realized I got 0 hits again.
6. Did NOT click cancel, but clicked on the tab "Details".
7. Everything is gone.

I don't know during which step the SQL for deleting was run.
But hopefully, the logs can tell you that.

Version 2.6.0.1157
Build 2010-07-24 12:01:44 GMT

Regards
Tibbs
 

Attachments

Tibbs

New Member
August 14, 2010
3
0
Re: Problems with importing, deleting all local filenames.

It is possible that I clicked next and finished the import, even if I had 0 hits on new episodes, the second time I tried to import new episodes.
 

Tibbs

New Member
August 14, 2010
3
0
Re: Importing deletes all local filenames on EVERY episode

It is happening again.
At the moment, when I press "Start Import Wizard", the list turns up empty, even if I've added several new episodes to the scanned directories. It doesn't matter if I restart or anything. The list turns up empty.

I've now taken a backup of "TVSeriesDatabase4.db3", where I now think the problem lies.
I haven't changed any settings or anything. The only thing I ever do is to import new episodes.

Now I have tested it.
First I pressed "Start Import Wizard"
The list turns up empty for some unknown reason, but I think it's in the database or the software or both.
Once I press "Next" after that, it deletes "Local FileName" on EVERY episode.


I've attached a copy of my datasbase this time. It's in a state where you can just go to import and start the wizard.
Every TV-serie is stored under the path "X:\TV-series", like "X:\TV-series\Dexter", "X:\TV-series\Criminal Minds".
X:\ is the harddrive on my NAS. I've made sure the drive is not "sleeping" when I try this. I tested to run an episode from it before I started the wizard, just to make sure.

I have now restored the database from the backup.
I still get no hits on import wizard, but atleast I have every Local FileName still.

Everytime this happens, I need to delete every episode and start all over again. Extremely annoying.

I hope it'll get some attention now, from the developers.
 

Attachments

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
R Bug: Video Folders disappear General Support 11
catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
framug [Approved] Fix Irtrans config bug Submit: code patches (MediaPortal/TV-Server/etc.) 4
ge2301 Bugs and Improvements Nereus 6
N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
Scheibes [solved] Kategorisierung der Genres (Bug?) Allgemeines Support- und Diskussionsforum 13
joecrow 3 Bugs in MP 1.21 1.21 5
dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
rsbrux Various bugs, some Zombies ;-) 1.20 6
J [solved] Mp 2.2 future bugs General 7
S [MP2-768] Installation Setup Failed - Error 0x80070666 - VC++ 2015/2017 Redist bug 2.2 Archive 19
D MP2.2: Possible bugs 2.2 Archive 20
R Jira bug exposed private server keys at major companies Developer Discussions 1
R Minor bug in recorded TV list Watch / Listen Media 0
P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
L TV-Series unvollständiger Import Plugins & Erweiterungen 5
toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
Lichloathe MP2 importing keyart instead of poster General 0
P Recordings not showing up unless re-imported and not possible to delete General 0
C Importer works super slow My TVSeries 5
C Imported media doesn't show up immediately? General 1
X Recording import hängt Allgemeines Support- und Diskussionsforum 0
J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
B xmltv - cannot import tvguide.xml australia Installation, configuration support 0
B [solved] tvguide.xml not importing australian channels Electronic Program Guide 10
Top Bottom