Cant start TV-server (1 Viewer)

seul48

Portal Member
July 8, 2011
5
0
33
Kaunas
Hello everyone, I'm just getting really frustrated right here, hope that someone can help me with this. The problem is, that i can not even start TV-server. I'm getting this error "connection failed! unable to connect to any of the specified MySQL hosts"
http://s1.postimage.org/u80fr4r0d/mediaportal_error.jpg
I tried uninstall/install everything several times, but nothing changes...

MediaPortal Version: 1.1.3
MediaPortal Skin: default
Windows Version: Windows 7 Ultimate 64bit
CPU Type: AMD Phenom(tm) II X 545 Processor 3.01 GHz
HDD: 500GB
Memory: 4.00GB RAM
Video Card: NVIDIA GeForce 9500 GT
Video Card Driver: 8.17.12.6724
1. TV Card: AverMedia A16D PCI Hybrid DVB-T
1. TV Card Type: analog, DVB-T
1. TV Card Driver: 3.6.64.9
Remote: AverMedia RM-HV
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi seul48

    Welcome aboard! :)
    I'm not sure what error you're talking about - you don't seem to say. Can you please post your TV Server logs (as required by support forum rules) otherwise I'm afraid we have no way to know what the problem is so we can't help. You can use option 3 in the watchdog (information in our wiki -->here<--) on a single seat installation, otherwise just zip up the log directory (Windows 7: C:\ProgramData\Team MediaPortal\MediaPortal TV Server\log).

    mm
     

    seul48

    Portal Member
    July 8, 2011
    5
    0
    33
    Kaunas
    Thank you guys for your replies...

    Hi seul48

    Welcome aboard! :)
    I'm not sure what error you're talking about - you don't seem to say. Can you please post your TV Server logs (as required by support forum rules) otherwise I'm afraid we have no way to know what the problem is so we can't help. You can use option 3 in the watchdog (information in our wiki -->here<--) on a single seat installation, otherwise just zip up the log directory (Windows 7: C:\ProgramData\Team MediaPortal\MediaPortal TV Server\log).

    mm
    I have edited my first post. The error i'm getting is "connection failed! unable to connect to any of the specified MySQL hosts". There is a screenshot of it http://s1.postimage.org/u80fr4r0d/mediaportal_error.jpg Also i have attached zipped log directory

    Is your MySQL service running?
    Yes.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi seul48

    It looks like TV Server is trying to connect to an SQL Server, not a MySQL server:

    Gentle.Common.GentleException: The database backend (provider SQLServer) could not be reached.
    Check the connection string: Password=;Persist Security Info=True;User ID=sa;Initial Catalog=MpTvDb;Data Source=; ---> System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
    at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
    at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
    at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
    at System.Data.SqlClient.SqlConnection.Open()
    at Gentle.Provider.SQLServer.SQLServerProvider.GetConnection()
    --- End of inner exception stack trace ---
    at Gentle.Common.Check.FailWith(Severity severity, Error error, Exception e, String msg)
    at Gentle.Common.Check.Fail(Exception e, Error error, Object[] args)
    at Gentle.Provider.SQLServer.SQL92Analyzer.Analyze(String tableName)
    at Gentle.Provider.SQLServer.SQLServerAnalyzer.Analyze(String tableName)
    at Gentle.Framework.GentleAnalyzer.UpdateObjectMap(ObjectMap map)
    at Gentle.Framework.ObjectFactory.ConstructMap(PersistenceBroker broker, Type type)
    at Gentle.Framework.ObjectFactory.GetMap(PersistenceBroker broker, Type type)
    at Gentle.Framework.SqlBuilder..ctor(IGentleProvider provider, StatementType stmtType, Type type, LogicalOperator logicalOperator)
    at Gentle.Framework.SqlBuilder..ctor(StatementType stmtType, Type type)
    at TvDatabase.TvBusinessLayer.GetSetting(String tagName, String defaultValue)
    at TvLibrary.Implementations.TvCardCollection..ctor(IEpgEvents epgEvents)
    at TvService.TVController.InitController()System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
    at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
    at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
    at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
    at System.Data.SqlClient.SqlConnection.Open()
    at Gentle.Provider.SQLServer.SQLServerProvider.GetConnection()
    at Gentle.Common.Check.FailWith(Severity severity, Error error, Exception e, String msg)
    at Gentle.Common.Check.Fail(Exception e, Error error, Object[] args)
    at Gentle.Provider.SQLServer.SQL92Analyzer.Analyze(String tableName)
    at Gentle.Provider.SQLServer.SQLServerAnalyzer.Analyze(String tableName)
    at Gentle.Framework.GentleAnalyzer.UpdateObjectMap(ObjectMap map)
    at Gentle.Framework.ObjectFactory.ConstructMap(PersistenceBroker broker, Type type)
    at Gentle.Framework.ObjectFactory.GetMap(PersistenceBroker broker, Type type)
    at Gentle.Framework.SqlBuilder..ctor(IGentleProvider provider, StatementType stmtType, Type type, LogicalOperator logicalOperator)
    at Gentle.Framework.SqlBuilder..ctor(StatementType stmtType, Type type)
    at TvDatabase.TvBusinessLayer.GetSetting(String tagName, String defaultValue)
    at TvLibrary.Implementations.TvCardCollection..ctor(IEpgEvents epgEvents)
    at TvService.TVController.InitController()
    Open up the Gentle.config file from your TV Server installation folder in a text editor like notepad and search for the section that looks like this:

    <DefaultProvider name="XXXXX" connectionString="Server=XXXXXXX;Database=XXXXXX;User ID=XXXXXX;Password=XXXXXXX;charset=utf8;Connection Timeout=300;" />
    <!--
    <DefaultProvider name="Firebird" connectionString="User=SYSDBA;Password=masterkey;Data Source=TvLibrary.fdb;ServerType=1;Charset=UNICODE_FSS;" />
    <DefaultProvider name="Jet" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Code\Gentle.NET\Source\Gentle.Framework.Tests\Database Files\Gentle_MSAccess.mdb;OLE DB Services=-1;" />
    <DefaultProvider name="MySQL" connectionString="Server=10.0.0.2;Database=test;User ID=xxx;Password=xxx" />
    <DefaultProvider name="PostgreSQL" connectionString="Server=10.0.0.2;Database=Test;User ID=xxx;Password=xxx" />
    <DefaultProvider name="Oracle" connectionString="Data Source=kermit.symbiote.sporadicism.com,1521;User ID=gentle;password=xxx" />
    <DefaultProvider name="OracleODP" connectionString="Data Source=kermit.symbiote.sporadicism.com,1521;User ID=gentle;password=xxx" />
    <DefaultProvider name="SQLite" connectionString="URI=file:c:/Code/Gentle.NET/Source/Gentle.Framework.Tests/Database Files/Gentle_SQLite.db" />
    <DefaultProvider name="SQLServer" connectionString="data source=127.0.0.1;initial catalog=Test;user id=xxx;password=xxx;packet size=4096" />
    -->
    You need to set the first line as follows:

    <DefaultProvider name="MySQL" connectionString="Server=DatabaseHostServer;Database=MpTvDb;User ID=MediaPortal;Password=MediaPortal;charset=utf8;Connection Timeout=300;" />
    DatabaseHostServer is the name of the computer running the MySQL server.
    Database is the name of the database, which is MpTvDb by default.
    I *think* the default User ID and password is MediaPortal.

    So make those changes according to your local setup, then save the file. After that try to start TV Server...

    mm
     

    Marvman

    Retired Team Member
  • Premium Supporter
  • November 14, 2007
    1,163
    735
    Bavaria
    Germany Germany
    Try to enter the IP of the PC where the mySQL server is running. Check your firewall setting regarding your ports.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Ahhh, thought I might have picked the wrong username - MediaPortal is the DB user account in my [multi-purpose] DB. :sorry:

    Yes, I know. I tried root as MySQL user as well... Didn't work either.
    And I guess you know about the case sensitive nature of the password...
    Was there any noticeable change in the symptoms? I think we should probably check your logs again to see what is happening now.

    mm
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A [solved] Cant see all recorded programs General 9
    G MP 1.21 TVserver race condition when cant delete recording triggered by episode management General Support 0
    craige1 MP2 - V2.1 Cant Install Older releases 12
    D Getting Started General Support 30
    horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 21
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    ajs Trakt error when start with MP crash Trakt 1
    F Recording starts at second time only MediaPortal 1 Talk 6
    tano_grasa Movie cover not showing when starting a movie aMPed 0
    ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
    joecrow AMD Radeon Settings app. won't start after hibernation. General Support 0
    Icaro Close MP when the external player is started General Support 13
    M MP1 stops responding after Starting Plugins General Support 14
    joecool70 Fehlermeldung Error invoking action "Start Timeshift" Allgemeines Support- und Diskussionsforum 1
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
    T MP bricht Videos und Serien beim Start ab. Allgemeines Supportforum 4
    D Enhance "wake on lan" feature (on demand, not on start) Feature Requests 6
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    K How to start Chrome or other programs MediaPortal 1 Talk 41
    R How to I get started with MP2? General 1
    squidina [solved] - MediaPortal 1.22 won't start even with new install General Support 4
    Similar threads

























    Top Bottom