Comskip 0.79 build 41: Many improvements (1 Viewer)

erik1958

Portal Pro
January 28, 2006
100
7
Many improvements

From the changelog

Changes in 0.79.41
- It is again possible to select the video pid in a TS file with --pid=xx where xx is pid of the video stream, all input and reporting on pid's is done in hexadecimal format. The Audio pid will be autoselected
- Bug solved: When a video stream has two audio streams (such as stereo and 5.1) the audio decoding will fail with all kind of error messages.
Changes in 0.79.40
- Added parameter: punish_no_logo, default is 1, if set to punish_no_logo=0 then the absence of logo is not punished towards commercial.
- Added parameters: validate_xxx, default is 1, if set to validate_xxx=0 then the validity of cut points coming from volume, scenechange and uniform will not be assessed
- Bug solved: Certain AC3 formats not recognized leading to many "Audio PTS jumped" messages
Changes in 0.79.39
- Added MPeg Video Wizard bookmark file output, set output_mls=1
- Corrected an error in the dvrcut_options parameter
- Bug solved: Sometimes a 0:0:0 0:0:0 show segment is generated causing DVRCut to crash
- Certain AC3 formats are NOT recognized, this is indicated by many many "Audio PTS jumped" messages in the log file.
- Bug solved: sage_minute_bug solution always rounds down instead of up or down.
Changes in 0.79.38
- Added parameter: Setting sage_minute_bug=1 in the ini file will correct the frame numbers in the .txt file in a sage specific way.
Changes in 0.79.37
- Added parameter: drvcut_options to set the way the dvrcut .bat file is being generated. The default allows for direct execution without any parameters
- Bug solved: No audio decoded with AC3 in MPEG PS files.
- Bug solved: AC3 audio decoding unreliable
Changes in 0.79.36
- Added ini parameter, setting output_dvrcut=1 will enable the generation of the bat file that can run the commandline dvr-ms cutter to generate a clean dvr-ms file. You need dvrcut.zip for this
Changes in 0.79.35
- Bug solved: Commercial frame numbers found on dvr-ms files with logo where completely wrong.
- Bug solved: There is a difference in results when processing an mpeg or the corresponding .csv
Changes in 0.79.34
- Added the proposed cutlistformat for TVersity, enable with output_edlx=1. Warning: This output only is available correctly when scanning the video file, not when editing the cutpoints or processing the .csv file.
- Added ini parameter sage_framenumber_bug=1 to halve the .txt file frame numbers when 720p/60fps content is detected.
- Changed logic when enabling both SILENCE and other detection methods to become more robust against input variations over broadcasting styles.
- Warning: Some changes did have the risk of slightly less quality in detection. Notify me when you detect this.
Changes in 0.79.33
- Added ini parameter max_repair_size=40 controls the maximum jump in frames of the PTS still to be repaired
- Bug solved: Restarting after logo found does not restart the demux output.
 

ASiDiE

Retired Team Member
  • Premium Supporter
  • January 14, 2005
    902
    5
    USA
    Damn... looks like you have been working really hard on this... Keep up the good work!
     

    martyyn

    Portal Pro
    November 5, 2005
    99
    0
    Wellington, New Zealand
    Erik,

    Id like to thank you aswell for your efforts on this. I havent used Comskip for a couple of weeks now because by the time I get to play with youve made more changes :D

    Im really looking forward to seeing this integrated into MP if thats possible.

    Cheers
    Martyn
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    B Comskip quit running after recording finishes. Skins and Plugins Installer (MPEI) 1
    O Can't browse network share on new build Newcomers Forum 1
    M General TVE 3.5 VS2019 - build discussion TV Engine 50
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24-1.26 Pre Release 89
    doskabouter Build errors MediaPortal 1 9
    doskabouter Building TVPlugins MediaPortal 1 17
    vapourEyes Building TV Plugin General Development (no feature request here!) 49
    wizard123 [solved] MP1 Build help MediaPortal 1 21
    morpheus_xx Test builds of MP2.3 WiP, x64, Nereus and more... MediaPortal 2 44
    T No TV after updating Windows 10 to latest Version 1903 / OS build 18362.175 (logs attached) General Support 2
    N [Question] How come when I build WIP_2.2.1 the logged version number is 2.1.1711.10774? MediaPortal 2 1
    N [Question] Build troubles MediaPortal 2 6
    Stéphane Lenclud [fixed] Core DLL not building from Visual Studio MediaPortal 1 2
    J Clock speed vs multi-core CPU's Can MediaPortal benefit from multi core cpu's? General 0
    J Recorded TV to NAS no longer working after Windows build 1803 1.19 6
    azzuro [WiP] MP1-4999 - Big changes with many related change at once by Sebastiii MediaPortal 1 22
    fredco [solved] Large import not working Moving Pictures 15
    Top Bottom