Configured decoders not applied. MP uses filters based on DS merit. (1 Viewer)


Portal Pro
June 5, 2008
Home Country
Finland Finland
TV-Server Version: 1.0final
MediaPortal Version: 1.0final
MediaPortal Skin: Indigo
Windows Version: XP SP3
CPU Type: AMD Athlon X2 4200+
HDD: WD 500 GB SATA + 2TB Linkstation over ethernet
Memory: 2GB DDR 800
Motherboard: Gigabyte GA-MA78GM-S2H
Video Card: integrated HD3200
Video Card Driver: Catalyst 8.12
Sound Card:
Sound Card AC3:
Sound Card Driver:
1. TV Card: Some USB stick (AF9015 BDA Device)
1. TV Card Type: DVB-T
1. TV Card Driver:
2. TV Card: Some USB stick (AF9015 BDA Device)
2. TV Card Type: DVB-T
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: ATI AVIVO MPEG decoder
MPEG2 Audio Codec: FFDSHOW
h.264 Video Codec: FFDSHOW
Satelite/CableTV Provider:
HTPC Case:
Power Supply:
Remote: MCE remote
TV: Samsung M87 40"
TV - HTPC Connection: HDMI

A while ago I had a working solution for sending audio to my TV or to my amplifier depending what I want.
When I want to send audio over HDMI to my TV, I was using AC3Filter (compress dynamic range + downmix to stereo).
When I wanted to use my AMP, I would use FFDSHOW and send audio directly to SPDIF.
This has worked previously by selecting the correct codec and audio renderer in MP config.

Now it doesn't work anymore. I don't have time to test all combinations, but this problem appeared after installing MP 1.0 final and upgrading to FFDSHOW tryout beta 6.

Only the audio renderer setting has effect in MP. What ever I set in the codec setting, has no effect. The codec is selected based on the filter merit only. When I raise AC3Filter merit, it is used. When I lower it, FFDSHOW is used.
MP configuration setting has no effect on this.

Here is my config file movieplayer section:

<section name="movieplayer">
<entry name="osdtimeout">0</entry>
<entry name="zapdelay">2</entry>
<entry name="zaptimeout">5</entry>
<entry name="skipsteps">15,30,60,180,300,600,900,1800,3600,7200</entry>
<entry name="skipsteptimeout">1500</entry>
<entry name="defaultar">normal</entry>
<entry name="autodecodersettings">no</entry>
<entry name="audiodualmono">no</entry>
<entry name="path">
<entry name="arguments">
<entry name="internal">yes</entry>
<entry name="audiorenderer">Realtek HDA HDMI Out</entry>
<entry name="wmvaudio">no</entry>
<entry name="mpeg2audiocodec">AC3Filter</entry>
<entry name="mpeg2videocodec">ATI MPEG Video Decoder</entry>
<entry name="h264videocodec">ffdshow Video Decoder</entry>
<entry name="filter0">undefined</entry>

Copied from MP log when I started to play a movie with DTS audio, using SPDIF (HD Audio Renderer) and should have used FFDSHOW for audio, but is using AC3Filter. I can see that from right clicking FFDSHOW video decoder icon on task bar.

2009-01-25 13:14:03.828125 [Info.][MPMain]: VideoPlayer:play V:\Movies\alvin.and.the.chipmunks.mkv
2009-01-25 13:14:03.890625 [Info.][MPMain]: VideoPlayerVMR9: Enabling DX9 exclusive mode
2009-01-25 13:14:03.890625 [Info.][MPMain]: Main: Received DX exclusive mode switch message. Fullscreen && maximized == False
2009-01-25 13:14:03.937500 [Info.][MPMain]: VMR9: added Video Mixing Renderer 9 to graph
2009-01-25 13:14:03.937500 [Debug][MPMain]: VMR9: SetDeinterlacePrefs()
2009-01-25 13:14:03.937500 [Debug][MPMain]: VMR9: Enabled YUV mixing - No DX Error
2009-01-25 13:14:03.937500 [Debug][MPMain]: VRM9: Turning on nonsquare mixing - No DX Error
2009-01-25 13:14:03.937500 [Debug][MPMain]: VRM9: Set filter mode - Gaussian Quad Filtering No DX Error
2009-01-25 13:14:03.937500 [Debug][MPMain]: VMR9: Now active
2009-01-25 13:14:03.937500 [Debug][MPMain]: VMR9: Renderer successfully added
2009-01-25 13:14:03.937500 [Info.][MPMain]: added filter:ffdshow Video Decoder to graph
2009-01-25 13:14:03.953125 [Info.][MPMain]: DirectShowUtils: First try to insert new audio renderer Realtek HD Audio output
2009-01-25 13:14:03.953125 [Info.][MPMain]: DirectShowUtils: Found audio renderer
2009-01-25 13:14:03.953125 [Debug][MPMain]: DirectShowUtils: added filter:Realtek HD Audio output to graph
2009-01-25 13:14:07.234375 [Debug][MPMain]: planescene: PresentImage()
2009-01-25 13:14:07.234375 [Debug][MPMain]: PlaneScene: PresentImage() dispose surfaces
2009-01-25 13:14:07.234375 [Debug][MPMain]: planescene: PresentImage()
2009-01-25 13:14:07.234375 [Debug][MPMain]: PlaneScene: PresentImage() dispose surfaces
2009-01-25 13:14:07.250000 [Info.][MPMain]: VideoPlayerVMR9: no vob sub filter in the current graph
2009-01-25 13:14:07.250000 [Info.][MPMain]: VideoPlayerVMR9: subtitles are not enabled
2009-01-25 13:14:07.250000 [Debug][MPMain]: VMR9: SetDeinterlaceMode()
2009-01-25 13:14:07.250000 [Debug][MPMain]: VMR9: SetDeinterlaceMode - FormatType = VideoInfo2
2009-01-25 13:14:07.250000 [Info.][MPMain]: VMR9: progressive mode detected - no need to de-interlace
2009-01-25 13:14:07.265625 [Info.][MPMain]: VideoPlayer:Duration:5473,8935546875
2009-01-25 13:14:07.265625 [Debug][MPMain]: VideoPlayer: FoundStreams: Type=Video; Name=V: [English], Filter=V:\Movies\alvin.and.the.chipmunks.mkv, Id=0, PDWGroup=0
2009-01-25 13:14:07.265625 [Debug][MPMain]: VideoPlayer: FoundStreams: Type=Audio; Name=A: [English], Filter=V:\Movies\alvin.and.the.chipmunks.mkv, Id=1, PDWGroup=1
2009-01-25 13:14:07.265625 [Debug][MPMain]: VideoPlayer: FoundStreams: Type=Subtitle_hidden; Name=No subtitles, Filter=V:\Movies\alvin.and.the.chipmunks.mkv, Id=2, PDWGroup=2
2009-01-25 13:14:07.265625 [Info.][MPMain]: g_Player.OnStarted() V:\Movies\alvin.and.the.chipmunks.mkv media:Video
2009-01-25 13:14:07.265625 [Debug][MPMain]: GUITVCropManager.g_Player_PlackBackStarted: media: Video tv:False ts:False
2009-01-25 13:14:07.265625 [Debug][MPMain]: g_Player: ShowFullScreenWindow
2009-01-25 13:14:07.265625 [Info.][MPMain]: g_Player: ShowFullScreenWindow switching to fullscreen video
2009-01-25 13:14:07.281250 [Debug][MPMain]: Window: MediaPortal.GUI.Video.GUIVideoFiles deinit
2009-01-25 13:14:07.312500 [Info.][MPMain]: TextureManager: Dispose:C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal\Thumbs\Videos\Title\Alvin and the ChipmunksL.jpg Frames:1 Total:12 Mem left:449839
2009-01-25 13:14:07.312500 [Debug][MPMain]: TextureManager: CleanupThumbs()
2009-01-25 13:14:07.359375 [Debug][MPMain]: Window: MediaPortal.GUI.Video.GUIVideoFullscreen init
2009-01-25 13:14:07.406250 [Debug][MPMain]: VMR9Helper: Playing -> Repainting, Frames 50
2009-01-25 13:14:07.421875 [Debug][MPMain]: g_Player.SeekAbsolute() - Preparing to seek to 0:2:8
2009-01-25 13:14:07.421875 [Info.][MPMain]: seekabs:128
2009-01-25 13:14:07.453125 [Info.][MPMain]: seekabs:128 done
2009-01-25 13:14:07.453125 [Debug][MPMain]: Successfully set rate to 1
2009-01-25 13:14:07.453125 [Info.][MPMain]: VideoPlayer:confused:etRate to:10000
2009-01-25 13:14:07.500000 [Debug][MPMain]: VMR9: Repainting -> Playing, Frames: 50
2009-01-25 13:14:07.734375 [Debug][VMRenderer]: PlaneScene: crop T, B : 0, 0
2009-01-25 13:14:07.734375 [Debug][VMRenderer]: PlaneScene: crop L, R : 0, 0
2009-01-25 13:14:07.734375 [Info.][VMRenderer]: PlaneScene: video WxH : 1280x720
2009-01-25 13:14:07.734375 [Debug][VMRenderer]: PlaneScene: video AR : 16:9
2009-01-25 13:14:07.734375 [Info.][VMRenderer]: PlaneScene: screen WxH : 720x556
2009-01-25 13:14:07.734375 [Debug][VMRenderer]: PlaneScene: AR type : Normal
2009-01-25 13:14:07.734375 [Debug][VMRenderer]: PlaneScene: PixelRatio : 1
2009-01-25 13:14:07.750000 [Debug][VMRenderer]: PlaneScene: src : (0,0)-(1280,720)
2009-01-25 13:14:07.750000 [Debug][VMRenderer]: PlaneScene: dst : (0,75)-(720,480)


Portal Pro
June 5, 2008
Home Country
Finland Finland
Bump. Can anyone verify this? Or prove I have the problem somewhere else? BTW, I'm using the pached mediaportal.exe and core.dll from Automatic RR changer thread. Could this mess up the audio decoder settings?

Users who are viewing this thread

Top Bottom