[confirm] DirectX and SQL errors (1 Viewer)

doveman

Portal Pro
February 12, 2008
2,326
178
United Kingdom United Kingdom
Country flag
MediaPortal Version: v1.2A
MediaPortal Skin: StreamedMP
Windows Version: Win7 Ultimate 64-bit
CPU Type: Athlon II X4 630
HDD: 2TB Samsung F4
Memory: 4GB DDR2 1066Mhz
Motherboard: Biostar TA790GXB3
Video Card: HD3300 IGP
Video Card Driver: 11.3
Sound Card: onboard Realtek AC97 (ALC662)
Sound Card AC3: no AC3
Sound Card Driver: 6.01.6194
1. TV Card: Hauppauge Nova-T 500
1. TV Card Type: DVB-T
1. TV Card Driver: 4.3.25080
MPEG2 Video Codec: Microsoft DTV-DVD
MPEG2 Audio Codec: ffdshow
h.264 Video Codec:Microsoft DTV-DVD
HTPC Case: Custom
Cooling: Scythe 120mm Bottom Intake Fan, Stock CPU HSF
Power Supply: OCZ StealthStream 400W
Remote: Nova-T 500
TV: Sony XBR800 36"
TV - HTPC Connection: DVI

MP has been working fine mostly with Win7, but when I just booted, it got stuck on the "Initialising DirectX" screen. I killed it and found an error in the error.log file (error.bak in attachment) saying there was a problem with my display settings, but I ran MP again and it worked fine. There was a pop-up from Daemon Tools on this reboot, so maybe it activated the UAC screen which confused MP.

Whilst I was checking the logs, I noticed there's a lot of errors in the TVserver_error.log saying "The database backend (provider MySQL) could not be reached." I thought it might be something to do with my firewall (PCTools Firewall Plus) but that's got rules allowing MP, TVService and Mysqld full In/Out access, although there is an Advanced Profile Settings section which has various rules, which I have to admit I don't entirely understand or know what they should be set to!

These errors don't seem to be affecting MP though and TV seems to be working fine. Perhaps the firewall is just blocking access before Win7 is finished booting and it's then that these errors are generated. I just tried stopping and restarting the TVservice and manually timeshifting one channel and no errors were generated then.

EDIT: I just got a similar SQL error when clicking on Configuration for the Radio plugin in MP Config. It doesn't appear to have logged the error anywhere unfortunately. I set my firewall to Allow All and then I didn't get the error, even after setting the Firewall back to Ask mode. However, after closing and re-opening MP config, the error occurred again, so obviously there's something about the Firewall that's causing this problem.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
R Directx 9.0 June 2010 does not install on Windows 10 x64, ends up with weird failure / no debug file Installation, configuration support 0
E Hanging on Initializing Directx General Support 6
H Felhler bei Installation Installationsprobleme? 0
G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
B 'Successful' install of MP2.2.2 on W8.1 - but can't connect to sql db General 1
F MediaPortal 1.16 server crashing due to user error? General Support 5
CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 8
G [solved] timeshift error Newcomers Forum 2
C Can't install any extensions - DLL error Installation, configuration support 19
horned_reaper Errors in FH log ... Fanart Handler 1
joecrow 1.25.0 5031: Error on Install. Bugreports 24
M MediaPortal2 TV Config Error on Install (0x80004005) General 7
J Blue Screen Error Submit: Bug Reports 0
G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
F Error invoking action 'GetNowNextProgramForGroup' Submit: Bug Reports 3
B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
vvulture UNKNOWN ERROR when starting live TV General Support 6
doskabouter Build errors MediaPortal 1 9
ajs Trakt error when start with MP crash Trakt 1
horned_reaper MediaPortal configuration error log message General Support 1
horned_reaper MiniDisplayStatus error log messages General Support 7
horned_reaper [solved] GUITextureManager Load2 log error messages Fanart Handler 1
Similar threads

























Top Bottom