Display needs to be turned on for TV services to function (1 Viewer)

xpand

New Member
April 18, 2020
2
0
Home Country
Australia Australia
Hi, new user. While debugging why I couldn't watch TV on a remote client via the Kodi Mediaportal PVR add-on, I noticed it only worked when my MP2 server host's display was turned on... and it turns out it's not just a problem with remote clients.

Live TV and the ability to record are impossible while the host's display is inactive. Full stop.

The MP2 server host is a HTPC, the display is a TV. I'm running MP2 2.2.2* on Windows 10 x64. Graphics is AMD Vega 8, bundled with a Ryzen 2200G. Software has been updated recently. *(Running 2.2.2 because 2.2.3 did not work with Kodi)

With the TV off:

* I can see the screen via remote viewing software, the MP2 front end program runs fine - but when I try to watch live TV, nothing happens.

* I can view live EPG data, and scheduling can be performed both via the external Kodi client as well as directly on the host via remote viewing software - but no action will take place when the time comes to record.

* I can watch pre-recorded content remotely via the external Kodi client as well as browsing through shared folders in e.g. Windows Explorer from another PC.

* Every other aspect of the PC seems to run just fine whilst the TV is off. With the remote viewing software, I can even play back media running directly on the host, e.g. music in Winamp, video in MPC-HC, or pre-recorded TV in MP2, and see it working in action and hear it with external speakers.

What the hell is going on, and how can I fix it? Not being able to record with the TV off is a deal breaker.

Thanks
 

xpand

New Member
April 18, 2020
2
0
Home Country
Australia Australia
Dumb mistake on my part. Forgot my TV signal amplifier was powered by my TV. Whoops.

Plugged it into my HTPC and it all works now.
 

Users who are viewing this thread

Similar threads

Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes, there will be many things. Main reason is simply, that MP2 is not developed based on MP1. I for example never used MP1. I tried it lately to test voice control and was shocked about many inconsistancies in...
Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes...
It´s been a while... :) Well, simply the reason is cause MP1 was working so well... :) Now I decided to upgrade my old servers and...
Replies
1
Views
244
I've been using version 1.2.2.0 for years and have found no need to upgrade to newer version. I hate it that skins loose compatibility with almost every new version. And new skins are too 'fancy' for my taste. I use a customized version of the default wide skin with only Videos and TV in the main menu. I use mediaportal for recording...
I've been using version 1.2.2.0 for years and have found no need to upgrade to newer version. I hate it that skins loose...
I've been using version 1.2.2.0 for years and have found no need to upgrade to newer version. I hate it that skins loose...
Replies
0
Views
207
  • Sticky
Great work and release!! Contrats to all involved developers :):D I installed MP1 initially, but didn’t get along with it. Many things were not intuitive, too frumpy and the gui had hardcoded dependencies to plug-ins, some buttons didn’t work even without a note due to that. Same for player controls, why do I see always play and pause...
Great work and release!! Contrats to all involved developers :):D I installed MP1 initially, but didn’t get along with it. Many...
We are proud to present MediaPortal 2.4 MediaPortal 2.4 is a full-blown media center software that addresses most common user...
Replies
4
Views
626
Good afternoon. I realized I never got back to posting the solution I found. Basically, I think I broke this on my own. I had made some registry changes to attempt to increase the video quality, which ended up not being supported by Kodi. Attached is a screenshot of what my final (working) settings are, just in case anyone else...
Good afternoon. I realized I never got back to posting the solution I found. Basically, I think I broke this on my own. I had...
Good morning. Back a few months ago, I replaced my original HTPC with updated hardware. I have a few Hauppauge ATSC tuners I'm...
Replies
2
Views
1K
i don't know if @Owlsroost can look this or @framug
i don't know if @Owlsroost can look this or @framug
Hi, I've been using MP TV-Server for ages in and old windows 7 32-bit PC, and different dvb-x cards (t, s). Some months ago I...
Replies
2
Views
1K
Top Bottom