DVD: 5.1/AC3 sound through SPDIF (1 Viewer)

JulianBuss

Portal Pro
November 14, 2004
136
2
I worked several hours on that issue until I realized that I made everything right from the beginning and that just my receiver was set to "stereo" for the digital input on which my computer hangs...

So for everyone who wants to put the digital AC3 sound from DVD directly to the receiver by SPDIF, I startet a page in the wiki with some tipps:

http://www.maisenbachers.de/dokuw/howto:myvideo:dvd
 
A

Anonymous

Guest
Thanks Julian!

That fixed most of my problems but I still have two remaining. I think I just need to tweak the settings of the filter and everything should work fine.

Cheers!
 
A

Anonymous

Guest
why I cant use the digital output for all sounds?

I ve got a SoundBlaster Live 5.1 with coaxial output and a digital soundsystem from Creative with optical and coaxial input.

Codecs are ffdshow.

When I connect with analog cable's, then I get sound, but with the coax cable, nothing. Also when the "only use digital Output" in Creative Soundmixer is enabled, nothing.

I have a lot of movies with AC-3 Codec (Divx/Xvid), but with analog connection, i have only stereo or this ..... Dolby Pro Logic II, this sucks.

Hope somebody can help me.
 

MrMario64

Retired Team Member
  • Premium Supporter
  • April 22, 2004
    822
    1
    48
    Home Country
    Netherlands Netherlands
    the use of digital out is a system setting, not a MP setting.
    Simply set windows to use digital out and your r good to go.
     
    A

    Anonymous

    Guest
    Here's an odd question.. I followed the directions in Julian's wiki entry and for the most part it worked. but since I did this I have noticed the following:

    1) On some AC3 movies, I can only hear parts of the audio. I can hear the music, sound effects, but no voices. I have no idea even how to look into this.

    2) Since I made the change, most of the shoutcast streams I created in MyRadio have no audio yet others do... ????

    I doubt the second problem is related to the changes I made but I haven't changed anythng else. Ideas?

    Cheers!
     
    A

    Anonymous

    Guest
    If you are running a creative labs card (live 5.1 or newer) there is an option in the creative control panels to have it decode ac3. If you want to use the spdif you must disable this option! Otherwise you will only get a pcm stream of the left and right channels over the spdif and the center, rear channels and subwoofer will be left in the dark.
     
    A

    Anonymous

    Guest
    Meat_PoPsiclez said:
    If you are running a creative labs card (live 5.1 or newer) there is an option in the creative control panels to have it decode ac3. If you want to use the spdif you must disable this option! Otherwise you will only get a pcm stream of the left and right channels over the spdif and the center, rear channels and subwoofer will be left in the dark.

    Nope. Running a sigma designs integrated audio. Seriously thinking about getting a PCI audio card. Thanks for the idea. I'll check to see if there are any options like that in my configuration.
     

    JulianBuss

    Portal Pro
    November 14, 2004
    136
    2
    if you find the answer to your problem please post it here, I will try to update the wiki page with tipps to other hardware and configurations.
     

    dman_lfc

    Retired Team Member
  • Premium Supporter
  • July 28, 2004
    1,772
    30
    UK
    Home Country
    New Zealand New Zealand
    All,

    Have a look at this post - Julian, please add the relevant detail to the Wiki if you like...

    http://nolanparty.com/mediaportal.s...0&postorder=asc&highlight=intervideo+registry

    Basically you don't need to use AC3 Filter for DD/DTS soundtracks, you can use the standard codecs that come with your DVD Player software provided the registry settings for the codec is set correctly.

    You can also use your DVD Audio Codecs for playing AC3 streams within AVI files by installing the MPGAudio filter.

    Get it here... www.kiwi07.pwp.blueyonder.co.uk/AC3/mpgaudio.ax

    At the command prompt where you saved the filter type regsvr32 /s mpgaudio.ax

    Go to your windows mixer for you sound device (Soundmax example) - typically under 'advanced' tick the boxes - AC3 SPDIF & PCM SPDIF.
    So whenever you use MP switch your external receiver to the correct input port from your HTPC and hey presto - you'll have normal sound for everything - TV,MP3's etc (probably mixed to pro logic by your receiver) but more importantly DD/DTS for DVD playback.

    Easy Peasy Lemon Sqeezy

    Enjoy

    DMAN
     

    Users who are viewing this thread

    Top Bottom