EPG- and- TV out trouble (1 Viewer)

excalibur

Portal Member
February 21, 2006
11
0
Area: Media EPG, TV-out
MP Version: 0.2 RC2
Skin: Blue
Windows Version: WinXP Pro SP2
CPU Type: Intel P3, 1GHz
Memory: 512 MB SDRAM
Motherboard Chipset: ASUS
Video Card: GeForce FX2
Video Card Driver: ?
Video Card Resolution: 800x600, true color
Video Render Type: VMR9
Video Codec Type & Version: Hauppage MPII
Audio Codec Type & Version: ?
TV Card: Hauppage PVR-350
TV Card Type: hardware
TV Card Driver: included with card

I have installed the .net extensions, DirectX 9C, and all WinXP updates, XMLTV which runs fine, and the Mediaportal without any problems.

EPG
I have then run the MP-Setup and it goes through with success: I pick Denmark, it automatically picks 'Skanderborg' which is not the right area but still
What is this page in the setup for/doing?
- Then I do a manual scan for stations and this finishes. I then delete or rename all channels to suit. NExt screen I map the channels to ? Is this mapping between the found stations and the XMLTV listings? And then I can finish setup.

Great now everything should be fine EPG wise. I exit MP fully (also from SysTray) and restart MP. The old listings are still there and the channel# are all whacky. Ie Canal+DK looks at the input from Travel Channel and so on... Help :?:

TV-Out
I can get fine picture both on monitor and on TV in Hauppage WinTV2000. :D
- But when I from MP try to TV-out I get no picture on TV... Might be a codec thing though!

In general I have VEEERRYYYY SLOOOOW response from some of the recording activation screens and the TV guide.

But just navigating MP is no problem at all. I have seen the odd crash from time to time though. :shock:

Any help would be greatly appreciated.

Thanks for great effort guys.

Morten

 

Callifo

Retired Team Member
  • Premium Supporter
  • December 7, 2004
    1,439
    21
    Adelaide, Australia
    Cant help you with EPG but reguards to the other problem. The missing image on the tv out occurs because your using overlay as the renderer. You need to change it to vmr9 renderless.

    Slowness can be caused by your cpu/gpu combo, while your cpu is under the minimum requirements this can be further exagerated if your video card is not dx9 (your listed one I cant find info on?).
     

    excalibur

    Portal Member
    February 21, 2006
    11
    0
    No TV-Out - Hauppage PVR-350 TV-card

    Thank you for your reply Callifo.

    I have verified my settings and they are already as you state: You need to change it to vmr9 renderless. I have an option of VMR 7 also, but this doesn't help.
    I do this already.

    Where do I select 'Overlay as the renderer' ?

    In short:
    I am seeing no live picture from the PVR-350s native TV-Out in MediaPortal, only a test screen on the TV with vertical colour lines... Works perfectly with live picture in WinTV2K from Hauppage...

    I have been over the settings, codecs, resolutions, PAL B, etc etc. I have no clue.

    Please anyone with the Hauppage PVR-350 working in MediaPortal. PM me your phone no. and I'll call you so I can verify my settings towards yours...
     

    onkl

    Portal Pro
    February 18, 2005
    341
    0
    44
    Wageningen
    Netherlands Netherlands
    Overlay and VMR7 are more or less the same concepts. I do not know if they are synonyms or not, but they are surely used that way.

    Just as a check: When you say "TV-out", do you mean the TV out on your PVR-350 or a TV-out on your videocard. The TV-out of the PVR is not supported in Mediaportal.

    In general, if I look at your hardware, I think your GPU (and your entire PC) is rather old for a heavy program like MP. (I'm not sure, I've never heard about a GeForce 2FX, but am looking at the rest of the set) and maybe, it might be wise to downscale to version 1.3.0, which is somewhat less hot for your PC.
     

    excalibur

    Portal Member
    February 21, 2006
    11
    0
    Is there no TV-OUT in MediaPortal?

    onkl said:
    Overlay and VMR7 are more or less the same concepts. I do not know if they are synonyms or not, but they are surely used that way.

    Just as a check: When you say "TV-out", do you mean the TV out on your PVR-350 or a TV-out on your videocard. The TV-out of the PVR is not supported in Mediaportal.

    In general, if I look at your hardware, I think your GPU (and your entire PC) is rather old for a heavy program like MP. (I'm not sure, I've never heard about a GeForce 2FX, but am looking at the rest of the set) and maybe, it might be wise to downscale to version 1.3.0, which is somewhat less hot for your PC.
    Hi Onkl,

    I think we are getting to the core of things now. Yes I mean TV-Out directly from PVR-350 just like I can from WinTV2000.
    I was under the impression that like WinTV2000 from Hauppage I could get Live TV out from MP...

    I am shocked - you say that there is NO TV-out in the PVR-350 in MP.
    :shock: But I have this in the WinTV2000 program. TV-Out. Why is this not there in MP?

    Does this mean that all of you use a fast graphicscard and take the TV-Out from there? I'm surprised to hear this.

    Is there any HTPC OS that supports this or will I have to buy another graphicscard. :cry:

    Anyway Onkl, thank you for clearing this out for me. I will try and downgrade and see what I get.

    So If I downgrade to 0.1.3 what will I then get except for speedier and more stable userinterface in MP? Does this version support TV-Out from the PVR-350?

    Thanks alot

    Morten
     

    excalibur

    Portal Member
    February 21, 2006
    11
    0
    MP 0.1.3. Now running but no EPG - and TV-out not sharp

    Hi,

    I have had a strenuous week-end... Gave up on MP and went with MythTV. After 2 long nights of grief I gave up on Linux. Even KnoppMyth, which should be 'out of the box' with my HW was not giving in to my efforts. :x

    Back to WinXP SP2 and MediaPortal. I prepped the PC:
    - updating DirectX to 9b but couldn't get it past this, so I found a loophole. 'DirectX Eradicator' which removes DirectX. Then I downbloaded DirX 9c and 9b and copied the cab-files from 9c to 9b dir extracted to my disk. This way camouflaging the 9c. Then I ran the 9b setup and it worked. Now I am at Directx 9c... :wink:

    PROBLEM 1: TV-Out is somewhat blurry - Monitor is tac sharp
    - Then I downloaded the latest Nvidia Geforce 4 driver and installed this instead of the one on my supplied driver CD. Shock and awe - I had TV-Out. :shock:

    I still have problem reading the text in both the Windows GUI and in MP though. It is actually so unsharp I can't read sub-titles. So I hope this can get better. Any hints anyone.
    Graphicscard is GeForce4 TI-4200, 128 MB VideoRAM.

    - Finally I downloaded and installed the .Net 1.1 without any problems.

    So Now I was ready for the big Caboo - MediaPortal 0.1.3. I saw poor response on my HW mentioned in initial post with MP 0.2. RC2. So this time I went for the older stable MP.

    - This installed nicely, and I upgraded with the recommended Video codecs.

    - MP-Setup: Eventhough Hauppage WinTV 2000 did not tune successfully, MP did! So I had picture and could associate the channels to right frequensies. Success :lol:

    PROBLEM 2: EPG
    - Eventually it was time to get the EPG going and I checked after setup, but EPG contains all sorts of channels from the UK that I don't have. But I only get EPG info on approx 5 channels.

    I have verified and rerun the procedure:
    - Remove TV channels from the MP-setup/Television/EPG
    - Run Grabber with 7 days, short description, tv_dk_conf or whatever this file is called. The one for Denmark.
    - It grabs much information and I see that the file xmltv\Guide.xml takes up approx 40 MB.

    How do I clean the EPG and starts over with only the channels that I Manually tuned into in the setup? :?:

    Thanks again

    Morten
     

    wortelsoft

    Portal Pro
    May 13, 2005
    374
    1
    44
    Rotterdam, The Netherlands
    Netherlands Netherlands
    You could try wepepg. For the 0.1.3 version you have to download is seperately: http://mypage.bluewin.ch/webepg/

    This program is a lot more user friendly and makes it possible to have a different name for you tv channel then the name in the xmltv grabber file.

    i.e. rtl4 in grabber can be RTL 4 in MP.

    For tv-out quality you should use google and search for it as there are a lot of reasons why tv-out is not sharp.
     

    excalibur

    Portal Member
    February 21, 2006
    11
    0
    EPG works (XMLTV - TV-out no progress - still blurry

    Hi,

    I have now succeeded in getting EPG info and can get the overview and start recordings accordingly. Phew very nice indeed.

    I still would like to know how I could get really sharp TV-Out though. It is impossible to do away with the monitor as I cannot get a completely sharp TV-image from MP.

    I think the Tuner signal through MP is fine, but somehow the MP GUI is very ragged and not too crisp.

    What can be done about this particular problem - Anyone....?

    Thanks

    Morten
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G Newb trying MP2, trouble with guide data General 5
    M Add Radio channels and EPG to Mediaportal xmlTV 2
    M EPG color by length of TV-show MediaPortal 1 Talk 1
    D Downloading EPG XML file: Installation, configuration support 0
    D EPG No Data General Support 2
    D [solved] EPG Data off by -20 hours? General 10
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    F Mini EPG more information? WMC Skin 4
    N No TV or EPG on fresh install General 0
    framug No color in TVGuide when XMLTV without DVB EPG MediaPortal 1 Talk 59
    T Freesat EPG in UK anyone? Electronic Program Guide 78
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    G Movie release date in guide Electronic Program Guide 2
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    CyberSimian [fixed] MP1-4990 : Improve horizontal scrolling in the EPG MediaPortal 1 10
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    J Understanding what EPG shows about schedules General 8
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    B [solved] MP2.2.3 TV Guide not scrolling with mouse wheel General 2
    HTPCSourcer Special (foreign) characters don't display correctly in EPG MediaPortal 2 4
    B How to Search MP2 for Movies only in 7 day EPG that comes from the Antenna General 3
    F EPG Buddy download Plugins & Erweiterungen 1
    P Timeshifting in XMLTV General 2
    Similar threads

























    Top Bottom