MP2 - V2.3.1 MP2 - V2.3 EPG view: incorrect displayed fonts (1 Viewer)

Corny

MP Donator
  • Premium Supporter
  • September 26, 2011
    38
    0
    Home Country
    Germany Germany
    Country flag
    MP2 Version
    2.3.1
    Before you create this bug report:
    1. Make sure that your system (Windows, codecs and drivers) is up to date, matching the Requirements and you've filled in your System Specs.
    2. Have a look at our MediaPortal Wiki! Maybe the solution is already there.
    3. Have a look at our Jira (Bug and Issue Tracker)and the threads in this section, maybe your problem is already known.
    4. Search the forums for your problem, it's very likely that someone else already encountered the same problem.

    Please always include log files with your Bug Report!
    Check out our Wiki: Bug Reports and Log Files

    ==================================================================

    Describe the Problem you encounter as detailed as possible! "It does not work" won't help the team to understand the problem.
    Description:

    Fonts in the Full- and Mini-EPG are displayed incorrect. Also in the news-view.


    Describe as detailed as possible the steps that are required to encounter the issue. This info is critical for the team to understand the problem.
    Steps to Reproduce:

    It happens sometimes, I don't know a way to reproduce it.
    I see this Bug for about one year now, but only about once in a month. First i thougt the cause would be an outdated driver of my graphics card, but after an upgrade the problem still exists.
    After restarting MediaPortal the text is displayed correctly.
    I also had this on BlueVision Skin on MePo 2.2.x

    The graphics card is a NVIDIA Geforce GT 1030 with driver version 456.71 (via Windows Update) on Windows 10 2004 x64.



    Zwischenablage02.jpg


    .
    Zwischenablage01.jpg

    Zwischenablage03.jpg
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,519
    2,683
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    The problem is known, but not reproducable unfortunately. It happens very seldom from time to time and is gone after a restart of the client.
    It is related to font rendering with FreeType library. Updating the library did not solve this issue yet, also not the recent change to SharpFont (based on FreeType as well).
    There is a new idea by @morpheus_xx to improve this in future, but I'm not sure about concrete details.
     

    Corny

    MP Donator
  • Premium Supporter
  • September 26, 2011
    38
    0
    Home Country
    Germany Germany
    Country flag
    So maybe I've just overseen the bug in Jira.

    But the bug isn't a big problem as it only happens very seldom and you can still use MediaPortal, so I think i can live with it ;)
     

    Users who are viewing this thread

    Similar threads

    Thanks @high, bug report options look good now.
    Thanks @high, bug report options look good now.
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    8
    Views
    694
    I just recently had an epiphany around QueryDisplayConfig w.r.t. how Windows deals with displays. The MS documentation uses the word 'display' to refer to both GDI-devices and the monitors themselves. There is also a zoo of different Id formats that refer to these things (adapters, displays, monitors, etc), and often no apparent way...
    I just recently had an epiphany around QueryDisplayConfig w.r.t. how Windows deals with displays. The MS documentation uses the...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    4
    Views
    442
    I remember that the home content was not always up to date. One situation I think can cause this is during import as the list only update after the import is completed. Maybe we could have the force behavior during import only and after it completes the home content should always be up to date?
    I remember that the home content was not always up to date. One situation I think can cause this is during import as the list only...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    6
    Views
    806
    Is this issue also solved meanwhile?
    Is this issue also solved meanwhile?
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    4
    Views
    630
    @Tomkon The reported issue was fixed. The fix will be part of next release. If you are interested I might create a test version and provide the link by message.
    @Tomkon The reported issue was fixed. The fix will be part of next release. If you are interested I might create a test version...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    7
    Views
    679
    Top Bottom