Eventghost Genius MediaCruiser und X10 (1 Viewer)

Mho

Portal Member
November 4, 2007
33
3
Germany Germany
GERMAN
Hallo da ich neu bin hier im Forum möchte ich gleich mal etwas beitragen.

Im Forum und im Netz sind viele Informationn verstreut wie man ein
Genius MediaCruiser Keyboard ( LuxeMate 810 ) zur Steuerung von einem Mediaportal nutzen kann.
Leider sind viele dieser Hinweise veraltet oder unvollständig.

Hier eine möglichst komplette Anleitung:

1. Das MessagePlugin installieren
Quelle : link
- die dll in den Ordner Plugin\Process
- die XML in den Ordner InputDeviceMappings\default

2. Die aktuellste Eventghost Version installieren (momentan eine Beta 0.3.6 ) die das Mediaportal direkt unterstützt
Quelle: link
- Das letzte Vollsetup installieren
- Das letzte Update installieren

3. Eventghost einrichten
- wird nur der Media Cruiser genutzt dann diese XML: bitte nachfolgendes post beachten
- wird der Mediacruiser und eine X10 Fernbedienung ( QSonic in meinem Fall) diese XML: bitte nachfolgendes post beachten


4. Eventghost anpassen
- Auf jeden Fall müsst ihr für den Start Knopf den Pfad anpassen
Dazu Restart and Start in Eventghost aufklappen und mit Doppelclick auf "Starte Anwendung" den Pfad ändern.
- Möglicherweise müsst ihr auch die HID Plugins neu mitaufnehmen falls es nicht so funktioniert,
dazu meine löschen und alle vier gefundenn Genius HIDs als neues Plugin mitaufnehmen

5. Mediaportal anpassen
- Alle Fernbedienungen deaktivieren
- MessagePlugin aktivieren

Auf dieser Grundlage könnt Ihr hoffentlich eure eigenen Anpassungen machen


Tschö
Mho

ENGLISH
Hello cause i'm a new member (ex MCE user)
I wrote a short guid to use Genius media cruiser.

Ther are many information around here in the forum and outside in www, but most of theme are outdated or incomplete.

1. Install Message Plugin
Source: link
- put dll in folder plugins\process
- put xml in folder InputDeviceMappings\default

2. get last EventGhost software (at the moment a beta 0.3.6)
source: link
- install last full setup
- install last update

3. configure eventghost
- for use only with media cruiser use this xml: please see nect post
- for use with media cruiser and X10 (qsonic in my case) use XML: please see nect post
4. set youre own data in eventghost
- customize the path to mediaportal.exe with double click on "start program" in node "Restart and start"
- maybe you need to delete HID plugins and add them again if eventghost is not working, addall four hids for the keyboard

5. customize mediaportal
- disable all remotes
- enable message plugin

I hope this will help you

Mho
 

Mho

Portal Member
November 4, 2007
33
3
Germany Germany
Achtung da hat sich ein Fehler eingeschlichen

Bitte nutzt diese beiden XML Dateien.

3. Eventghost einrichten
- wird nur der Media Cruiser genutzt dann diese XML: View attachment 12869
- wird der Mediacruiser und eine X10 Fernbedienung ( QSonic in meinem Fall) diese XML: View attachment 12868
 

Beton

Portal Member
November 11, 2007
9
0
Cologne
Germany Germany
Danke das ist genau das was ich gesucht habe. Benutze genau die gleiche Kombination Media Cruiser und X10 von Pearl (beste Kombination überhaupt!!). Leider bekomme ich bei EventGhost einige Fehler wenn ich die XML Datei importiere (siehe Screenshot). Es sieht so aus als wäre Media Cruiser mehrfach enthalten und noch einige XML Fehler da drin?

Vielen Dank für die tolle Arbeit

Gruß
Daniel
//////////////////////////////////////
Thanks this is exactly what I have been looking for. Unfortunately this isn't working for me.
I also have the Media Cruiser and the X10 (Pearl Edition). This error message appears in EventGhost (see screenshot). It appears as if Media Cruiser is in there a couple times and the XML is corrupt.

Thanks for the great work

Best Regards
Daniel
 

Attachments

Mho

Portal Member
November 4, 2007
33
3
Germany Germany
Hallo
Auch ich hatte immer wieder Probleme mit den HID Geräten.

Zum einen muss wohl jeder die HID Controller einmal neu anlegen im Eventghost.

Trotzdem kam es bei mir zu dem Effekt das das nur funktioniert hat bis zum nächsten
Neustart. Danach schien Eventghost die HID Geräte nicht mehr zu erkennen.
Abhilfe schuf ab und anstecken des Mediacruiser Empfängers.
Eventghost merkt dann das wieder Hids da sind und kann diese wieder verwenden.

Das ist aber zu unpraktisch.
Bei MCSoft habe ich ein Tool gefunden welches USB Geräte ab und wieder anmelden kann.
Dieses wird von Eventghost nach restart des Rechners ausgeführt und die Taststur funktioniert wieder.

Quelle des MCSoft Tools: DEVCON (klasse Name, oder?)

Whermutstropfen: Bei mir funktioniert das nicht ohne das UAC abzuschalten.

Es kann sein das Ihr die PID der USB Geräte anpassen müsst im Eventghost unter
Power and Start - > USB reload -> Starte Anwendung DEVCON
Bei mir fangen alle HID Geräte der Mediacruiser Tastatur mit restart USB\VID_0BC7 an.

Entsprechend ist das in der angepassten Eventghost Konfiguration enthalten.

Die X10 Qsonic nutze ich inzwischen übrigens wieder über die Mediaplayer Standard Konfiguration.
Dort funktioniert das Gedrückthalten einer Taste besser.

Ausserdem ist nun folgendes enthalten:
- Die Direktwahltasten suchen erst nach dem Mediaportal Fenster und weisen dem den Fokus zu.
- Die Start Taste kann das Mediaportal durchstarten
- Die Tastenfunktion des Scrollrades löst das OK des Mediaportals aus anstatt ENTER solange Mediaportal läuft.
- Mausfunktion komplett mit aufgenommen


Hier die neue Konfiguration ( Qsonic X10 enthalten aber deaktiviert )

View attachment MediaPortal_full.xml
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
milagroso Remote control with EventGhost - I'm stuck, need help General 3
T Shortcuts for Basic-Windows Input / Output interfaces 6
Similar threads


Top Bottom