Expressions/Rules requests (2 Viewers)

Inker

Retired Team Member
  • Premium Supporter
  • December 6, 2004
    2,055
    318
    Please use this thread to request Parsing Expressions and Logo Rules. Follow-up questions are allowed, any other talk should not go here.

    Be as decisive as possible when making a request. Include at least one full example. Be nice and be aware that your request may or may not be fullfilled.

    I would suggest that if you fullfill a request, you add it to the exchange thread to keep them all in one place. Simply reply to the requester with a quote and a link to your reply in the exchange thread.

    Thank you in advance for any request you might fullfill.

    [UPDATE]

    There is more and more threads about parsing problems. This is what this thread is for, please use it!

    Any further threads about parsing problems that are not in this thread will be deleted.

    Also, please if somebody made an expression for you that works, add it to the Expression exchange thread, nobody seems to do this. I know your excited once your series import, but please take 5 minutes so other people won't have to ask the same question again.

    Thank you.
     

    Vergo

    Portal Pro
    August 30, 2005
    162
    59
    Brugge
    Belgium Belgium
    I have 2 requests:
    1/ Genre logo
    2/ if filename contains HDTV, then HD logo

    I have no idea how to get these 2 working, any help please?
     

    pannivas

    Portal Pro
    July 26, 2006
    340
    2
    42
    Nicosia
    Cyprus Cyprus
    I have 2 requests:
    1/ Genre logo
    2/ if filename contains HDTV, then HD logo

    I have no idea how to get these 2 working, any help please?
    but you can do that already for HD Logos, using these 2 rules.

    If <Episode.videoHeight> >= 500 AND <Episode.videoWidth> >= 960 AND <Episode.videoHeight> != 720 use HD 540p logo

    If <Episode.videoHeight> >= 720 AND <Episode.videoWidth> >= 1280 use HD 720p logo
     

    EgoManiac

    Portal Member
    April 11, 2007
    35
    0
    38
    Genre can be done 2 ways :

    1. use dynamic filenames with <Series.Genre>
    2. use <Series.Genre> contains 'comedy' etc for each of the logos.
     

    Inker

    Retired Team Member
  • Premium Supporter
  • December 6, 2004
    2,055
    318
    If you want the hd based on the filename, then you can use
    If <Episode.Episodefilename> contains 'hdtv'

    As state, for genres there are two option, but option one is more convinient. But, and I'm not sure, it will probably not work fully yet as it will look for the exact combination of Genres. So for instance Action,Adventure would not try to load Action.jpg and Adventure.jpg but Action_Adventure.jpg. So for now, use option 2 :)
     

    Bobb25

    Portal Pro
    November 26, 2006
    232
    0
    Durban
    South Africa South Africa
    Ok, i obviously am not as bright as i thought i was! lol. I am trying to make a logo rule to differentiate episodes backed up to DVD as apposed to eps that are actually on my server. For all episodes that are backed up, i created a standard little avi that says "Please insert relevant TVDVD" and then renamed them with the actual episode names so that My-Tvseries shows what is backed up to DVD in the normal menus. Whats the easiest way to get mytvseries to show a logo for these files? Should i edit the file names and put DVD in them? What would be the logo rule for that then? Any suggestions / advice would be appreciated.
     

    G.B. Wolf

    MP Donator
  • Premium Supporter
  • March 22, 2007
    227
    3
    Braunschweig
    Germany Germany
    Should i edit the file names and put DVD in them? What would be the logo rule for that then? Any suggestions / advice would be appreciated.
    This would be something like:

    Type: Logo Rule
    DVD-Logo
    Description:
    Show a DVD-logo if filename contains "DVD"
    Expected Filename: static
    Rule:
    Code:
    Thumbs\TVSeries\DVD.png;-;<Episode.EpisodeFilename>;-;contains;-;DVD;-;AND;-;;-;=;-;;-;AND;-;;-;=;-;;-;
     

    ccMatrix

    Portal Pro
    November 9, 2006
    97
    10
    37
    Somehow the aspect ratio rule doesn't work here. Could it be because in the database there is a 1.7xxxx but on my system , is the default character for decimals ? I tried 1.7 and 1,7 as a <= rule but it won't work. For now I had to use a workaround with contains 1.7 but it seems ugly ;)
     

    nylonhof

    Portal Pro
    August 5, 2006
    99
    0
    Germany Germany
    Somehow the aspect ratio rule doesn't work here. Could it be because in the database there is a 1.7xxxx but on my system , is the default character for decimals ? I tried 1.7 and 1,7 as a <= rule but it won't work. For now I had to use a workaround with contains 1.7 but it seems ugly ;)
    ccMatrix,

    if you are trying to show the 16:9 logo shouldn't you set the ratio to "greater than" 1.7? And not "less than" as you wrote above...

    Regards
    nylonhof
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom