Failing to compile, can't find a single reference... (1 Viewer)

A

Anonymous

Guest
I followed the howto's to get the source and compile but when trying to compile I get 560 build errors. All are reference errors, I tryed to deete and add the reference but it doesn't change anything.

This doesn't look like a source code problem but I can't figure out what's wrong...
 
A

Anonymous

Guest
I use VS.Net 2003 and I followed the howto. Ran the postsetup and copied the files without overwriting.
 

Frodo

Retired Team Member
  • Premium Supporter
  • April 22, 2004
    1,518
    121
    51
    The Netherlands
    Home Country
    Netherlands Netherlands
    could you post (some) of the errors you're getting?
    and i take it you :

    -did install DX9 Summer update 2003 SDK?
    -use VS.NET 2003?

    Frodo
     
    A

    Anonymous

    Guest
    Actually I use the 2004 beta DX9 update. But it shouldn't have anything to do with this:

    Code:
    C:\dev\mediaportal\mediaportal\GUIMusic\GUIMusicTop100.cs(136): The type or namespace name 'Action' could not be found (are you missing a using directive or an assembly reference?)
    
    C:\dev\mediaportal\mediaportal\GUIMusic\GUIMusicFiles.cs(274): The type or namespace name 'Action' could not be found (are you missing a using directive or an assembly reference?)
    
    C:\dev\mediaportal\mediaportal\VideoPlayer\IPlayer.cs(52): The type or namespace name 'Action' could not be found (are you missing a using directive or an assembly reference?)
    
    C:\dev\mediaportal\mediaportal\GUIMusic\GUIMusicArtists.cs(72): The type or namespace name 'VirtualDirectory' could not be found (are you missing a using directive or an assembly reference?)
    
    C:\dev\mediaportal\mediaportal\xbmc\SetupForm.cs(3999): The type or namespace name 'AMS' could not be found (are you missing a using directive or an assembly reference?)

    That's just a few out of the 547 errors.

    While loading the solution I get 97 tasks in the tasklist, then they dissapear:
    Code:
    The referenced component 'Dialogs' could not be found.
     
    A

    Anonymous

    Guest
    Actually it looks like it is the DX9 beta I use, it doesn't have the TextureState as used it guilib. I'll have to check it out....
     

    Users who are viewing this thread

    Top Bottom