Failing video rendering on one of my clients... (1 Viewer)

jhb

Portal Pro
September 19, 2006
121
2
Gothenburg
Sweden Sweden
TV-Server Version: 1.0.1 standalone
MediaPortal Version: 1.0.1 (Client Only)
MediaPortal Skin:
Windows Version: Vista SP1 (on Client)
CPU Type: AMD 3000+
HDD: Samsung 200G
Memory: 1GB DDR2
Motherboard: GA-MA78GM-S2H rev 1.1
Video Card: ATI HD3200 (built-in on MB)
Video Card Driver: Catalyst 8.11
Sound Card: Realtek (built in on MB)
Sound Card AC3: Realtek (built in on MB)
Sound Card Driver:
1. TV Card: FloppyDTV + Viaccess CAM
1. TV Card Type: DVB-T
1. TV Card Driver:
2. TV Card: Leadtek 1000S
2. TV Card Type: DVB-T
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: MPV
MPEG2 Audio Codec: MPA
h.264 Video Codec: PowerDVD8
Satelite/CableTV Provider: Boxer
HTPC Case: Enlight Mediacenter
Cooling:
Power Supply: Enlight
Remote: Microsoft MCE
TV: 37" LCD
TV - HTPC Connection: DVI


Hi, I have a problem that I have tried to get help with that now is ready to be reported as a bug in the correct forum...
...so I copy the information from my thread (Video rendering failing in multi-seat with client on ga-ma78gm-s2h - MediaPortal Forum) to this forum instead...

It worked in 1.0, even though there I had other problems, but in 1.0.1 the problem is way too big to be acceptable.

The problem is that one of my clients (gigabyte ga-ma78gm-s2h with ATI HD3200 graphics processor) is failing to show live TV other than with a clean start of MP directly after a reboot of the operating system.

I don't even need to start any video application within MP before closing the application, the next time I start it video rendering of TV is not working, but the audio starts after a while.

I have made a clean install of the OS and the drivers and tested different versions of the catalyst drivers without any success. No additional codecs are installed (as I said the OS is clean!), only the ones from vista and MP. The only drivers that are installed are the ones for audio (Gigabyte/leadtek) and video (Gigabyte/ATI) and daemon tools lite.

The attached logs shows a successful TV-viewing (directly after reboot of the OS), a failed scenario (after the application has been closed down and is restarted again), and finally a failed scenario after starting MP directly after reboot from the logs collector. If I am not autostarting the MP-application at reboot, the application always fails to render video, even if the OS had a clean restart just before starting MP.

The first thing that seems to differ in the TSreader-log seem to be that "aud: set discontinuity" is done in both successful and failing cases, but "vid: set discontinuity" is only done in the successful cases. After this is set, the successful stream is identified as late b/p/i-frames but that never happens in the failing stream.

In the Mediaportal log there seems to be warnings regarding that VMR9 Pins 0-2 are not connected in the failing logs.

The problem is reproducable with both VMR9 as renderer (added a failed log for that case also) as well as with EVR as renderer. With VMR9 the problem results in a black screen, but with EVR the last MP menu (e.g. EPG) will be shown instead of the TV-show. Audio will start (but late) in both cases.

I hope this helps someone to identify the problem. It also may be related to the VMR9 problems that some others have reported for 1080i etc. Look also at this thread (Sound but no image for TV after stop/start) that reports almost the same problem but a little bit different...
...symptoms are also similar to the ones in this (Odd problem: VMR9 not working. EVR works.) thread. Btw, Aero is enabled...

...and I had similar problems on my XP client when using VMR9 there, but there it works with EVR.

I am starting to guess that the problem is timing related (due to the fact that I only get it to work when rebooting with autostart of MP-client) and that only some systems encounter it and under different conditions in different builds...


Additional info:

I found a workaround that works for now:
- by not restarting the application when going to standby, and
- by enabling minimize of the MP application when "closing it" instead of actually closing it

This takes down the number of restarts quite a lot...
...but I really need this to be solved...


I have now tried many different combinations of codecs and ways to reproduce the problems, but I can only get the client (GA-MA78GM-S2H rev 1.1) to work by loading it automatically at boot, but never when manually started. I don't have this problem in any of my other clients (I can not get VMR9 to work on my XP-box, but EVR works fine there).


Logs (in my previous thread):
https://forum.team-mediaportal.com/...ter-restart-after-stop-seccessful-viewing.zip
https://forum.team-mediaportal.com/...-fail-after-starting-clean-logs-collector.zip
https://forum.team-mediaportal.com/...15_04_09-success-autostarted-after-reboot.zip
https://forum.team-mediaportal.com/...-ma78gm-s2h-mediaportallogs_16_04_09-vmr9.zip


--------------------------------------------------------------------------------------------------

Edit:
Added the last post from my previous thread also:

Thanks Elliotmc.

Made a new thread in the correct fora (https://forum.team-mediaportal.com/...iling-video-rendering-one-my-clients-58679/)-

But answering your questions:
- changing codecs is not solving the issue. Have tried many combinations...
- I can only get the client to work when starting it automatically at boot. Have never managed to get as many codec combos to work as with this SW release (goes for all my clients), but on this specific client-HW they only work when starting MP automatically at boot...
- my best guess is that the problem is unique to the combo of client-motherboard and running a split architecture. I have earlier also had a lot of problems that were related to having a split architecture (e.g. https://forum.team-mediaportal.com/...screen-after-channel-change-53609/index4.html). I was not the only one having those, but we were not that many....
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
joecrow Online Videos fails after MP 1.23 upgrade. 1.23 Pre Release 37
Steve.Rayner61 Online Videos - Automatic Updates fails 'Automatic update disabled. Check your internet connection' OnlineVideos 10
joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
T [solved] failed to-startup tvservice Installation, configuration support 1
B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
W Setup data connection - mySQL connection failed Installation, configuration support 1
BrownGhost MP-TVSeries, Failed to save xml to cache, and not adding any info to tvseries from tvdb My TVSeries 4
C Setup failed: 0xfffffff7 Allgemeines Support- und Diskussionsforum 1
G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
B TV tuner fails to initialise Watch / Listen Media 0
P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
J DVB-S2 card fails to tune? Subchannel count increasing Television (MyTV frontend and TV-Server) 3
joecrow Scheduled Recordings Failed (MP 1.22) General Support 12
rexdog [solved] MP2 Instal failing on WIN10 General 2
porky996t DVB Sat card possibly failed General Support 1
joecool70 [solved] Installationsprobleme: MP2-Server failed to start Allgemeines Support- und Diskussionsforum 25
Ralph Holmes [solved] MP2 fails to start after re-boot 2.2 Archive 8
Holzi [solved] MediaPortal 2 will not install - Failed to start services MediaPortal 2 1
B [further infos missing] Install failed Exit code: 0xfff7, restarting: No 2.2 Archive 1
S Display driver failed to start, using microsoft basic display driver instead General Support 23
Frans Nijhuis [further infos missing] Deleting all TV channels and all channel groups in "MP 2 TV configuration" fails 2.2 Archive 1
Stéphane Lenclud [fixed] libbluray submodule update fails MediaPortal 1 3
Similar threads

























Top Bottom