Filesharing via network (1 Viewer)

frietkot

Portal Member
January 1, 2006
15
0
I am really stuck with this.
I have 2 pc's connected in a small home network via crossover cables.
My Mediacentre pc funcions as server. My MP machine has access to the My movies titles folder on the Media centre pc.
Now, I want to be able to play movies from the my movies tiltles folder on the media centre pc with MP. I have tried numerous times to add the folder to the playlist but it the folder dissappears after I pressed finish and it does not show up under videos in MP.
I must be doing something wrong.
This is what I do:

In the movie shares I click add, then I get the edit folder window with local folder, remote ftp etc... How do I take it from here to get MP to find the movies titles on the server.
The file on the server is called \\Mediacentre\my movies titles

Regards
 

scoop

Retired Team Member
  • Premium Supporter
  • November 14, 2004
    614
    7
    Country flag
    Hi,

    Are you trying to add the network share via the wizard? If you do, please try to just use the setup. This way works perfectly for me:

    - Goto Movies --> Movie Folders
    - Click Add
    - Give the folder a descriptive name (i.e. "mediacentre-movies")
    - Enter in "local path" the UNC path with trailing backslash: \\server\share\path\
    - Click OK to add the new folder

    FYI: The path to my movies folder doesn't contain a space. Maybe that causes trouble? You could try sharing the folder with spaces as a share name without spaces.

    Also make sure the share is accessible (i.e. an IPC$ connection has been made with the server) before you try adding the folder in setup. I always make sure by running a batch file which contains something like this:
    Code:
    @echo off
    net use \\<servername>\IPC$ /user:<username> <password>
    ...
    Kind regards,
    Michel
     

    frietkot

    Portal Member
    January 1, 2006
    15
    0
    Hi Michel,

    I still cannot work it out. Sorry.

    The folder that had to be added is named as follows:
    \\Mediacentre\my movies titles

    When I use the movie wizard, the following info in the wondow shows up:

    Name

    Local folder

    This is a remote FTP folder (does this have to be used as well)?

    Login Password

    Folder on the remote FTP server

    /

    Can you show me with the above named file what to do?

    Regards,

    F
     

    scoop

    Retired Team Member
  • Premium Supporter
  • November 14, 2004
    614
    7
    Country flag
    Hi,
    frietkot said:
    I still cannot work it out. Sorry.
    Like I said, you shouldn't use any of the wizards. When MediaPortal is active, press F2 or in the "Options" menu, choose "Configuration...". This will take you to MediaPortal Setup where you can change settings directly, instead of using the wizard-based approach. While you're in configuration, try the steps I mentioned above.

    The "Movies" wizard only allows you to change the folder where movie playlists are stored. It doesn't allow you to add folders (local or remote).

    Kind regards,
    Michel
     

    frietkot

    Portal Member
    January 1, 2006
    15
    0
    Sorry Michel,

    I went into setup or configuration, but I am confused.
    To I need to fill out the bottom section of the edit page?
    Or only the top section with folder?

    When I put in "folder" at the top section \\Mediacentre\my movies titles nothing shows up in MP, when I return to add, the added folder has disappeared.

    Please understand that I do not have much knowledge of this. I got everything else working but this is really bugging me!

    Regards,
    Frank
     

    scoop

    Retired Team Member
  • Premium Supporter
  • November 14, 2004
    614
    7
    Country flag
    Hi,
    frietkot said:
    To I need to fill out the bottom section of the edit page?
    Or only the top section with folder?
    In the "Edit Folder" window you only need to specify the "Name" and "local folder" fields. You do not need to enable "This is a remote FTP folder", because you aren't using FTP to access the remote folder.

    If this doesn't help, then please make screenshots of the configuration windows while adding the directory, and post the logfile so we can see what goes wrong.

    Kind regards,
    Michel
     

    moullas

    Portal Pro
    January 15, 2005
    103
    0
    Home Country
    Cyprus Cyprus
    You can always try mapping the remote drive

    the command is :
    net use X: \\computername\share /user:USERNAME PASSWORD

    this command will map the remote share as the X: drive on your local computer

    And you can save that as the media folder for MP
     

    SiLenTYL

    Retired Team Member
  • Premium Supporter
  • April 23, 2004
    1,144
    159
    Melbourne
    Home Country
    Australia Australia
    Country flag
    hi there...ive been using a shared mapped drive for a long time..but i see issues with it ...so i changed the way i did it

    in the Setup app, i go to Movies, Movie Folders

    i click on ADD

    i put a name ..like shared movies ...

    then for "local folder" ..i click on the "..." and find the directory i want to share...i do this by going first to "My Network Places"...then find the shared directory there

    done!

    to make a folder "sharable" u need to use the PC with the folder u want shared...open My Computer..find the folder u want shared...then right-click on it and go to Properies, Sharing..then click on "i want to share this folder on my network" ....if u want to allow other users to change files u can set this here...i usually have that one "unchecked"..so noone can edit the remote folder (just read from it)


    if i have a mapped drive as "local folder" ...like Drive X: ...then i must open My Computer and open the shared drive X: before i can see it in MP.....so the benefit of doing this is that i dont need "net use" to connect the shared folder :)

    enjoy
     

    frietkot

    Portal Member
    January 1, 2006
    15
    0
    Ok Guys,

    Thanks for your help, but there had to be something wrong. I am not very handy with pc's but cleared more difficult tasks then this. The same 20 object kept on appearing in My video's nomatter how hard I tried to add another folder.

    Here is how I solved the problem:

    I tried to add another folder from the c drive where MP is located, wouldn't do it either. Also tried to add my external disk, no success.

    I then uninstalled MP, installed version 1.3, tried again, no success.
    Installed version 2 rc 2 again, no success. Uninstalled version 2 rc2 again.
    Then I looked in every nook and cranny to find a file related to MP. Deleted every file and reinstalled version 2 rc2. Guess what. From the first try, I was able to add the server folder.

    Some way, a MP log prevented me from adding another share, and kept the same 20 objects appearing in the video shares.

    Anyway, thanks for your help, I hope someone else can learn from this experience as well.

    Regards,

    Frank
     

    Users who are viewing this thread

    Similar threads

    Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes, there will be many things. Main reason is simply, that MP2 is not developed based on MP1. I for example never used MP1. I tried it lately to test voice control and was shocked about many inconsistancies in...
    Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes...
    It´s been a while... :) Well, simply the reason is cause MP1 was working so well... :) Now I decided to upgrade my old servers and...
    Replies
    1
    Views
    191
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up a running mediaportal setup. Without the logs however, I don't have a clue on what exactly is wrong...
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up...
    Hi there, I'm a happy long time user and am currently using MP 1.25. Up until now I had no issues with my setup. Yesterday...
    Replies
    1
    Views
    485
    MP1 MP2 Local Data Refresh DE
    I also confirm that the issue is fine with movies. My initial query was because the importer was 'missing' some of the Season Posters and using the Series Poster by default. This is not resolved because there is no 'Refresh' Option for Seasons. So the only option at present is to remove the Series, double-check the info with tMM...
    I also confirm that the issue is fine with movies. My initial query was because the importer was 'missing' some of the Season...
    When I right-click (mouse) or Press 'i' (remote) I get the option to Reimport the data for a Movie or TV Series. This then...
    Replies
    8
    Views
    668
    Yo use Basic Home page or Classic Home page? Home Screen You can switch MyVideo to Database view - Database Views If you do not use Media Portal to watch TV, then you do not need it. If you are using it, check if the TV plug-in is enabled in the settings and whether it is displayed on the home screen. - Plugin Config Did you see...
    Yo use Basic Home page or Classic Home page? Home Screen You can switch MyVideo to Database view - Database Views If you do not...
    Hi. I am a first time user of MP1. My home page has the following tabs : Plugins/Settings/Videos/Music/Pictures. I can click on any...
    Replies
    1
    Views
    384
    Hi Issue is now resolved after testing. I found solution in another thread, there was the recommondation to change recording path to UNC instead of matching server drive directly with drive ID (windows style) Great I am happy now, BR Michael
    Hi Issue is now resolved after testing. I found solution in another thread, there was the recommondation to change recording path...
    Hi! I already searched existing threads here in forum, they sounded similar, but I do not succeed. Basically I have installed...
    Replies
    1
    Views
    751
    Top Bottom