First-time install, weird X10 remote error in log file

damaster

Portal Pro
November 23, 2007
412
28
Home Country
Canada Canada
TV-Server Version:
MediaPortal Version: 0.2.0.4
MediaPortal Skin: BlueTwo Wide
Windows Version: Windows Vista
CPU Type: AMD X2 6400+
HDD: WD SE16 500GB
Memory: 2GB DDR2 800
Motherboard: Gigabyte GA-MA69GM-S2H
Motherboard Chipset:
Motherboard Bios:
Video Card: ATI X1250
Video Card Driver: Catalyst 7.12
Sound Card:
Sound Card AC3:
Sound Card Driver:
1. TV Card:
1. TV Card Type:
1. TV Card Driver:
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
Satelite/CableTV Provider:
HTPC Case: nMedia 200BA
Cooling: Zalman CNPS8700NT
Power Supply: Corsair 450VX
Remote: Home Theater Master MX-700
TV: Toshiba 50H82
TV - HTPC Connection: Component

I installed MediaPortal 0.2.3.0 and then used update patch MediaPortal-update-0.2.0.4. I then configured MediaPortal and set it to use the MCE IR remote, since that's what I have. However, MediaPortal refuses to start up with the following error in the log file:

07/01/2008 10:59:49 PM Exception :Could not load file or assembly 'AxInterop.X10, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
07/01/2008 10:59:49 PM site :Void Init(IntPtr)
07/01/2008 10:59:49 PM source :RemotePlugins
07/01/2008 10:59:49 PM stacktrace: at MediaPortal.InputDevices.X10Remote.Init(IntPtr hwnd)
at MediaPortal.InputDevices.InputDevices.Init()
at MediaPortalApp.DoStartupJobs()
at MediaPortalApp..ctor()
at MediaPortalApp.Main(String[] args)
07/01/2008 10:59:49 PM MediaPortal stopped due 2 an exception Could not load file or assembly 'AxInterop.X10, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified. RemotePlugins at MediaPortal.InputDevices.X10Remote.Init(IntPtr hwnd)
at MediaPortal.InputDevices.InputDevices.Init()
at MediaPortalApp.DoStartupJobs()
at MediaPortalApp..ctor()
at MediaPortalApp.Main(String[] args)

I also can't start the test tool and get a error window on step 1 :(. Any ideas please?

Ignore this please, the problem went away with the latest SVN nightly build.
 

diehard2

Retired Team Member
  • Premium Supporter
  • April 22, 2006
    518
    0
    Chicago
    Home Country
    United States of America United States of America
    why would you install 0.2.0.4 over 0.2.3.0? The first sounds like a very, very old file.
     

    diehard2

    Retired Team Member
  • Premium Supporter
  • April 22, 2006
    518
    0
    Chicago
    Home Country
    United States of America United States of America
    Everything typically goes by build number. So, 0.2.0.4 would be the update to 0.2.0.3, but would be outdated for anything with a build number higher than 0.2.0.4. We unfortunately don't have a way of preventing incorrect patches from being applied at the moment.
     

    damaster

    Portal Pro
    November 23, 2007
    412
    28
    Home Country
    Canada Canada
    Ya, it would help if there was a built-in mechanism to avoid user errors like this. The worst part is I followed the documentation on the Wiki which points to that update page for users wanting to install a stable and tested update. Most users won't realize that a file called MediaPortal-update-0.2.0.4 should not be applied on top of install 0.2.3.0, since it only seems to imply that the update version # is 0.2.04. Especially since the Wiki docs point the user there.
     

    Andrew H
    Country flag

    MP Donator
  • Premium Supporter
  • September 8, 2007
    571
    18
    Alabama
    Home Country
    United States of America United States of America
    I've learned that the hard way myself, a few months back. So did you load the 0.2.3.0 final release yet? I'd really suggest getting the latest version and I personally have stayed away from nightly builds. What about the Nightly Build is so compelling that motivated you?
     

    damaster

    Portal Pro
    November 23, 2007
    412
    28
    Home Country
    Canada Canada
    0.2.3.0 final release with latest nightly builds works well for me mostly. Gonna stick to that :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom