home
products
contribute
download
documentation
forum
Home
Forums
New posts
Search forums
What's new
New posts
All posts
Latest activity
Members
Registered members
Current visitors
Donate
Log in
Register
What's new
Search
Search
Search titles only
By:
New posts
Search forums
Search titles only
By:
Menu
Log in
Register
Navigation
Install the app
Install
More options
Contact us
Close Menu
Forums
Products
TV-Server
For The Record - The rule-based scheduling suite
Contact us
RSS
JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding.
You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an
alternative browser
.
Reply to thread
Message
<blockquote data-quote="dvdfreak" data-source="post: 223131" data-attributes="member: 21313"><p>Aha, this is the error I was looking for. Look at this part:</p><p></p><p>"... where Title = @Title and () and ..."</p><p></p><p>The two brackets are wrong. And the reason is that the schedule is referencing TvChannels that are no longer there. That perfectly explains it actually, since you deleted them.</p><p></p><p>Try editing your schedules one-by-one and make sure the TV channels are correctly set (you'll probably notice the list will be empty instead of showing the channels). Then save the schedules again and all will be well again.</p><p></p><p>I have to think about how I could fix this for a next release. Either I remove the brackets and make the query work again, but then <u>all</u> channels will be included. Or I throw an error about the schedule containing unknown TV channels. What would be the best thing to do...?</p><p></p><p></p><p></p><p>No, that won't work for the same reason as above.</p><p></p><p>But I don't think the database has been upgraded since release 1.0.8.0, so you won't have a problem upgrading. If you <u>really</u> want to make sure you can still make a backup of the entire database before you upgrade, so you can always roll back to that.</p></blockquote><p></p>
[QUOTE="dvdfreak, post: 223131, member: 21313"] Aha, this is the error I was looking for. Look at this part: "... where Title = @Title and () and ..." The two brackets are wrong. And the reason is that the schedule is referencing TvChannels that are no longer there. That perfectly explains it actually, since you deleted them. Try editing your schedules one-by-one and make sure the TV channels are correctly set (you'll probably notice the list will be empty instead of showing the channels). Then save the schedules again and all will be well again. I have to think about how I could fix this for a next release. Either I remove the brackets and make the query work again, but then [U]all[/U] channels will be included. Or I throw an error about the schedule containing unknown TV channels. What would be the best thing to do...? No, that won't work for the same reason as above. But I don't think the database has been upgraded since release 1.0.8.0, so you won't have a problem upgrading. If you [U]really[/U] want to make sure you can still make a backup of the entire database before you upgrade, so you can always roll back to that. [/QUOTE]
Insert quotes…
Verification
Post reply
Forums
Products
TV-Server
For The Record - The rule-based scheduling suite
Contact us
RSS
Top
Bottom