[fixed] Forced subtitles still not work (1 Viewer)

ShIvADeSt

Portal Pro
May 30, 2009
71
2
MediaPortal Version: 1.2.0
MediaPortal Skin: DefaultWide
Sub engine is MPC-HC, Autoload option is off. Therefore forced subs must load and show. But it dont appears till button click. Logs attached. I made 2 actions
1. I start play film with forced sub, none subs is show, Stop playing.
without closing
2. I start play film again and click show subs. Forced subs appeared and I see it.
After it I 've closed MP and collect log.
In log such text
Main(1)]: Filter: E:\Фильмы\Фантастические Боевики\Терминатор\Терминатор 4 - Да Придет Спаситель (Режиссерская Версия).mkv - try to connect: Subtitle
2011-04-30 21:37:03.775719 [Debug][MPMain(1)]: - failed
 

infinite.loop

Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Country flag
    Am I right when I assume that you use the Haali Matroska Splitter for mkv's?
    Thats a bug in the nolonger maintained Haali Splitter.

    Force subtitles only work with MPC's mkv splitter or the lavf splitter.
     

    ShIvADeSt

    Portal Pro
    May 30, 2009
    71
    2
    When I try to use MPC splitter, I have problem, if film has 2 audio streams, both is playing in one time, but forced subs is showing.
    When I use LAV filters, I can switch between audio streams, but no forced subs appear. What I can did wrong?
    Which splitter I must use, that I can both switch between audio streams and autoload force subs?
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi,

    LAVF is not ready yet for forced sub in MP (it display forced when a forced sub is detect but it's not manage right now by MPC-HC Engine).
    Only Matroska splitter parse the Flag and manage with MPC-HC Engine.
    Effectively, you need to setup FFDShow audio to be the switcher of Audio Stream or add Mediaportal Audio Switcher in Post Processing Filter in Video Section (look the screenshot).
    My choice goes to add MP Audio Switcher :)
    Seb.
     

    Attachments

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    I have add the detection of Forced Flag for LAVF and now it works :)
    We can use LAVF and MP to detect if track are forced or not and automatly switch on it :p

    Autoload subtitles ON -> Try to match Subtitle with Subtitle Language set in setting.
    Autoload subtitles OFF -> Try to load Forced Flag, if no Forced Flag, all subtitle will be available but the setting was set on No Subtitle by Default.

    Seb.
     

    ShIvADeSt

    Portal Pro
    May 30, 2009
    71
    2
    Is it change in MP to load forced subs with LAV splitter or in current 1.2.0 beta it works too?
    I add MP Audio postprocessing for MPC splitter and all works fine, but I wanna now, how do the same for LAV filter.
    Coz I already tried all checkbox in LAVF for subtittles and no forced subs appeared. If it works in current 1.2.0 Beta can U give some screenshots for LAVF.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Is it change in MP to load forced subs with LAV splitter or in current 1.2.0 beta it works too?
    I add MP Audio postprocessing for MPC splitter and all works fine, but I wanna now, how do the same for LAV filter.
    Coz I already tried all checkbox in LAVF for subtittles and no forced subs appeared. If it works in current 1.2.0 Beta can U give some screenshots for LAVF.
    Hi,

    Yes a change is needed in MP for LAV Splitter Forced Flag, need to ask team if it will be added for 1.2.0RC.
    Good to know that if works for you for MP Audio postprocessing with MPC Splitter :)
    Regards,
    Seb.
     

    ShIvADeSt

    Portal Pro
    May 30, 2009
    71
    2
    What team said about adding feature to autoload forced subs when LAVF splitter is used? Don't see it in road map.
     

    scorpie

    Portal Pro
    November 5, 2009
    206
    8
    Nürnberg
    Germany Germany
    Hi,

    can someone tell me how to use the "MPC's mkv splitter" I updated to MP 1.2 cuz of the forced suptitles and uninstalled haali (couldn't see anything after that) because of that I installed Lav

    Changelog
    0.25 - 2011/05/06 - Release Notes
    Code:

    LAV Splitter
    - Added the ability to filter Blu-ray PGS subtitles, so only frames flagged as "forced" are delivered
    - Either through a new "Forced Subtitles" stream (default)
    - Or, filtering for every PGS stream (configurable)
    - Improved support for H264 in AVI
    - Improved timings for TrueHD in MKV
    - m2ts files directly openend inside a Blu-ray structure should now properly display stream languages
    - Alot of fixes and enhancements for format compatibility (especially MPEG-TS)
    - Support using the ArcSoft HD Audio Decoder for E-AC3
    in the hope that I can get the forced subs. I tried to add Lav to the Video Post Processing but if I activate it MP hangs. My vids are all mkvs.

    Would be nice to get some screenshots for the "MPC's mkv splitter" settings and how and where to add.

    Every help is welcome
    scorpie
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
    G [fixed] [MP2-811] Forced client wake-up at 2:00 2.2 Archive 32
    Neoculture Force installation of TV-Server? Newcomers Forum 3
    mickb Subtitles My TVSeries 9
    J How to change y position of subtitles General 3
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    S Remote button to change audio and subtitle on / off General 10
    P [solved] ATSC subtitles not fixed yet? General 2
    E Swedish subtitles problem General 2
    ratata Someone stole my subtitles... General Support 0
    Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    S Display non english folder name, subtitle, etc. General 23
    S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
    S [solved] Live TV subtitle issue if not using 100% font General 31
    D [solved] How to configure subtitle color in MP 2.2.1? General 5
    S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
    G [fixed] [MP2-611] Having problems with subtitles (ATSC) 2.2 Archive 14
    S Australia live TV teletext subtitle General 4
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    ratata Non present codecs is still showing... MediaPortal 1 Talk 2
    P [solved] TV server no longer saving to NAS - (can still play from NAS) General Support 2
    high [Help Me!] Atlassian Fisheye/Crucible still used? Team Lounge 8
    N Onscreen keyboard to still accept input from real keyboard Feature Requests 6
    Similar threads

























    Top Bottom