Hauppauge HVR-1800 not detected

Discussion in 'Installation, configuration support' started by RamonS, October 19, 2007.

  1. RamonS

    RamonS Portal Member

    Joined:
    October 8, 2007
    Messages:
    30
    Likes Received:
    0
    Ratings:
    +0 / 0
    TV-Server Version: n/a?
    MediaPortal Version: 0.2.3 RC3 SVN build 16281
    MediaPortal Skin: default
    Windows Version: XPSP2
    CPU Type: AMD Athlon 64 X2 5200+
    HDD: Seagate 320GB SATA2 RAID1
    Memory: 2 GB
    Motherboard: Asus M2N32-SLI Deluxe
    Motherboard Chipset: NVIDIA nForce® 570 SLI™ MCP
    Motherboard Bios: 1203
    Video Card: eVGA 7600GT 256MB PCIe 16x
    Video Card Driver: latest
    Sound Card: SoundMax HD onboard
    Sound Card AC3: ?
    Sound Card Driver: latest from Asus
    1. TV Card: Hauppauge HVR-1800
    1. TV Card Type: PCIe 1x, NTSC/ATSC/QAM/FM
    1. TV Card Driver: latest from Hauppuage CD 3.4d1
    MPEG2 Video Codec: ?
    MPEG2 Audio Codec: ?
    Satelite/CableTV Provider: TW
    Cooling: AMD CPU cooler, 2x 80mm, 1x 120mm case fans, chipset cooling via heatpipe, chipset fan for VGA card
    Power Supply: 550W Rosewell




    Note: The portions with ? are not out of ignorance, but I do not know how to obtain that information.

    Problem: Even with the latest nighly SVN build the HVR-1800 is not detected as a capture card in the configuration. And that puts an end to using MediaPortal right there.

    All logs that I could find are attached. And yes, I did search the forum (but gave up after going through dozens of pages of "results"), the wiki, the manual, the web, the docs, and my sock drawer. The card works fine with WinTV 6 / 2k, SageTV (trial), and BeyondTV (trial).

    Let me know if you need to know anything else or have me try something. Since it doesn't work we can't break anything either. :D

    Thanks in advance!
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. farmertom

    farmertom Portal Member

    Joined:
    September 7, 2007
    Messages:
    21
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    hauppuage hvr-1800 support

    Hi,
    Last I checked the hvr-1800 card is not listed in the CaptureCardDefintions.xml file. That is where your card gets detected. I have a hvr-1800 and had to add the definitions to the file. I only use the ASTC tuner on my hvr-1800. below is my is a link to my hack at the settings. Good luck...

    https://forum.team-mediaportal.com/hauppuage_hvr_1800_support-t28504.html

    farmertom
     
    • Like Like x 1
  4. Commodore 64
    • Premium Supporter

    Commodore 64 Retired Team Member

    Joined:
    June 20, 2005
    Messages:
    328
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
  5. RamonS

    RamonS Portal Member

    Joined:
    October 8, 2007
    Messages:
    30
    Likes Received:
    0
    Ratings:
    +0 / 0
    OK, I finally got around to take a go at this. The results are disappointing. I copied FarmerTom's XML section into the CaptureCardDefinitions.xml, but the capture card is still not detected.
    I also looked at the instructions on how to add cards and for the life of me I can't figure those instructions out. There are steps missing as it seems and the many "should" in there don't really make me trust the directions that much. I also found that the information asked for ended up to be always the same string. I totally lost it when it was about dragging something (what?) to the workspace and do a bunch of funky stuff with the pins. I did this using 0.2.2.0 as well as 0.2.3.0RC3 and neither one works out.
    I wonder if there is a way to extract the information from GraphEdit and then parse out what is needed (or what looks likely and have the user choose) and then stuff that into the CaptureCardDefinitions.xml.
    Other than that, my new FireFly remote works great with Media-Portal on both XP 32 bit and XP 64 bit. Would be nice if I could find a replacement for WinTV, which works, but has about 6 functions (on/off/ch+/ch-/vol+/vol-) and doesn't really work well with my new remote.

    Life would be boring if stuff is easy.
     
  6. farmertom

    farmertom Portal Member

    Joined:
    September 7, 2007
    Messages:
    21
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    More help

    Sorry you are having troubles with your hvr-1800. I have attached my CaptureCardDefinitions.xml file. Rename your old file and copy this one to the same MP directory. Maybe you copied the defintions to the wrong space, Not sure :confused:

    You are adding the card in the setup program? just checking...:)
    Good Luck!
    farmertom
     
  7. dman_lfc
    • Premium Supporter

    dman_lfc Retired Team Member

    Joined:
    July 28, 2004
    Messages:
    1,772
    Likes Received:
    30
    Occupation:
    Sales Manager
    Location:
    UK
    Ratings:
    +30 / 0
    Home Country:
    New Zealand New Zealand
    HVR-1800 support for ATSC OTA & NTSC is in SVN 16370 or later.
    Note: If you want QAM support you need TVServer.

    DMAN
     
  8. RamonS

    RamonS Portal Member

    Joined:
    October 8, 2007
    Messages:
    30
    Likes Received:
    0
    Ratings:
    +0 / 0
    Hi!
    First of all, thank you both for your help. I tried both farmertom's xml as well as the SVN build 16374. Both find the ATSC tuner without problem and can tune channels, which I can view in MP no problem (except for the SVN build freezing when maximizing the window, audio still goes). I also tried farmertom's xml on the SVN build 16374.
    The original xml from the SVN build also correctly identifies the NTSC tuner, but when I select it as a capture card I get the error "Unable to create graph for this device!!" twice before getting into the Properties, which lack the Autotune tab. Manually adding a channel and assigning that to the NTSC card fails, which didn't really surprise me.
    I then took the svn build 16374 xml, saved it, and installed it with the current stable release of MP. Same deal here, ATSC works fine, FM radio as well (which I haven't seen in the SVN build, but I didn't really look either*), NTSC analog cable is zip.
    On first sight, I cannot make out any drastic differences between the sections of the two XMLs. What is different is the commercial name, the interface line, and the way how the tags are formed in farmertom's xml. I did not test the different tag formatting as the tagging in the SVN build strikes me to be more following the official XML, e.g.
    farmertom:
    <capabilities tv="true" radio="true" mpeg2="true" mce="true" sw="false" bda="false"/>
    svn 16374:
    <capabilities tv="true" radio="false" mpeg2="true" mce="false" sw="false" bda="true"></capabilities>

    Anything I can do to help to make that graph be able to be created for the analog tuner/ capture? Is there maybe somehting missing in my system? What can I check and report on? It may help that I learn what a graph is in regards to PC TV.
    Also, where should I report the issues with the screen maximizing problem? Yea, I probably should read the release notes or such. Will do.

    In any case, thank you very much for all your help. I am sure that once 0.2.3 is released the problems will be ironed out.

    * I just noted that the SVN build 16374 xml has the radio set to disabled, which is correct for some models of the HVR-1800, but not for all. I guess I get FM configuration options when I set radio to true on the analog tuner.
     
  9. dman_lfc
    • Premium Supporter

    dman_lfc Retired Team Member

    Joined:
    July 28, 2004
    Messages:
    1,772
    Likes Received:
    30
    Occupation:
    Sales Manager
    Location:
    UK
    Ratings:
    +30 / 0
    Home Country:
    New Zealand New Zealand
    Hrmm, send me the info as outlined here...
    https://forum.team-mediaportal.com/getting_your_h_w_tvcard_supported_you-t1573.html

    Also for your version of the card, radio="true".

    DMAN
     
  10. farmertom

    farmertom Portal Member

    Joined:
    September 7, 2007
    Messages:
    21
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    RamonS
    Glad you got the ASTC tuner working. Please do not use my NSTC definitions for the hvr-1800, they DO NOT work, as you are finding out. Sorry I could not help more.

    farmertom
     
  11. RamonS

    RamonS Portal Member

    Joined:
    October 8, 2007
    Messages:
    30
    Likes Received:
    0
    Ratings:
    +0 / 0
    Thanks dman and farmertom! Dman, I emailed you something, but I have no idea if it is anything useful. I was tempted to expand all nodes in the Insert Filter window and screenshot everything, but I guess the interesting parts would be burried in tons of garbage.
    Let me know if I didn't do it right and let me know what exactly is needed. I don't complain or whine or demand anything, but for someone who is new to the whole idea of graphs, filters, and the like the instructions are not very detailed. I'd write up some better ones if I'd just know what the talk is about.
    I apologize in advance. :sorry:

    What I can do is craft a help file (I'm a tech writer) or do translations to German (don't know any other language besides English).

    OK, enough of my blubbering...and thanks a million again!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!