Help with TV setup (2 Viewers)

TLD

Portal Pro
October 26, 2007
714
126
Rainy Washington
Home Country
United States of America United States of America
Country flag
I've never heard of 'Silicondust'. Do you think it would help with our problem? Would it be safe?
I have seen Silicondust TV tuner cards before.
I think i would try other options first before installing this program as it seems TV server setup can see your tuners.
 

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,346
    1,428
    Southampton
    Home Country
    United Kingdom United Kingdom
    Country flag
    My driver looks be be old (2011). Should I update the driver? What worries me is loosing what I have. At this time I can at least watch TV.
    Yes, since the MP Wiki specifically mentions the driver version for the Hauppauge device, you should definitely update your Hauppauge driver. There may be a version that is even more-recent than the one mentioned by the Wiki. If there are multiple versions available, download and install the most recent. The following looks to be the current version (the name of the driver package suggests that it is from 2017-12-06):


    I understand your reluctance to mess-up a system that still works for WMC. The Hauppauge driver package is an EXE file contained within a ZIP file, so you download the ZIP file, unzip it, and then invoke "setup.exe". It will install the driver, and (from the description on the web page) update the device's firmware. It is not possible to tell ahead of time what exactly the EXE will do, but most installers preserve the existing driver so that you can use Windows to revert the driver to the previous version if necessary. However, you may not be able to revert the firmware update. Nevertheless, since the MP Wiki specifically mentions the minimum driver version required, you must perform this update to have any chance of using MP with your Hauppauge device.

    Note that the web page says that for Windows 7 the firmware update may not work initially, but you run it again (read the web page carefully before trying any updates).

    Also note that there is a separate download for the remote-control software. You may not need this if you use the WMC remote control instead of the Hauppauge remote control. (The WMC remote control works fine with MP.)

    -- frm CyberSimian in the UK
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,346
    1,428
    Southampton
    Home Country
    United Kingdom United Kingdom
    Country flag
    This is in "MediaPortal Configuration" see pic below.
    I was a bit lazy and did not show a screen shot of the relevant panel. :oops:

    Your screen shot shows that you do not have WMC services installed, so perhaps you are using Windows 10? For Windows 7, that panel looks like this:

    3rd_party_checks.jpg

    -- from CyberSimian in the UK
     

    TLD

    Portal Pro
    October 26, 2007
    714
    126
    Rainy Washington
    Home Country
    United States of America United States of America
    Country flag
    I think you should restart your computer after you disable WMC to make sure the components that start with windows are terminated before scanning for channels again.
     

    Old school Bob

    New Member
    August 13, 2020
    32
    1
    Home Country
    United States of America United States of America
    Country flag
    Sorry to be so late today. Busy day. Here's my plan of attack:
    Load new drivers.
    Disable WMC.
    Re-scan channels with MP.

    Hope everything works correctly.

    First problem - I checked my driver.
    driver 2.JPG
    Then I clicked on 'update driver'
    It came back with 'best driver is already installed' and it did check the internet.

    driver 1.JPG

    I did download the driver from Hauppauge but haven't installed it yet (no guts). Maybe later tonight.

    I think (and hope) if the new driver fails I can use 'system restore' to get the old driver back. I can't find any other drivers on Hauppauge.

    Thanks

    Bob
     

    Old school Bob

    New Member
    August 13, 2020
    32
    1
    Home Country
    United States of America United States of America
    Country flag
    I think you should restart your computer after you disable WMC to make sure the components that start with windows are terminated before scanning for channels again.

    Thanks TLD. I'll add that to my plan.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,346
    1,428
    Southampton
    Home Country
    United Kingdom United Kingdom
    Country flag
    Here's my plan of attack:
    Load new drivers.
    Disable WMC.
    Re-scan channels with MP.
    That looks fine, but I would reboot before scanning with MP. It may not be necessary to reboot after installing the new driver, but it won't do any harm.

    It came back with 'best driver is already installed' and it did check the internet.
    What I think is happening here is that Windows checks the Microsoft driver database on the Microsoft web site. The problem with this is that the Microsoft driver database often does not contain the most up-to-date drivers for every device that it knows about. So the database probably does not contain a newer driver for your device. However, the Hauppauge web site does have a newer driver, so you should install that.

    Also, the device name shown in your screen shot is Hauppauge WinTV DCR-2650 Consumer IR. Notice the IR at the end of the name. It is possible that you checked the driver for the Hauppauge infra-red remote control, and not the driver for the tuner box itself. :(

    I did download the driver from Hauppauge but haven't installed it yet (no guts).
    I too am usually careful about installing new drivers or other software on a working system. My custom is to copy the Windows partition, and then install the new driver or software in the partition copy. Then if it does not work, I can revert to the original partition. But I run a multi-boot system with many different bootable partitions, and I would not suggest this solution for someome who is not a computer expert. :(

    You will be installing the driver and firmware from the original device manufacturer, so I would be fairly confident that it would work correctly. :)

    If you are still wary, I would suggest creating a backup image of your Windows partition. This creates a compressed image of the entire drive, usually on an external USB disk. You can restore the image subsequently, if you need to return the system to its original state. There are several free tools that can do this, but if this is new to you, it is yet another tool that you need to learn before you can continue setting up MP. :(

    -- from CyberSimian in the UK
     

    TLD

    Portal Pro
    October 26, 2007
    714
    126
    Rainy Washington
    Home Country
    United States of America United States of America
    Country flag
    Sorry to be so late today. Busy day. Here's my plan of attack:
    Load new drivers.
    Disable WMC.
    Re-scan channels with MP.

    I always restart after changing drivers, you should be fine restarting after disabling WMC.

    Hope everything works correctly.

    I'm confident that the driver/firmware update will work fine. Did you note that on the driver download page it said the firmware update may fail but to just run the driver package program again.

    First problem - I checked my driver.
    View attachment 206490
    Then I clicked on 'update driver'
    It came back with 'best driver is already installed' and it did check the internet.

    View attachment 206491

    As CyberSimian said, That only checks the windows driver database on the Microsoft web site, and of the 6 different Hauppauge cards I've owned I've never seen a driver update for Hauppauge cards drivers from windows.

    I did download the driver from Hauppauge but haven't installed it yet (no guts). Maybe later tonight.
    As CyberSimian said, the driver you are looking at in the pic is for your remote, there is a new driver for that also shown at the bottom of the page where you downloaded the card driver from.
    You should install the new IR (Remote driver} also after installing the card driver as you will be updating the firmware for the device.
    Even if you don't use the remote.

    I think (and hope) if the new driver fails I can use 'system restore' to get the old driver back. I can't find any other drivers on Hauppauge.
    Always best to be safe, personally I keep a clone of all of my Windows OS drives that I update each quarter.
    I don't think you will have any issue. just be sure to restart after the driver updates.

    I would suggest scanning the "QAM Standard" range again first and them go delete the "encrypted/scrambled" channels and see what you come up with. If no green dot channels show up in the "TV Channels" section try another range and delete the "encrypted/scrambled" channels again, Repeat through all QAM ranges until you get green dot channels showing up in the "TV Channels" section. Then we can move on to mapping the channels to both tuners.
     

    TLD

    Portal Pro
    October 26, 2007
    714
    126
    Rainy Washington
    Home Country
    United States of America United States of America
    Country flag
    The driver for your card should show up in the section shown in the pic below.
     

    Attachments

    • Win device manager.PNG
      Win device manager.PNG
      31.9 KB · Views: 0

    Old school Bob

    New Member
    August 13, 2020
    32
    1
    Home Country
    United States of America United States of America
    Country flag
    Also, the device name shown in your screen shot is Hauppauge WinTV DCR-2650 Consumer IR. Notice the IR at the end of the name. It is possible that you checked the driver for the Hauppauge infra-red remote control, and not the driver for the tuner box itself.

    I didn't know IR was for the remote control. At the time it was the only Hauppauge device I could find.

    The driver for your card should show up in the section shown in the pic below.

    I looked under sound, video, and game controllers but didn't find Hauppauge. I did finally found it under Network Adapters.

    driver 01.JPG

    Next I tried to update driver but it said my driver was up to date. But it did have a button to "roll back driver".

    driver 02.JPG

    Hopefully when I update from Hauppauge that button will be enabled in case it fails.

    I'll let you know what happens.

    Thanks

    Bob
     

    Users who are viewing this thread

    Similar threads

    So after a long search and a lot of experiments I did find out the culprit: I did disable events of the Common Information Model Object Manager. As soon as they are disabled TV server will always show "port 554 is already bound". Enabling/disabling events is done by this reg key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM]...
    So after a long search and a lot of experiments I did find out the culprit: I did disable events of the Common Information Model...
    I've got a Digital Devices Cine S2 V7A Twin and a DigitalEverywhere FloppyDTV for Satellite TV. I've been running MediaPortal 1.4.0...
    Replies
    1
    Views
    299
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM] "EnableEvents"="0" As soon as I set it back to the default value 1, TV server did no longer say port 554 is bound and TV was working. On MediaPortal 1.4.0 and earlier the reg value could be set to 0 without any problem...
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM]...
    I've described my problem here: https://forum.team-mediaportal.com/threads/satellite-tv-not-working-in-mediaportal-1-28.140530/ And...
    Replies
    1
    Views
    655
    The "TV Server" part of MP is included in the MP download. However, it is installed only if you specify at install time that you will be using a TV tuner. If the install is successful, there are two config tools. You access these via shortcuts on the Windows desktop: MediaPortal Configuration TV Server Configuration -- from...
    The "TV Server" part of MP is included in the MP download. However, it is installed only if you specify at install time that you...
    I am a newbie coming over from MythTv. I have downloaded Media Portal 1.25 onto Win 10 Home. Installed OK but with no TV con fig. I...
    Replies
    1
    Views
    454
    It's described in WIKI. see last chapter here.
    It's described in WIKI. see last chapter here.
    OK, I'm not the best at software, I'd rather build computers. Anyway, I just want to use media portal as a TV tuner software. I...
    Replies
    2
    Views
    521
    Thanks CyberSimian, I'll see what I can find at the Green Button web site.
    Thanks CyberSimian, I'll see what I can find at the Green Button web site.
    Hi Folks, I have a Dell XPS Desktop computer that I've had an Analog Angel USB TV Tuner hooked up to for the past 5+ years that...
    Replies
    7
    Views
    1K
    Top Bottom