High pitched audio artifacts

Discussion in 'Television (MyTV frontend and TV-Server)' started by Lyxalig, March 28, 2007.

  1. Lyxalig
    • Premium Supporter

    Lyxalig MP Donator

    Joined:
    January 30, 2005
    Messages:
    276
    Likes Received:
    1
    Occupation:
    IT student
    Location:
    Norway
    Ratings:
    +1 / 0
    Home Country:
    Norway Norway
    MediaPortal Version:
    MediaPortal Skin:
    Windows Version: Windows XP SP2
    CPU Type: Intel P4 2.4Ghz
    HDD: WD 120GB x2 + Samung 80GB
    Memory: 1GB
    Motherboard: MSI MS-6728
    Motherboard Chipset: Intel 865PE
    Motherboard Bios:
    Video Card: Radeon 9550se (256 MB)
    Video Card Driver:
    Sound Card: Creative SB Live! Series
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Hauppuge PVR-500
    1. TV Card Type: analog
    1. TV Card Driver: original
    2. TV Card: Hauppauge NOVA-T stick (not in use)
    2. TV Card Type: DVB-T
    2. TV Card Driver: original
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: MPV
    MPEG2 Audio Codec: MPA
    Satelite/CableTV Provider:
    HTPC Case: SilverStone S10
    Cooling:
    Power Supply:
    Remote: Microsoft MCE Philips
    TV: Samsung 40"
    TV - HTPC Connection: D-SUB

    Hi, I'm not sure if this is a bug or not, but it sure should'nt be like this... But here goes:

    I've recently tried using the Tvserver3 in single seat, as Tv engine 2 has audio-sync issues. I've used it before with great success, but decided to wait a bit. Now, I got back to trying it becasue of dropped recordings with tvE2.

    So to my current issue: When watching a live stream I get some weird audio artifacts. When there are "intensity" in the audio, I get loud high-pitched "squeeks". It is not only making me cracy, but it actually damages my hearing. I'm getting fysically sick?



    Definition of "intensity" in the audio:
    If there is a man speaking in a low tone: no problems.
    Jingle: Lots of artifacts.
    Woman speaking (high pitched voice): Some artifacts.

    So how on earth does this happen, and am I the only one having this..

    Logs does'nt say anything but here is my tv.log:

    28.03.2007 14:51:19 Detected analog card:hauppauge wintv pvr pci ii tvtuner
    28.03.2007 14:51:19 Detected analog card:hauppauge wintv pvr pci ii tvtuner
    28.03.2007 14:51:19 PluginManager: Loaded ConflictsManager version:1.0.0.1 author:Broceliande
    28.03.2007 14:51:19 PluginManager: Loaded Power Scheduler version:0.1.0.0 author:micheloe
    28.03.2007 14:51:19 PluginManager: Loaded ServerBlaster version:1.0.0.0 author:Julio - based on smirnuff code
    28.03.2007 14:51:19 PluginManager: Loaded TV Movie EPG import version:0.2.2.1 author:mPod / rtv
    28.03.2007 14:51:19 PluginManager: Loaded XmlTv version:1.0.0.0 author:Frodo
    28.03.2007 14:51:19 PluginManager: Loaded Zap2it EPG Client version:1.8 author:Jonathan <bradsjm>
    28.03.2007 14:51:19 Controller: Started at HTPC
    28.03.2007 14:51:19 Controller: local ip adress:192.168.0.101
    28.03.2007 14:51:19 Controller: server running on HTPC
    28.03.2007 14:51:19 Controller: setup hybrid cards
    28.03.2007 14:51:19 Controller: setup streaming
    28.03.2007 14:51:19 Scheduler: started
    28.03.2007 14:51:19 Scheduler: loaded 16 schedules
    28.03.2007 14:51:19 Plugin:ConflictsManager started
    28.03.2007 14:51:19 plugin: ConflictsManager started
    28.03.2007 14:51:19 Plugin:power Scheduler disabled
    28.03.2007 14:51:19 Plugin:confused:erverBlaster disabled
    28.03.2007 14:51:19 Plugin:TV Movie EPG import disabled
    28.03.2007 14:51:19 Plugin:XmlTv started
    28.03.2007 14:51:19 plugin: xmltv started
    28.03.2007 14:51:19 Plugin:Zap2it EPG Client disabled
    28.03.2007 14:51:19 Controller: initalized
    28.03.2007 14:51:19 Controller: epg start
    28.03.2007 14:51:19 ConflictManager: Updating conflicts list
    28.03.2007 14:52:23 Controller: StartTimeShifting National Geographic 21
    28.03.2007 14:52:23 Controller: find free card for channel National Geographic
    28.03.2007 14:52:23 Controller: got 1 tuning details for National Geographic
    28.03.2007 14:52:23 Controller: card:1 type:Analog is available priority:2 #users:0 same transponder:False
    28.03.2007 14:52:23 Controller: card:2 type:Analog is available priority:1 #users:0 same transponder:False
    28.03.2007 14:52:23 card: CardTune 2 National Geographic HTPC:2:-1
    28.03.2007 14:52:23 card:Tune 2 to National Geographic
    28.03.2007 14:52:23 card:user:HTPC:2:-1 tune tv:National Geographic Freq:0 Channel:94 Country:Norway Tuner:Cable Video:Tuner
    28.03.2007 14:52:23 card: to different transponder
    28.03.2007 14:52:23 analog: Tune:tv:National Geographic Freq:0 Channel:94 Country:Norway Tuner:Cable Video:Tuner
    28.03.2007 14:52:23 analog: build graph
    28.03.2007 14:52:23 analog: AddTvTunerFilter Hauppauge WinTV PVR PCI II TvTuner
    28.03.2007 14:52:23 analog: AddCrossBarFilter
    28.03.2007 14:52:23 analog: AddCrossBarFilter try:Hauppauge WinTV PVR PCI II Crossbar
    28.03.2007 14:52:23 analog: FindCrossBarPin type:Video_Tuner direction:Input
    28.03.2007 14:52:23 analog: FindCrossBarPin inputs:8 outputs:2
    28.03.2007 14:52:23 analog: pin 0 type:Video_Tuner
    28.03.2007 14:52:23 analog: FindCrossBarPin found pin at index:0
    28.03.2007 14:52:23 analog: ConnectFilter()
    28.03.2007 14:52:23 analog: PinDest:name:0: Video Tuner In Direction:Input
    28.03.2007 14:52:23 analog: pinSource 0:name:Analog Video Direction:Output
    28.03.2007 14:52:23 analog: pins connected
    28.03.2007 14:52:23 analog: AddCrossBarFilter succeeded
    28.03.2007 14:52:23 analog: AddTvAudioFilter
    28.03.2007 14:52:23 analog: FindCrossBarPin type:Audio_Tuner direction:Input
    28.03.2007 14:52:23 analog: FindCrossBarPin inputs:8 outputs:2
    28.03.2007 14:52:23 analog: pin 0 type:Video_Tuner
    28.03.2007 14:52:23 analog: pin 1 type:Audio_Tuner
    28.03.2007 14:52:23 analog: FindCrossBarPin found pin at index:1
    28.03.2007 14:52:23 analog: AddTvAudioFilter try:Hauppauge WinTV PVR PCI II TvAudio
    28.03.2007 14:52:23 analog: ConnectFilter()
    28.03.2007 14:52:23 analog: PinDest:name:TVAudio In Direction:Input
    28.03.2007 14:52:23 analog: pinSource 0:name:Analog Video Direction:Output
    28.03.2007 14:52:23 analog: pinSource 1:name:Analog Audio Direction:Output
    28.03.2007 14:52:23 analog: pins connected
    28.03.2007 14:52:23 analog: AddTvAudioFilter succeeded:Hauppauge WinTV PVR PCI II TvAudio
    28.03.2007 14:52:23 analog: AddTvCaptureFilter
    28.03.2007 14:52:23 analog: AddTvCaptureFilter try:Hauppauge WinTV PVR PCI II Capture
    28.03.2007 14:52:24 analog: AddTvCaptureFilter succeeded:0x0
    28.03.2007 14:52:24 analog: FindCapturePin on capture filter
    28.03.2007 14:52:24 analog: AddTvEncoderFilter
    28.03.2007 14:52:24 analog: AddTvEncoderFilter found:2 encoders
    28.03.2007 14:52:24 analog: try encoder:Hauppauge WinTV PVR PCI II Encoder
    28.03.2007 14:52:24 analog: encoder in-pin1:name:656 Direction:Input
    28.03.2007 14:52:24 analog: AddTvEncoderFilter no media types for pin1
    28.03.2007 14:52:24 analog: ConnectEncoderFilter video:True audio:False
    28.03.2007 14:52:24 analog: found pin#0 name:656 Direction:Input
    28.03.2007 14:52:24 analog: pinsAvailable on capture filter:6
    28.03.2007 14:52:24 analog: capture pin:2 name:Capture Direction:Output
    28.03.2007 14:52:24 analog: capture pin:3 name:Audio Out Direction:Output
    28.03.2007 14:52:24 analog: capture pin:4 name:VBI Direction:Output
    28.03.2007 14:52:24 analog: capture pin:5 name:656 Direction:Output
    28.03.2007 14:52:24 analog: connected pin:5 656 with pin0
    28.03.2007 14:52:24 analog: ConnectEncoderFilter succeeded
    28.03.2007 14:52:24 analog: AddTvEncoderFilter succeeded
    28.03.2007 14:52:24 analog: FindCapturePin on encoder filter
    28.03.2007 14:52:24 analog: FindCapturePin pin:name:MPEG Direction:Output
    28.03.2007 14:52:24 analog: FindCapturePin major:e436eb83-524f-11ce-9f53-0020af0ba770 sub:e06d8022-db46-11cf-b4d1-00805f6cbbea
    28.03.2007 14:52:24 analog: FindCapturePin succeeded
    28.03.2007 14:52:24 analog: FindVBIPin
    28.03.2007 14:52:24 analog: SetupTeletext()
    28.03.2007 14:52:24 analog: teletext setup
    28.03.2007 14:52:24 analog: AddMpeg2Demultiplexer
    28.03.2007 14:52:24 analog: connect capture->mpeg2 demux
    28.03.2007 14:52:25 Hauppauge Quality Control Initializing No DX Error
    28.03.2007 14:52:25 Hauppauge Set Bit Rate No DX Error
    28.03.2007 14:52:25 Hauppauge set video parameters - Max kbps: 6000, Min kbps: 4000, VBR True
    28.03.2007 14:52:25 analog: Graph is built
    28.03.2007 14:52:25 analog: RunGraph
    28.03.2007 14:52:25 analog: set to TV
    28.03.2007 14:52:26 analog: SetupCrossBar:Tuner
    28.03.2007 14:52:26 crossbar pin:0 type:Video_Tuner
    28.03.2007 14:52:26 route input:Video_Tuner -> video output result:0
    28.03.2007 14:52:26 crossbar pin:1 type:Audio_Tuner
    28.03.2007 14:52:26 route input:Audio_Tuner -> audio output result:0
    28.03.2007 14:52:26 crossbar pin:2 type:Video_SVideo
    28.03.2007 14:52:26 crossbar pin:3 type:Video_Composite
    28.03.2007 14:52:26 crossbar pin:4 type:Audio_Line
    28.03.2007 14:52:26 crossbar pin:5 type:Video_SVideo
    28.03.2007 14:52:26 crossbar pin:6 type:Video_Composite
    28.03.2007 14:52:26 crossbar pin:7 type:Audio_Line
    28.03.2007 14:52:26 Analog: Tuned to video:231250000 Hz audio:236750000 Hz locked:True
    28.03.2007 14:52:26 card: tuned user:HTPC subchannel:0
    28.03.2007 14:52:26 user:HTPC add
    28.03.2007 14:52:26 card: Tuner locked:True signal strength:100 signal quality:100
    28.03.2007 14:52:26 card2:HTPC 2 0
    28.03.2007 14:52:26 control1:HTPC 2 0
    28.03.2007 14:52:26 control2:HTPC 2 0
    28.03.2007 14:52:26 Controller: delete timeshift files C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts
    28.03.2007 14:52:26 Controller: delete C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts.tsbuffer
    28.03.2007 14:52:26 Controller: delete C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts.tsbuffer1.ts
    28.03.2007 14:52:26 card: StartTimeShifting 2 C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts
    28.03.2007 14:52:26 card: WaitForUnScrambledSignal
    28.03.2007 14:52:26 card: return not scrambled
    28.03.2007 14:52:26 Analog: StartTimeShifting()
    28.03.2007 14:52:26 analog: StopGraph
    28.03.2007 14:52:26 analog: DeleteTimeShifting
    28.03.2007 14:52:26 analog:AddMpegMuxer()
    28.03.2007 14:52:26 analog:connect pinvideo->mpeg muxer
    28.03.2007 14:52:26 analog:connect pinaudio->mpeg muxer
    28.03.2007 14:52:26 analog:AddTsFileSink
    28.03.2007 14:52:26 analog:connect muxer->tsfilesink
    28.03.2007 14:52:26 analog:confused:etTimeShiftFileName:C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts
    28.03.2007 14:52:26 analog:confused:etTimeShiftFileName: uses .ts
    28.03.2007 14:52:26 analog: RunGraph
    28.03.2007 14:52:27 card: WaitForTimeShiftFile
    28.03.2007 14:52:27 card: WaitForUnScrambledSignal
    28.03.2007 14:52:27 card: return not scrambled
    28.03.2007 14:52:28 card: timeshifting fileSize:0
    28.03.2007 14:52:29 card: timeshifting fileSize:142880
    28.03.2007 14:52:29 card: timeshifting fileSize:166380
    28.03.2007 14:52:29 card: timeshifting fileSize:331256
    28.03.2007 14:52:29 card: timeshifting fileSize:498012
    28.03.2007 14:52:29 card: timeshifting fileSize:663452 0
    28.03.2007 14:52:29 user:HTPC card:2 sub:0 add stream:C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts.tsbuffer
    28.03.2007 14:52:29 RTSP: start streamer
    28.03.2007 14:52:29 RTSP: Streamer started
    28.03.2007 14:52:29 RTSP: add stream stream2.0 file:C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts.tsbuffer
    28.03.2007 14:52:29 Controller: StartTimeShifting started on card:2 to C:\Program Files\Team MediaPortal\MediaPortal TV Server\live2-0.ts.tsbuffer
    28.03.2007 14:53:25 Controller: StopTimeShifting 2
    28.03.2007 14:53:25 card: StopTimeShifting user:HTPC sub:0
    28.03.2007 14:53:25 user:HTPC remove
    28.03.2007 14:53:25 Stopcard
    28.03.2007 14:53:25 analog: StopGraph
    28.03.2007 14:53:25 analog: DeleteTimeShifting
    28.03.2007 14:53:25 analog: remove tsfilesink
    28.03.2007 14:53:25 analog: mpeg muxer
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Lyxalig
    • Premium Supporter

    Lyxalig MP Donator

    Joined:
    January 30, 2005
    Messages:
    276
    Likes Received:
    1
    Occupation:
    IT student
    Location:
    Norway
    Ratings:
    +1 / 0
    Home Country:
    Norway Norway
  4. dukeelam

    dukeelam Portal Member

    Joined:
    September 30, 2006
    Messages:
    31
    Likes Received:
    6
    Ratings:
    +6 / 0
    Home Country:
    Sweden Sweden
    Can be the same problem i had, overheating on the TV card decoder chip.
    I had to mount a fan on my heatsink. I have a different card though and the 500 does not have a heatsink, if the pictures i googled are correct. Anyway if the airflow trough your case is poor around the TV card it can overheat. Try running the case open and use a hairdryer (w.o the heat on :D ) to cool the card. As its encoded to your mpeg stream i figure its either the TV card or something the chipset creates.

    Regards
    Duke
     
  5. Lyxalig
    • Premium Supporter

    Lyxalig MP Donator

    Joined:
    January 30, 2005
    Messages:
    276
    Likes Received:
    1
    Occupation:
    IT student
    Location:
    Norway
    Ratings:
    +1 / 0
    Home Country:
    Norway Norway
    Hi, I'll surely try this, but the thing is that this problem does not apply to TVEngine2. So my only guess is that it has something to do with TVengine 3. As I said in the earlier post I've successfully had TVengine 3 running without these issues.

    I hope some developer will take a look into this, and that someone with hauppage cards can confirm this.

    Thanks again for your reply
     
  6. Rhys.Goodwin

    Rhys.Goodwin Portal Pro

    Joined:
    November 20, 2006
    Messages:
    336
    Likes Received:
    1
    Occupation:
    Systems Admin
    Ratings:
    +1 / 0
    Home Country:
    New Zealand New Zealand
    Sorry guys I should have followed up my own post! (https://forum.team-mediaportal.com/bad_audio_hauppauge_prv_150_tv3_rev-t21087.html) By comparing SVN revsions I found that this problem was introduced in REV13498 when diehard2 set the audio of the hauppauge to 192Kbps. I've spoken to him about it and he said that it should not cause this issue but we will set it to 228kbps to see if that helps. I'm not sure what it defaults to if it is not set at all. (Previous to 13498 it was not set at all). I'm glad someone else is having this issue, I still thouht it might be specific to something strange on my setup!

    Cheers,
    Rhys
     
  7. Rhys.Goodwin

    Rhys.Goodwin Portal Pro

    Joined:
    November 20, 2006
    Messages:
    336
    Likes Received:
    1
    Occupation:
    Systems Admin
    Ratings:
    +1 / 0
    Home Country:
    New Zealand New Zealand
    Lyxalig are you using the tuner or the LineIN+SVIDEO OR Both on your Hauppuge PVR-500? I only use the LineIN+SVIDEO I was wonding if the the problem was only with this. I'm wonding why no one else has reported this problem
     
  8. Lyxalig
    • Premium Supporter

    Lyxalig MP Donator

    Joined:
    January 30, 2005
    Messages:
    276
    Likes Received:
    1
    Occupation:
    IT student
    Location:
    Norway
    Ratings:
    +1 / 0
    Home Country:
    Norway Norway
    Hi,

    I only use the tuner. Isn't there any developer who can have a look at this? You said the sound gets compressed now.. Is it hardcoded? I can't find any place for settings...
     
  9. Rhys.Goodwin

    Rhys.Goodwin Portal Pro

    Joined:
    November 20, 2006
    Messages:
    336
    Likes Received:
    1
    Occupation:
    Systems Admin
    Ratings:
    +1 / 0
    Home Country:
    New Zealand New Zealand
    Yes it is hardcoded in TvCardAnalogBase.cs. Developer Diehard2 is aware of the problem and said that he will see what he can do about getting an option to change this in TVSetup. But I'm sure like most volunteer devs he only has a little time avaliable to work on MP. So I guess we'll just have to wait :) Or you can SVN the source and compile your self, I don't really know how tho so I think I'll just wait till it's fixed. The squeaky audio is annoying tho I agree! :)
     
  10. Lyxalig
    • Premium Supporter

    Lyxalig MP Donator

    Joined:
    January 30, 2005
    Messages:
    276
    Likes Received:
    1
    Occupation:
    IT student
    Location:
    Norway
    Ratings:
    +1 / 0
    Home Country:
    Norway Norway
    I might just try that. Thanks for the info. I'm a it student, and know c# fairly well... I'll try my best..
     
  11. Rhys.Goodwin

    Rhys.Goodwin Portal Pro

    Joined:
    November 20, 2006
    Messages:
    336
    Likes Received:
    1
    Occupation:
    Systems Admin
    Ratings:
    +1 / 0
    Home Country:
    New Zealand New Zealand
    How did you get on? Maybe you could submit a patch? ;-)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!