Home menu

Discussion in 'X-Factor' started by leftfield, February 18, 2010.

  1. leftfield
    • Premium Supporter

    leftfield MP Donator

    Joined:
    July 23, 2008
    Messages:
    29
    Likes Received:
    0
    Ratings:
    +0 / 0
    I've got two problems with my home menu screen:

    1. Backgrounds aren't displayed except Games & Sports. Only the defaults are there, I've never changed the images. Something strange happens on movies and seems to quickly display the movies image followed by the settings image before a blank background reappears.
    2. Whenever returning to the main menu it's always got movies highlighted regardless of where I've just been. Not sure if this an issue on my configuration or a feature ;)

    Any help would be greatly appreciated.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. cul8er
    • Premium Supporter

    cul8er Retired Team Member

    Joined:
    August 31, 2006
    Messages:
    2,159
    Likes Received:
    2,682
    Ratings:
    +2,698 / 0
    Home Country:
    Sweden Sweden
    Hi,

    Thank you for your report. Can you please upload the fanarthandler.log from your mediaportal log directory. You find the directory by pressing your windows start button and go Programs\Team MediaPortal\MediaPortal. Also, what version of MP are you using? Last, can you please upload your basichome.xml file. I think this is the same issue intered had in this thread (link). If so the solution should be the same.

    best regards
    cul8er
     
  4. jmcentire

    jmcentire Portal Pro

    Joined:
    November 7, 2008
    Messages:
    85
    Likes Received:
    68
    Ratings:
    +69 / 0
    Home Country:
    United States of America United States of America
    I had the same problem, followed instructions in the link above and it fixed it!
     
  5. leftfield
    • Premium Supporter

    leftfield MP Donator

    Joined:
    July 23, 2008
    Messages:
    29
    Likes Received:
    0
    Ratings:
    +0 / 0
    Sorry for the delay. See files attached.

    Note Fanarthandler.log does not get any information inserted into it when I reproduce this problem. ie If I delete the log file, go into media portal and navigate around the main menu, the log file isn't even recreated. I have included one as an example though in case it helps.

    I am using MP v1.0.4.23491 but I'm sure I had the same issue with 1.02.

    I haven't upgraded to the latest skin yet, would you rather I did that? I wanted to wait a while before upgrading.

    I've looked at the link you suggested, I don't have a Fanarthandler.org in the database directory. I haven't removed Fanarthandler.db3 yet given the other file was missing.

    Thanks again for a great skin!
     

    Attached Files:

    • BasicHome.xml
      File size:
      30.6 KB
      Uploaded:
      February 22, 2010
      Views:
      117
  6. ryan20021982
    • Premium Supporter

    ryan20021982 Retired Team Member

    Joined:
    June 27, 2008
    Messages:
    655
    Likes Received:
    83
    Occupation:
    Prison Guard
    Location:
    USA
    Ratings:
    +83 / 0
    Home Country:
    United States of America United States of America
    He asked for the

     
  7. leftfield
    • Premium Supporter

    leftfield MP Donator

    Joined:
    July 23, 2008
    Messages:
    29
    Likes Received:
    0
    Ratings:
    +0 / 0
    And that is what i've attached. The other files I mentioned are from the thread Cul8er discussed.
     
  8. cul8er
    • Premium Supporter

    cul8er Retired Team Member

    Joined:
    August 31, 2006
    Messages:
    2,159
    Likes Received:
    2,682
    Ratings:
    +2,698 / 0
    Home Country:
    Sweden Sweden
    Hi leftfield,

    I will release a new version of the skin within a couple of days. Speed improvements and some improvements in onlinevideos and so on. It will also include version 1.5 of the fanart handler plugin and that will hopefully solve your problem. As you haven't upgraded your xfactor skin you have a very old version of the fanart handler plugin installed and also miss the fanarthandler.org database file that is required. Please hold on for a day or so until the new version is out.

    best regards
    cul8er
     
    • Like Like x 1
  9. leftfield
    • Premium Supporter

    leftfield MP Donator

    Joined:
    July 23, 2008
    Messages:
    29
    Likes Received:
    0
    Ratings:
    +0 / 0
    Will do, thanks again.
     
  10. leftfield
    • Premium Supporter

    leftfield MP Donator

    Joined:
    July 23, 2008
    Messages:
    29
    Likes Received:
    0
    Ratings:
    +0 / 0
    Much appreciatedd, that fixed the problem with the images not displaying.

    I notice that XFactor still doesn't seem to remember which menu it was in when you return to the main menu. Instead it returns to the main menu with the highlighted menu bein the one selected in 'Default Menu' in the configuration tool.

    So If I've gone into TV Series and returned to the main menu it would return with movies highlighted if that is my default menu. This isn't how applications normally work but is there a design reason behind it happening here.
     
  11. cul8er
    • Premium Supporter

    cul8er Retired Team Member

    Joined:
    August 31, 2006
    Messages:
    2,159
    Likes Received:
    2,682
    Ratings:
    +2,698 / 0
    Home Country:
    Sweden Sweden
    Hi leftfield,

    Thanks for your feedback. The reason why I haven't used the "remember last focused" feature is that it caused to many problems. I will see if MP 1.1 have solved them because this was in the 1.0.2 days;) I'll let you know if this is working in MP1.1 and if I will include it in next version.

    cheers
    cul8er
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!