How to run ir.exe or bat file when MP exits? - fixed (1 Viewer)

Nielsen

Portal Pro
December 6, 2004
98
0
Home Country
Denmark Denmark
Hi

I have some application that uses the ir.exe from Hauppauge, and works fine. But my problem is that when Hauppauge remote is enabled in MP, the ir.exe is stopped when starting or exiting MP. So after I have used MP my other applications can not be controlled by remote before I manually runs ir.exe again.

So I am looking for at way to run ir.exe automatically every time MP exit/stops, how do I do that?
One way is to run a bat-file when MP exits, but how?

I have found something in that home plugin, but I can not make it works. Are there a description how to make this plugin to work?

I am using MP 0.2 RC2 CVS 05-02-06.

Best regards
Martin
 

wewe

Portal Pro
August 3, 2005
362
0
61
Herxheim
Home Country
Germany Germany
in earlier versions MP did stop ir when entering and RESTART ir when exiting. I don't know if that feature was removed or if it is currently just not working as desired.

Maybe mPod reads that thread ...

thanks+regards
WeWe
 

mPod

Portal Pro
January 26, 2005
2,084
3
Berlin
Home Country
Germany Germany
wewe said:
Maybe mPod reads that thread ...
He does. :wink:

Strange that nobody spotted this before. It must have been for a while like this. I got it fixed here, it will be committed as soon as the investigations concerning HVR-1300 cards are done. Of course IR.exe will be started automatically on MP close then (if it was running on MP start).

You gotta wait a bit...
 

Nielsen

Portal Pro
December 6, 2004
98
0
Home Country
Denmark Denmark
hi

That sounds great; I will look forward to that.

Just a thought, would it be difficult to put it in the next CVS or would it be waist of time to do that before the HVP-1300 problem is solved?


To Khris
I have made such a bat file, but it is not executed when MP is started from PVR scheduler.

Best regards
Martin

keep up the good work :D
 

mPod

Portal Pro
January 26, 2005
2,084
3
Berlin
Home Country
Germany Germany
Problem is, I can't put that file into CVS atm, cause there are too many changes that are not fully completed yet. And for this I need the HVR-1300 to complete (verify, test, etc.) the changes. Those current changes depend on each other.
If I would put the current changed file into CVS, this would break it for all Hauppauge remote controls (and CVS wouldn't compile anymore). And if I'd do that, there are some users/devs out there who'd really love to rip my balls then. Well... I still need them, so keep your fingers crossed that Hauppauge doesn't need much more time until the card arrives.

You might wanna try 0.2RC2 (or RC1?), I think that bug is not in those versions. Not sure if that's okay for you. If not, you gotta wait a bit.
 

wewe

Portal Pro
August 3, 2005
362
0
61
Herxheim
Home Country
Germany Germany
to mPod: I did notice it long ago, but I don't want to get the title: 'nagger of the year' :wink:

thanks+regards
WeWe
 

Nielsen

Portal Pro
December 6, 2004
98
0
Home Country
Denmark Denmark
Hi

Thank you. Fast work I must say.

I have installed the latest CVS (mediaportal-cvs-02-10-2006--01-05) but it doesn’t seem to restart ir.exe yet or at least not on my computer.

Is the restarting ir.exe fix included in this CVS version or?

Best regrads
Martin
 

Users who are viewing this thread

Top Bottom