Imon LCD Display (e.g. Silverstone GD01)

Discussion in 'Mini Display' started by spraycleaner, January 7, 2007.

Thread Status:
Not open for further replies.
  1. spraycleaner

    spraycleaner Portal Member

    Joined:
    December 25, 2004
    Messages:
    31
    Likes Received:
    0
    Ratings:
    +0 / 0
    I have just swapped my LC16M Silverstone VFD Display /iMON remote system out with the newer GD01 LCD(!) Display type still with iMon Remote!

    But now I cannot get MP to work with this newer display, are there anybody working on this? I simply think that there is no support for the display in MP its not because I have the wrong setup or anything...

    The Silverstone GD01 housing was first out about 06.01 2006 so its not THAT new!


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Zeuser

    Zeuser Portal Member

    Joined:
    May 10, 2006
    Messages:
    19
    Likes Received:
    0
    Ratings:
    +0 / 0
    I can't get the GD01 LCD to work either. I may have to try LCDSmartie or C.All and see what happens.
     
  4. knutinh

    knutinh Portal Pro

    Joined:
    September 4, 2005
    Messages:
    558
    Likes Received:
    2
    Ratings:
    +2 / 0
    How do you think this display works compared to the VFD in terms of brightness and font-size?

    Does it affect the IR reception?

    I guess integrating those "symbol" parts of the LCD is going to be a challenge...

    [​IMG]

    -k
     
  5. thanatos

    thanatos Portal Member

    Joined:
    April 12, 2007
    Messages:
    23
    Likes Received:
    0
    Occupation:
    System Engineer
    Location:
    Munich
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Hi JoeDalton,

    now I've turnde the MP debuging on and started MP - after navigation a while I closed it again. Like you said, now there are many entries from the External Display Plugin in it.

    Here are the (in my opinion) most interesting parts - if you need something different, just let me know:

    2007-04-19 15:29:21.015625 [Info.][MPMain]: ExternalDisplay plugin starting...
    2007-04-19 15:29:21.015625 [Debug][MPMain]: ExternalDisplay: Determining configured display type...
    2007-04-19 15:29:21.015625 [Debug][MPMain]: ExternalDisplay: Searching type iMON...
    2007-04-19 15:29:21.031250 [Info.][MPMain]: ExternalDisplay: Loading drivers...
    2007-04-19 15:29:21.031250 [Debug][MPMain]: ExternalDisplay: Loading DebugForm...
    2007-04-19 15:29:21.031250 [Debug][MPMain]: ExternalDisplay: Loading VLSYSLis2...
    2007-04-19 15:29:21.031250 [Debug][MPMain]: ExternalDisplay: Loading iMON...
    2007-04-19 15:29:21.031250 [Debug][MPMain]: ExternalDisplay: Loading ClipBoard...
    2007-04-19 15:29:21.031250 [Debug][MPMain]: ExternalDisplay: Loading Girder...
    2007-04-19 15:29:21.031250 [Debug][MPMain]: ExternalDisplay: Loading MediaPad...
    2007-04-19 15:29:21.140625 [Debug][MPMain]: ExternalDisplay: Loading PropertySetter...
    2007-04-19 15:29:21.140625 [Debug][MPMain]: ExternalDisplay: Loading CrystalFontz634...
    2007-04-19 15:29:21.140625 [Debug][MPMain]: ExternalDisplay: Loading HD44780JD...
    2007-04-19 15:29:21.140625 [Debug][MPMain]: ExternalDisplay: Loading T6963CJD...
    2007-04-19 15:29:21.140625 [Debug][MPMain]: ExternalDisplay: Loading NoritakeGU7000...
    2007-04-19 15:29:21.140625 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\ba66.dll...
    2007-04-19 15:29:21.156250 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\belc.dll...
    2007-04-19 15:29:21.156250 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\bt62005.dll...
    2007-04-19 15:29:21.171875 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\eep_serial.dll...
    2007-04-19 15:29:21.171875 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\fanomatic.dll...
    2007-04-19 15:29:21.187500 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\futabavfd.dll...
    2007-04-19 15:29:21.187500 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\hd44780.dll...
    2007-04-19 15:29:21.187500 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\hd44780_4x40.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\hd61830.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\HP12542R.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\iMonVfd.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\irtrans.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\ks0108_128x64.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\lcdh_g15.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\lintec1601.dll...
    2007-04-19 15:29:21.203125 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\lph7508.dll...
    2007-04-19 15:29:21.218750 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\m50530s.dll...
    2007-04-19 15:29:21.218750 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\m50530_24x8.dll...
    2007-04-19 15:29:21.218750 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\MT-12232A.dll...
    2007-04-19 15:29:21.218750 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\nju6426.dll...
    2007-04-19 15:29:21.234375 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\noritake_gu3900.dll...
    2007-04-19 15:29:21.234375 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\noritake_gu7000.dll...
    2007-04-19 15:29:21.234375 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\noritake_gu_128x32_311.dll...
    2007-04-19 15:29:21.234375 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\noritake_tseries.dll...
    2007-04-19 15:29:21.234375 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\pcd8544.dll...
    2007-04-19 15:29:21.234375 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\PCF8548.dll...
    2007-04-19 15:29:21.234375 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\sed133x.dll...
    2007-04-19 15:29:21.250000 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\sed133x_usb_lui.dll...
    2007-04-19 15:29:21.250000 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\sed1520.dll...
    2007-04-19 15:29:21.250000 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\sed1530.dll...
    2007-04-19 15:29:21.250000 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\slx2016.dll...
    2007-04-19 15:29:21.250000 [Debug][MPMain]: ExternalDisplay: Loading C:\Programme\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\t6963c.dll...
    2007-04-19 15:29:21.250000 [Debug][MPMain]: ExternalDisplay: Driver loading complete...
    2007-04-19 15:29:21.250000 [Debug][MPMain]: ExternalDisplay: Requested type was found.
    2007-04-19 15:29:21.281250 [Debug][ExternalDisplay]: Entering run loop.
    2007-04-19 15:29:21.281250 [Debug][ExternalDisplay]: Creating displayhandler.
    2007-04-19 15:29:21.281250 [Debug][ExternalDisplay]: Starting displayhandler.
    2007-04-19 15:29:21.328125 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:21.328125 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    2007-04-19 15:29:21.328125 [Debug][ExternalDisplay]: Detected status is Idle
    2007-04-19 15:29:21.343750 [Debug][ExternalDisplay]: ExternalDisplay: Sending lines to display.
    2007-04-19 15:29:21.390625 [Debug][ExternalDisplay]: Sleeping...
    2007-04-19 15:29:21.687500 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:21.687500 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    2007-04-19 15:29:21.687500 [Debug][ExternalDisplay]: Detected status is Idle
    2007-04-19 15:29:21.687500 [Debug][ExternalDisplay]: ExternalDisplay: Sending lines to display.
    2007-04-19 15:29:21.734375 [Debug][ExternalDisplay]: Sleeping...
    2007-04-19 15:29:22.031250 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:22.031250 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    2007-04-19 15:29:22.031250 [Debug][ExternalDisplay]: Detected status is Idle
    2007-04-19 15:29:22.031250 [Debug][ExternalDisplay]: ExternalDisplay: Sending lines to display.
    2007-04-19 15:29:22.078125 [Debug][ExternalDisplay]: Sleeping...
    2007-04-19 15:29:22.375000 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:22.375000 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    2007-04-19 15:29:22.375000 [Debug][ExternalDisplay]: Detected status is Idle
    2007-04-19 15:29:22.375000 [Debug][ExternalDisplay]: ExternalDisplay: Sending lines to display.
    2007-04-19 15:29:22.421875 [Debug][ExternalDisplay]: Sleeping...
    2007-04-19 15:29:22.718750 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:22.718750 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    2007-04-19 15:29:22.718750 [Debug][ExternalDisplay]: Detected status is Idle
    2007-04-19 15:29:22.750000 [Debug][ExternalDisplay]: ExternalDisplay: Sending lines to display.
    2007-04-19 15:29:22.796875 [Debug][ExternalDisplay]: Sleeping...
    2007-04-19 15:29:23.093750 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:23.093750 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    2007-04-19 15:29:23.093750 [Debug][ExternalDisplay]: Detected status is Idle
    2007-04-19 15:29:23.093750 [Debug][ExternalDisplay]: ExternalDisplay: Sending lines to display.
    2007-04-19 15:29:23.140625 [Debug][ExternalDisplay]: Sleeping...
    2007-04-19 15:29:23.437500 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:23.437500 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    2007-04-19 15:29:23.437500 [Debug][ExternalDisplay]: Detected status is Idle
    2007-04-19 15:29:23.437500 [Debug][ExternalDisplay]: ExternalDisplay: Sending lines to display.
    2007-04-19 15:29:23.484375 [Debug][ExternalDisplay]: Sleeping...
    2007-04-19 15:29:23.781250 [Debug][ExternalDisplay]: Processing status.
    2007-04-19 15:29:23.781250 [Debug][ExternalDisplay]: Active window is WINDOW_HOME

    I think the most interesting part is "ExternalDisplay: Requested type was found.
    " ...
    Is there something else I can try? Give you any further informations, or help?
    ...Just let me know!

    Thx
     
  6. Johan

    Johan Portal Pro

    Joined:
    April 19, 2006
    Messages:
    443
    Likes Received:
    11
    Ratings:
    +11 / 0
    Home Country:
    Sweden Sweden
    There are more and more people reporting about this.
    It's strange that not normal text is working with this new iMON LCD.
    At the moment I don't care about the symbols. I want at least text to be displayed.

    I have also posted in the soundgraph forum to ask for help and what the difference is with the VFD and the LCD. Let's hope we can figure this out. I am not a programmer so I am not able to help JoeDalton with anything. I hope I get some interesting info from the soundgraph crew.
     
  7. JoeDalton
    • Premium Supporter

    JoeDalton Retired Team Member

    Joined:
    September 27, 2004
    Messages:
    425
    Likes Received:
    18
    Gender:
    Male
    Occupation:
    IT Architect
    Location:
    Belgium
    Ratings:
    +18 / 0
    Home Country:
    Belgium Belgium
    Show System Specs
    Did you already try the other iMon driver in the list?

    Also try to copy the SG_VFD.dll from your Soundgraph\imon folder and overwrite the version in the MP home folder.

    And don't forget to check "Use third party plugins" in your imon options. This will make the iMon software virtually useless, but that is the way Soundgraph wants it:(

    Joe

    PS: I merged the thread about the iMon display from the General section with this one. I like to keep this part of the forum as clean as possible:D
     
  8. hirscho

    hirscho Portal Pro

    Joined:
    December 24, 2006
    Messages:
    186
    Likes Received:
    10
    Ratings:
    +15 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hello there

    At first I would like to thank the developers for their hard work on MP. It is great piece of software and for me only one thing is missing for my perfect HTPC and that is the support of this new iMON LCD display.

    I don't know if it helps, but I couldn't get the LCD display run together with MediaPortal neither. So just to test I downloaded the "iMON VFD API" from the SoundGraph support homepage. It includes an example program that so I thought should work with the new LCD display. I activated the plug-in feature in in the iMON manager I used the SG_VFD.dll from the newest driver package and .... it doesn't work.

    Joe, I really hope you can make run.

    Hirscho
     
  9. thanatos

    thanatos Portal Member

    Joined:
    April 12, 2007
    Messages:
    23
    Likes Received:
    0
    Occupation:
    System Engineer
    Location:
    Munich
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Ok, I'm back with a few new results.
    Here is what I did:

    I installed the latest SVN snapshot (MediaPortal-svn--04-20-2007--00-59-Rev14213.exe).
    After that I replaced Mediaportals Version of the "SG_VFD.dll" with the one out of the Soundgraph Folder - Mediaportal Version is something 3.x and the newest Soundgraph Version is 5.x
    After that I started Mediaportal and - at least - in the logfile its looking not to bad now :D :

    - snip -
    2007-04-20 19:19:32.203125 [Debug][MPMain]: ExternalDisplay: Driver loading complete...
    2007-04-20 19:19:32.203125 [Debug][MPMain]: ExternalDisplay: Requested type was found.
    2007-04-20 19:19:32.218750 [Debug][ExternalDisplay]: Entering run loop.
    2007-04-20 19:19:32.218750 [Debug][ExternalDisplay]: Creating displayhandler.
    2007-04-20 19:19:32.218750 [Debug][ExternalDisplay]: Starting displayhandler.
    2007-04-20 19:19:32.265625 [Debug][ExternalDisplay]: Processing status.
    2007-04-20 19:19:32.265625 [Debug][ExternalDisplay]: Active window is WINDOW_HOME
    - snip -

    Before I "updated" the SG_VFD.dll it said something like "not found" - now this changed to "Requested type was found." :)

    I Also tried both drivers in the External Plugin Configuration Page "iMon VFD" and "SoundGraph iMon USB Driver 1.0".
    In iMon i checked and unchecked the "3rd party" option along with any configuration of "Frontview" I could think of (start always / never / auto, Frontview Automode, Frontview Plugin Mode) and also completely turned off Imon.

    In any case - sorry to say that - i could not get the display to show any information. :(

    I think, the replacement of the old SG_VFD.dll was a step in the right direction :)thx: for that hint, JoeDalton) - any ideas out there, where to go from here?
     
  10. JoeDalton
    • Premium Supporter

    JoeDalton Retired Team Member

    Joined:
    September 27, 2004
    Messages:
    425
    Likes Received:
    18
    Gender:
    Male
    Occupation:
    IT Architect
    Location:
    Belgium
    Ratings:
    +18 / 0
    Home Country:
    Belgium Belgium
    Show System Specs
    If even the example program from Soundgraph doesn't work, I doubt I can get it to work either. Try contacting Soundgraph support to get at least the example program working. Then we can try to get it to work in MP too...

    Joe
     
  11. Johan

    Johan Portal Pro

    Joined:
    April 19, 2006
    Messages:
    443
    Likes Received:
    11
    Ratings:
    +11 / 0
    Home Country:
    Sweden Sweden
    thanatos, it actually said "ExternalDisplay: Requested type was found." in your previous log file as well. I dont want to dissapoint you but there does not seem to be any difference (log wise) from the new dll.

    I have asked for API that are working with the LCD from soundgraph. I hope they care about their customers and provide a working demo program/code that will work with the LCD.

    P.S. thanatos - they sent the case today! I have the tracking number :)
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!