iMon Ultrabay - rc does not work as expected (1 Viewer)


Portal Member
January 2, 2009
Home Country
Norway Norway
TV-Server Version: (Remote tv-server)
MediaPortal Version:
MediaPortal Skin: Blue 3
Windows Version: Vista Home Premium (SP1)
CPU Type: Intel Core 2 Duo E8400
HDD: Samsung Spinpoint F1 1 TB
Memory: 4GB
Motherboard: Gigabyte GA-E7AUM-DS2H (Rev 1.0)
Video Card: Nvidia GeForce 9400 (Integrated)
Video Card Driver:
Sound Card: Nvidia
Sound Card AC3: Nvidia
Sound Card Driver:
1. TV Card: External TV-tuner
1. TV Card Type:
1. TV Card Driver:
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
h.264 Video Codec:
Satelite/CableTV Provider: Canal Digital (Analog cable)
HTPC Case: AeroCool Racer
Cooling: Original
Power Supply: Corsair VX 450W
Remote: iMON Ultrabay 7.20.0502
TV: LG42PG3000
TV - HTPC Connection: HDMI

I have had some trouble to get the display and remote to work properly with MediaPortal.
Seems like the LCD-problem was solved after I gived the HTPC-user administrative privilegies in the OS.

But I am still strugling with Remote and buttons on the display. I have searched on the forum here and also followed the detailed guide on MediaPortal - Setup guide for Silverstone LC16M Case | iMon Remote Setup, iMon VFD Setup, iMon Front Button Hack without success.

My problem is
1) Every second time I start the computer, the iMON-remote work as expected. The next time it works as a mouse and is hopeless to in use. After a boot it is okey again without changing any configuration.

2) The knob and buttons on the display worked (at least) once and it was very nice since I was able to navigate through MP-menues by turning and pressing the navigation-knob. Now it is not working anymore, and I am not able to reverse the changes done in the meanwhile.

Anyone who have experience and solution on this problem?


MP Donator
  • Premium Supporter
  • January 17, 2009
    Home Country
    United States of America United States of America
    I do not have a display with buttons but do have a Soundgraph LCD and remote (Silverstone branded).

    I followed this post and it works great for me.

    My settings are here.

    A few notes. I have checked in MP Config to set remote to keyboard (ie not use mouse functions). I do not know exactly where it is, but I think it is under General in the MP Config GUI. Also, there is a key on the remote above the 8way pay...Keyboard/Mouse I think it is called. This switches between the two modes regardless of application you are using. So you might be pressing it...???

    Hopefully this will get you started in the correct path.



    Portal Member
    January 2, 2009
    Home Country
    Norway Norway
    Still the same problem, the RC works as a mouse and not as a RC. The "Keyboard/mouse"-toggle-key have no effect. This problem is very annoying since it is rather hard to navigate through MP this way.

    I have tried to follow the description as best I can, but the menu-choice for "3rd party" and the possibility to change some Windows-command is for some reason disabled. That may be because I happened to install latest driver from iMON and then downgraded again.

    I am not able to make the front key working neither, but the display works now allmost as expected. The last shown TMP-message is left on displayed after the computer is shutdown and powered off. Instead of the title of the last movie shown, I would much better like to see actual time (but not in the uggly font that iMON have used).

    Any help or hints, anyone?



    Retired Team Member
  • Premium Supporter
  • November 8, 2008
    What version of IMON software are you using?

    i use imon remote and have no probs getting it to work with MP

    there's a toggle in the IMON control panel to set the remote to default to keyboard (instead of mouse mode)

    Under Settings -> Remote Controller
    Remote Controller = iMON PAD
    Initial Keyboard/Mouse Mode = Keyboard

    Import the attached mediaportal.imo settings file

    Click Import
    Open the mediaportal.imo file you saved to the desktop
    Select Import Values including "RC Button Name" and "RC Setup"
    Click Import

    Users who are viewing this thread

    Top Bottom