Import von Videos unvollständig (1 Viewer)

Ghostangel

New Member
August 1, 2021
2
0
Home Country
Germany Germany
Country flag
Hallo zusammen,

ich hatte vor längerer Zeit das MP1 genutzt und dann eine Weile ausgesetzt. Derzeit baue ich einen HTPC zusammen der mir als Mediaserver dienen soll und baue dafür eine neue Datenbank auf.
Ich dachte ich gehe direkt zu MP2 weil dort auch die digitalen Radiosender mit angeboten werden als Plugin aber beim Import der Videos habe ich Probleme.
Bei den Serien hatte ich diese auch aber hier war die Namensgebung das Problem und dies konnte durch eine Korrektur behoben werden.
Bei den Videos leider nicht. Ich habe viele Videos nicht als ISO sondern direkt als .MP4, .avi und.FLV vorliegen. Die Namen habe ich abgeglichen trotzdem werden viele Videos nicht erkannt wie zum beispiel Elektra oder 2 Fast 2 Furious. Obwohl richtig geschrieben erscheinen die Filme nicht beim Import während andere Filme des gleichen Formats erkannt werden. Auch in der Ansicht Filme wo alle eigentlich erscheinen sollen, tauchen diese nicht auf also weder unter Filme noch Videos und beim Import sehe ich auch anhand der Anzahl der Dateien, das diese zu wenig sind.

Hat jemand eine Idee?

Mfg
Chris
 

Lehmden

Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    Die Filme und Serien, die nicht "auftauchen" müssten alle unter "Videos" zu finden sein. Es sind nämlich zwei Paar Schuhe, das Video selbst einzulesen und es dann mit den richtigen Online Metadaten zu versorgen. Speziell bei Filmen gibt es (zu) viele Filme mit identischem Namen. Die können ohne weitere Hilfe dann nicht gefunden werden.
    Falls sie auch unter Videos nicht auftauchen, musst du mal von Datenbank- Ansicht auf Ordner- Ansicht umstellen und schauen, ob du die fehlenden Filme dann findest und sie abspielen kannst. Falls ja, hat der Import in die Datenbank nicht geklappt und du solltest ihn einfach noch mal ausführen. Speziell beim ersten Import von sehr vielen Dateien kann das schon mal vorkommen, da der Importer dann schlicht zu viel zu tun hat...

    Wenn sie auch dann nicht gefunden werden sie nicht als Videos erkannt. Das passiert normalerweise nur, wenn entweder die Dateiendung nicht erkannt wird oder das Video selbst beschädigt ist. Leider sind sehr viel mehr beschädigte Videos als heile im Umlauf. Manche Player (wie etwa VLC) kommen mit "halb-kaputten" Videos besser klar als andere. MP nutzt dazu die Windows- eigene DirectX Geschichte, wie sie auch z.B. vom Windows Media Player oder von MPC HC verwendet werden. Das liefert in aller Regel eine sichtbar bessere Bildqualität als etwa VLC, ist dafür aber empfindlicher auf Unstimmigkeiten bei den Videos.

    Generell ist es aber mit Abstand am Sinnvollsten, alle Filme und Serien mit lokalen Metadaten und Grafiken zu versehen. Dann braucht man bei keinem HTPC System (außer MP1 bei Serien, wo das immer noch nicht unterstützt wird) jemals wieder einen langwierigen und ungenauen Online Abgleich vornehmen. Der Import, egal ob in MP, Kodi, Plex, Emby, Jellyfin,... klappt dann mit 100% Trefferquote...
    Dazu gibt es diverse Tools wie z.B. TinyMediaManager oder mein eigenes Tool Media-Buddy... Zu beiden gibt es hier im Forum umfangreiche Posts und meist auch direkt schnelle Hilfe... Es gibt auch andere derartige Tools, die nur hier nicht so verbreitet sind. So lange sie lokale Fanart und .nfo Dateien erzeugen können, ist es eigentlich egal, welches Tool man verwendet. Macht einmalig vermeintlich sehr viel Arbeit, ist auf lange Sicht hin aber erheblich bequemer, genauer und auch schneller...
     

    Ghostangel

    New Member
    August 1, 2021
    2
    0
    Home Country
    Germany Germany
    Country flag
    Hi,

    vielen dank für den Input. Sie werden weder unter Filme noch Videos erkannt. Bei der Anzahl gibt es auch Differenzen. Den Import hatte ich mehrmals durchgeführt. Der Ansatz mit den Metadaten werde ich versuchen. Gibt es ein Programm was du empfehlen kannst?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    Gibt es ein Programm was du empfehlen kannst?
    Na ja, wenn ich so ein Programm schon selbst geschrieben habe, dann nutze ich das Programm natürlich auch selbst. Von daher bin ich da wohl nicht ganz unparteiisch. Wenn du Media-Buddy mal ausprobieren möchtes, den Link gibt es in meiner Signatur.

    Obwohl ein Ausstatten mit lokalen Metadaten grundsätzlich das mit Abstand Beste ist, was man seiner Medien- Sammlung antun kann, dürfte es dir nur wenig bei deinem Problem helfen. Denn wenn die Dateien auch nicht in Videos auftauchen, erkennt MP sie erst gar nicht als Video Dateien... Das passiert nur, wenn sie erheblich beschädigt oder tatsächlich keine Video Dateien sind...
     

    Users who are viewing this thread

    Similar threads

    Hier ist das Branch mit dem TVMosaic Provider Plugin. GitHub - MediaPortal/MediaPortal-2 at FEAT_TvMosaicClient Wenn es jemand testen will, kann ich daraus einen Installer erstellen. Dann wissen wir zumindest, ob wir eine funktionierende Basis haben.
    Hier ist das Branch mit dem TVMosaic Provider Plugin. GitHub - MediaPortal/MediaPortal-2 at FEAT_TvMosaicClient Wenn es jemand...
    Hallo. Seit ein paar Tagen ist der ehemals kommerzielle TV Server TVMosaic Open Source, da die Herstellerfirma den Betrieb...
    Replies
    4
    Views
    256
    Please find the log files attached. At first I had all files in a simple "test" directory. This caused it to crash with a reference to line 36561. Searching for said line lead to to a forum post that hinted at the importance of the directory structure. Once I found that, I could sort the issue myself.
    Please find the log files attached. At first I had all files in a simple "test" directory. This caused it to crash with a reference...
    Hallo liebe Mediaportalcommunity, da ich recht neu zum MP2 gekommen bin, weiß ich nicht ob mein Problem ein echter Bug oder nur...
    Replies
    26
    Views
    2K
    Hallo alle zusammen. Ich habe den Fehler nun endlich ausfindig gemachen. Die MP2 trifft keine Schuld. So wie es aussieht "blockiert" das CAM Modul die Tuner, weil sie "zugewiesen" sind. Obwol kein Modul enthalten ist, versuchen die Karten wohl darüber ein Signal zu erhalten oder zu entschlüssen. Dies schlägt fehl und blockiert so den...
    Hallo alle zusammen. Ich habe den Fehler nun endlich ausfindig gemachen. Die MP2 trifft keine Schuld. So wie es aussieht...
    Hallo. Ich habe ein Problem mit meiner TV Karte und eurer Software. Aus irgendeinen Grund findet die MP2 beim Sendersuchlauf keine...
    Replies
    6
    Views
    465
    Hallo! Danke für die Rückmeldung! Habe mit MP3 Playlist getestet, hat reibungslos funktioniert. Serie habe ich leider nicht. Ich habe nun die Audiodateien neu verbunden, diesmal habe ich Netzwerkpfad vom Server (\\SERVER\AUDIO\") statt das direkte Mapping wie "D:\Audio" verwendet. Nun wird nicht mehr jeder 2. Song übersprungen. Wow...
    Hallo! Danke für die Rückmeldung! Habe mit MP3 Playlist getestet, hat reibungslos funktioniert. Serie habe ich leider nicht. Ich...
    Hallo! ich habe ein Problem, dass bereits im Forum zu einer recht alten Version (2018) bereits einmal diskutiert wurde. Wenn ich...
    Replies
    7
    Views
    429
    Hallo, ich bin umgezogen und an der neuen Adresse gibt es leider nur Kabel und kein Sat. Bekomme ich das irgendwie zum laufen? Also gibt es eine Möglichkeit, dass ich TV über MediaPortal gucken kann? Zwar findet der Rechner einige Sender, aber z.B. Dmax gibt es nicht als "frei". Also brauche ich ein CI-Modul und eine Smartcard. Diese...
    Hallo, ich bin umgezogen und an der neuen Adresse gibt es leider nur Kabel und kein Sat. Bekomme ich das irgendwie zum laufen? Also...
    Hallo, ich bin umgezogen und an der neuen Adresse gibt es leider nur Kabel und kein Sat. Bekomme ich das irgendwie zum laufen? Also...
    Replies
    0
    Views
    169
    Top Bottom