Installer misdetects XP Pro x64, and crashes at end.

Discussion in '0.2.3.0 RC3 and SVN Builds' started by Al_Capone, October 17, 2007.

  1. Al_Capone
    • Premium Supporter

    Al_Capone MP Donator

    Joined:
    September 26, 2006
    Messages:
    527
    Likes Received:
    13
    Gender:
    Male
    Ratings:
    +19 / 1
    Home Country:
    Norway Norway
    Show System Specs
    Installing RC3 on XP Pro x64 gives this message : "Warning windows 2003 not supported"
    then it continues after clinking OK.
    later on, it crashes:

    "${NAME} has encountered an problem and needs to close"

    AppName: mediaportal_0.2.3.0_rc3_setup.exe AppVer: 0.2.3.0 ModName: unknown
    ModVer: 0.0.0.0 Offset: 03a4c550



    attaching what windows would like to send to M$:
    it crashes like that each time. (The resulting install seems working fine, so file-copying is probably done)
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Al_Capone
    • Premium Supporter

    Al_Capone MP Donator

    Joined:
    September 26, 2006
    Messages:
    527
    Likes Received:
    13
    Gender:
    Male
    Ratings:
    +19 / 1
    Home Country:
    Norway Norway
    Show System Specs
    ..and the same happens when uninstalling.

    - and during a clean installation (even default installation directory removed)
     
  4. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    Wonder why XP x64 it's detected as Windows 2003, have looked @ the NSIS installer script & which message did you get , was it this one: "MediaPortal is not support on Windows 2003. Use at your own risk"?

    Are your windows version NT 5.2?

    Regards
    Roy
     
  5. Al_Capone
    • Premium Supporter

    Al_Capone MP Donator

    Joined:
    September 26, 2006
    Messages:
    527
    Likes Received:
    13
    Gender:
    Male
    Ratings:
    +19 / 1
    Home Country:
    Norway Norway
    Show System Specs
    yes, and ver returns, "... [Version 5.2.3790]"
     
  6. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    Yeah the problem it's that MS has same build number(5.2) of XP Pro x64, Windows 2003 & Windows Home Server.
    This problem it's fixed in installer but will not be in before final or next RC release.

    Regards
    Roy
     
  7. Al_Capone
    • Premium Supporter

    Al_Capone MP Donator

    Joined:
    September 26, 2006
    Messages:
    527
    Likes Received:
    13
    Gender:
    Male
    Ratings:
    +19 / 1
    Home Country:
    Norway Norway
    Show System Specs
    could the later crash be related to this simple thing ?
    the installer both installs, and uninstalls, as far I can see, just fine, but it crashes at end of each operation (install and uninstall)
     
  8. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    Dunno, will contact you if you're interested of course when we start testing final release, so you can test.
    Actually this could be a problem with uninstall.exe, have some errors regarding that one in my event log on vista x64, will check that further to see if it's anything know problem around.

    Regards
    Roy
     
  9. Al_Capone
    • Premium Supporter

    Al_Capone MP Donator

    Joined:
    September 26, 2006
    Messages:
    527
    Likes Received:
    13
    Gender:
    Male
    Ratings:
    +19 / 1
    Home Country:
    Norway Norway
    Show System Specs
  10. RamonS

    RamonS Portal Member

    Joined:
    October 8, 2007
    Messages:
    30
    Likes Received:
    0
    Ratings:
    +0 / 0
    I use the RC3 and SVN builds on XP 64bit as well, and yes, the installer detects it as W2k3, but I don't get any crashing.
     
  11. PCPete

    PCPete New Member

    Joined:
    September 9, 2008
    Messages:
    4
    Likes Received:
    0
    Occupation:
    Audio Engineering
    Location:
    Melbourne, Australia
    Ratings:
    +0 / 0
    Home Country:
    My (limited) understanding is that XP x64 is basically Windows Server 2003 x64 with the 32-bit XP GUI more-or-less bolted/glued on. I guess that's why MP reports the OS as S2003. Not sure if this is helpful or useful, but I'm looking around for x64 ideas and ways I can help get MP running on XP x64, so...
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!