iPiMP 5.1.0 issues & fixes (1 Viewer)

Status
Not open for further replies.

cheezey

Community Plugin Dev
August 26, 2004
1,560
312
51
West Yorks, UK
United Kingdom United Kingdom
  • Thread starter
  • Moderator
  • #1
Sometimes the installer reports the error....

URL reservation failed

The MPCC process plugin is what iPiMP uses to communicate with your MediaPortal clients. It listens on 2 ports, one for TCP communications and one for HTTP communications. By default the TCP port is set to 55667 and the HTTP port is 55668 (TCP port + 1). There is a requirement to reserve HTTP endpoints on some versions of windows, the iPiMP installer tries to do this for you, reserving the MPCC url on the default HTTP port of 55668. If this fails then after the installer completes run this command:

Code:
netsh http add urlacl url=http://*:55668/mpcc sddl=D:(A;;GX;;;WD)
Also, if you change the MPCC port you will also have to change this URL reservation. To do that run the following commands:

Code:
netsh http delete urlacl url=http://*:55668/mpcc
Code:
netsh http add urlacl url=http://*:<new http port>/mpcc sddl=D:(A;;GX;;;WD)
EDIT
On Windows XP (and Server 2003) you'll need to use HTTPCFG.EXE, which is available in the Windows XP Support Tools.

The command would be:

Code:
httpcfg.exe set urlacl /u http://*:55668/mpcc /a "D:(A;;GX;;;WD)"
 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
R MP2 GUI Issues General 7
morpheus_xx [WiP] WIP 2.3 Fanart issues? MediaPortal 2 13
morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
W Not finding/matching new series - thetvdb issue? My TVSeries 3
J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
1gkar Latest Intel HD4600 Drivers Issue General Support 1
J Odd issues with Freesat EPG - MP2 General 18
DHosein Mediaportal & Antimalware Service High CPU issue General Support 2
J MediaPortal TV Server and Kodi media source issues General 9
S Movie navigation issues in MP2 General 8
cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
2BitSculptor MP1.23 release mediainfo issue? MediaPortal 1 Talk 4
A TV Channel Combination - case issue Television (MyTV frontend and TV-Server) 0
Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
G Amazon Prime (Online Videos) Issue Plugin Development 6
joecrow 1.22.0 MPE Manager issues. 1.22 5
M [solved] MP2 v 2.2.1 Issue - Registry Key not created General 5
D [solved] Multiple issues with new MP2.2.1 install 2.2 Archive 7
S [solved] Live TV subtitle issue if not using 100% font General 31
T FF or Rewind video issue watch/edit Videos 0
K server issue OffTopic 0
T Issues with MediaPortal not starting correctly using versions after 1.20 Final General Support 6
johns11 [solved] MP2.2 TV configuration issue General 4
A Issues with new install of My Emulators 2 My Emulators 11
R [fixed] [MP2-799] New Manual Schedule issue. 2.2 Archive 8
Top Bottom