ISDN no CallerID crashes MP (1 Viewer)

Webcomber

Portal Member
January 5, 2006
26
0
Home Country
Netherlands Netherlands
Country flag
I use 0.2 RC2, no CSVs (please see full details in my first post https://forum.team-mediaportal.com/viewtopic.php?t=12088&highlight= ).

When I receive a phone call over ISDN with suppressed CallerID, ie. from abroad or from companies that suppress their CallerID, my MediaPortal crashes.

To be precise, on my primary monitor I get the Crash window, but MP stays fully active and functional on my secondary monitor. Only when I click the OK in the crash window, MP dies abruptly.

This is the tail of my log:

22-2-2006 10:18:10 window:MediaPortal.GUI.Home.HomeWindow init
22-2-2006 11:16:36 ISDN: CAPI command: 0x02 / 0x82
22-2-2006 11:16:36 ISDN: Buffer: (10)(161)35zzzzzzz(2)(0)(163)(0)(0)(3)(128)(144)(163)(0)(2)(145)(129)(4)
Note: my Dutch area code is 035, I edited out my 7 digit subscriber number.


When I receive a call with CallerID it works OK, although not perfectly. I had to add modified phone numbers in my Outlook Contacts to get them recognised properly, but alas!
Here is the log entry of my GSM calling home. In spite of the exception, MP stops all audio/video for a couple of seconds, displays my picture (from Contacts) and my name and then resumes.

3-1-2006 13:58:46 Loaded font:font16 height:16 texture:512x512 chars:[32-256] miplevels:1
3-1-2006 14:00:29 ISDN: CAPI command: 0x02 / 0x82
3-1-2006 14:00:29 ISDN: Buffer: (10)(161)35zzzzzzz(11)(33)(131)65zzzzzzz(0)(0)(3)(128)(144)(163)(0)(0)(4)
3-1-2006 14:00:29 ISDN: stripped 0 leading zeros
3-1-2006 14:00:29 ISDN: CalledID: 35zzzzzzz
3-1-2006 14:00:29 ISDN: CallerID: 65zzzzzzz
3-1-2006 14:00:29 Outlook exception: Array index out of bounds.
3-1-2006 14:00:29 ISDN: Incoming call from Rzzz Bzzzz (unknown, the Netherlands / +31 (I) 65zzzzzzz)
3-1-2006 14:00:29 Texturemanager loaded temporay:Thumbs\yac\text-message.jpg 111x148 format:X8R8G8B8
3-1-2006 14:00:29 texturemanager:added:Thumbs\yac\text-message.jpg total:6 mem left:294649856
3-1-2006 14:00:29 window:MediaPortal.Dialogs.GUIDialogNotify init
3-1-2006 14:00:29 Loaded font:font10 height:13 texture:256x256 chars:[32-256] miplevels:1
3-1-2006 14:00:29 dx9 re-entrant
3-1-2006 14:00:41 dx9 re-entrant


Hope this can be fixed, for now I have to disable the ISDN plugin. :cry:
 

Users who are viewing this thread

Similar threads

Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
Replies
2
Views
1K
What is the status of the fix? I seem to be hitting this exact problem at channel 24 (in Seattle it is KUNS-DT).
What is the status of the fix? I seem to be hitting this exact problem at channel 24 (in Seattle it is KUNS-DT).
MediaPortal 2 Version: 2.2.2 Description I am setting up a new Windows 10 Pro system to replace my old Windows 7 WMC server to be...
Replies
33
Views
2K
BTW, realized I never replied back on this one, in case anyone else runs into it. @Stéphane Lenclud Got me pointed in the right direction. My TV Has an option HD Deep Color Mode, turning this on or off will get the desired results.
BTW, realized I never replied back on this one, in case anyone else runs into it. @Stéphane Lenclud Got me pointed in the right...
Okay, I am having some issues. i will try and go to as much detail in text as I can but the attached short video shows what I am...
Replies
16
Views
3K
The watchdog is not available on the server unless MP is installed. So, I expect you would run the watchdog on the client to get a zip of the client logs; then zip all the logs in the server log directory to get a second zip; finally, post/attach both zip files here.
The watchdog is not available on the server unless MP is installed. So, I expect you would run the watchdog on the client to get a...
Hello, i've got the problem, that after changing to another channel the new channel is running for roughly 2 seconds and then the...
Replies
6
Views
833
oops, thought I had that in the zip. Attached zip file has all TV Client/Server logs for Dec 16. Looking at when I ran setuptv, 1st noticed hang somewhere around/before 4:40PM, did tv server stop/start, MePo live tv ran until I noticed 2nd hang somewhere after 6PM, did 2nd tvserver stop/start at 9:28PM. I have a 2nd MePo remote...
oops, thought I had that in the zip. Attached zip file has all TV Client/Server logs for Dec 16. Looking at when I ran setuptv, 1st...
MePo 1.9.0, tv server on win7 (core i5 4 core), tv remote client on win8.1 (core i3 2 core), wired ethernet. I've seen this happen...
Replies
2
Views
1K
Top Bottom