Как добавить свой тюнер в граф файл MediaPortala (1 Viewer)

Neos

Portal Member
February 14, 2008
18
15
Home Country
Netherlands Netherlands
Help =) ну не как не хочет работать!

<?xml version="1.0"?>


<capturecards>


<capturecard commercialname="Behold TV 505 FM: A/V Capture [Slot 1]" capturename="Behold TV 505 FM: TV Tuner [Slot 1]"

devid="ven_1131&dev_7130&subsys_50505ace&rev_01">


<capabilities tv="true" radio="true" mpeg2="true" mce="false" sw="false" bda="false"/>


<tv>
      <interface cat="mux" video="" audio="" mpeg2="0"></interface>
<filters>
<filter cat="tvtuner" name="Beholder Analog TV 505 FM: A/V Capture [Slot 1]" checkdevice="true"/>
<filter cat="tvaudio" name="Beholder TV Audio [Slot 1]" checkdevice="true"/>
<filter cat="crossbar" name="Beholder A/V Crossbar [Slot 1]" checkdevice="true"/>
<filter cat="capture" name="Beholder A/V Capture [Slot 1]" checkdevice="true"/>
<filter cat="videncoder" name="%videoencoder%" checkdevice="false"/>
<filter cat="audencoder" name="%audioencoder%" checkdevice="false"/>
<filter cat="mux" name="%mpegmux%" checkdevice="false"/>
</filters>
<connections>
<connection sourcefilter="tvtuner" sourcepin="0" sinkfilter="crossbar" sinkpin="%tvtuner%"/>
<connection sourcefilter="tvtuner" sourcepin="1" sinkfilter="tvaudio" sinkpin="0"/>
<connection sourcefilter="tvaudio" sourcepin="0" sinkfilter="crossbar" sinkpin="%audiotuner%"/>
<connection sourcefilter="crossbar" sourcepin="0" sinkfilter="capture" sinkpin="0"/>
<connection sourcefilter="crossbar" sourcepin="1" sinkfilter="capture" sinkpin="1"/>
<connection sourcefilter="capture" sourcepin="0" sinkfilter="videncoder" sinkpin="0"/>
<connection sourcefilter="capture" sourcepin="3" sinkfilter="audencoder" sinkpin="0"/>
<connection sourcefilter="videncoder" sourcepin="0" sinkfilter="mux" sinkpin="0"/>
<connection sourcefilter="audencoder" sourcepin="0" sinkfilter="mux" sinkpin="1"/>
</connections>
</tv>
</capturecard>
</capturecards>
 

Aquaman

Portal Member
August 16, 2007
2
0
Home Country
slob said:
Братцы помогите кто знает у меня Beholder 607 FM,МР 1020. Граф написал сам всё определяется кодек inter video.При прописывание каналов каналы то находит то нет (чаще нет)) Настройки брал из самого Biholder. И по номеру канала и по честоте и всё вместе (всё пустое)) Может кто сталкивался с этим приму помощь с благодарностью))

Вопрос: как определял, что "находит или не находит"?? если используя preview в конфигураторе - то у меня был такой же глюк.
В самом МП (после добавления и рестарта) - все ок. Все вручную настроенные каналы отображаются нормально.
 

yohi

Portal Member
November 14, 2008
1
0
Home Country
Russian Federation Russian Federation
Народ. Может кто держал в руках эту prolink-овскую карточку - "Pixelview Play TV MPEG 8000GT"?
Не могу понять. По-смыслу - вроде как должно работать, а в реале - в МР определяется, но пишет что-то типа: "uncreate graph for this capture"...
Гляньте опытным глазом, может найдете косячок?

Вот мой "CaptureCardDefinitions.xml":
Code:
<?xml version="1.0" encoding="UTF-8"?>
<capturecards>
  <capturecard commercialname="Pixelview Play TV MPEG 8000GT" capturename="Prolink 2388x Video Capture" devid="VEN_14F1&DEV_8800&SUBSYS_49351554&REV_05">
    <capabilities tv="true" radio="true" mpeg2="true" mce="false" sw="false" bda="false"></capabilities>
      <tv>
        <interface cat="mux" video="" audio="" mpeg2="0"></interface>
        <filters>
          <filter cat="tvtuner" name="Prolink 2388x Tuner" checkdevice="true"></filter>
          <filter cat="tvaudio" name="Prolink 2388x TvAudio" checkdevice="true"></filter>
          <filter cat="crossbar" name="Prolink 2388x Crossbar" checkdevice="true"></filter>
          <filter cat="capture" name="Prolink 23880 Video Capture" checkdevice="true"></filter>
          <filter cat="audcapture" name="%soundcard%" checkdevice="true"></filter>
          <filter cat="videncoder" name="%videoencoder%" checkdevice="false"></filter>
          <filter cat="audencoder" name="%audioencoder%" checkdevice="false"></filter>
          <filter cat="mux" name="%mpegmux%" checkdevice="false"></filter>
        </filters>
        <connections>
          <connection sourcefilter="tvtuner" sourcepin="0" sinkfilter="crossbar" sinkpin="%tvtuner%"></connection>
          <connection sourcefilter="tvtuner" sourcepin="1" sinkfilter="tvaudio" sinkpin="0"></connection>
          <connection sourcefilter="tvaudio" sourcepin="0" sinkfilter="crossbar" sinkpin="%audiotuner%"></connection>
          <connection sourcefilter="crossbar" sourcepin="0" sinkfilter="capture" sinkpin="0"></connection>
          <connection sourcefilter="crossbar" sourcepin="1" sinkfilter="capture" sinkpin="1"></connection>
          <connection sourcefilter="capture" sourcepin="0" sinkfilter="videncoder" sinkpin="0"></connection>
          <connection sourcefilter="audcapture" sourcepin="0" sinkfilter="audencoder" sinkpin="0"></connection>
          <connection sourcefilter="videncoder" sourcepin="0" sinkfilter="mux" sinkpin="0"></connection>
          <connection sourcefilter="audencoder" sourcepin="0" sinkfilter="mux" sinkpin="1"></connection>
      </connections>
    </tv>
  </capturecard>
</capturecards>
 

myhnet

Portal Pro
February 11, 2009
1,733
4
Home Country
Russian Federation Russian Federation
yohi Неплохо бы выложить логи, знающие люди посмотрят. Да и еще "CaptureCardDefinitions.xml" используется только встроенным ТВ движком, который убран из портала версий выше 1.0.2. Все что выше этой версии использует для ТВ только ТВ сервер.
 

deris777

New Member
October 1, 2009
50
0
Взял CaptureCardDefinitions.xml c сайта бехолдер, но как определить что MP нашёл тюнер? В конфигураторе в разделе Television и далее CaptureCard, в последнем при нажатии Add тюнер не находится.
 

deris777

New Member
October 1, 2009
50
0
Самому сделать совсем не получается. Программы отображают только Displayname, совсем не похожее на приведённое в первом посте. Никаких devid вовсе не видно.
 

Edalex

Community Plugin Dev
  • Premium Supporter
  • January 3, 2008
    2,931
    1,234
    Saratov
    Home Country
    Russian Federation Russian Federation
    Country flag
    Mr Bad Guy said:
    А зачем столько возни, когда можно установить ТВ-сервер?
    Наверное, потому что ТВ-сервер тоже не работает.
    В моем случае (старая аналоговая карта, нет аппаратного мпег2 кодирования) разработчики лишь недавно победили падения портала при попытке каналы просканировать. Сейчас он просто ничего не находит. Симптомы - missing software encoder (хотя он установлен), unable to start graph, unknown error
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 AV Splitter DE
    ООООО... Срочно в закладки!! СПАСИБО!!
    ООООО... Срочно в закладки!! СПАСИБО!!
    Здравствуйте. Прошу замучать сплиттер на предмет работы в портале. Сплиттер обладает рядом возможностей которые могут оказаться...
    Replies
    75
    Views
    15K
    renault! Проздравь меня я дал жизни этому тюнеру!!! точнее его аналоговой части! Как говорится спасение утопающих - дело рук самих утопающих. Выяснил вот что: Графэдит неправильные пины выдает в XGR! Я думаю, это больше косяк драйвера нежели графэдит! Создал два графа на родном его Mainconcept encoder: <capturecard...
    renault! Проздравь меня я дал жизни этому тюнеру!!! точнее его аналоговой части! Как говорится спасение утопающих - дело рук самих...
    РЕШЕНИЕ ПРОБЛЕМЫ ПОСТРОЕНИЯ ГРАФА ДЛЯ АНАЛОГОВОЙ ЧАСТИ: viewtopic.php?f=8&t=40&p=193&sid=f4e7d5b0b12ec5651f9e610cf6e3eb75#p193...
    Replies
    11
    Views
    7K
    Нет этот граф не подойдет,у каждого тюнера свой id,плюс разные чипсеты,и т.д.Граф нужно писать под конкретный тюнер.А ТВ Сервер,что не видит тюнер?
    Нет этот граф не подойдет,у каждого тюнера свой id,плюс разные чипсеты,и т.д.Граф нужно писать под конкретный тюнер.А ТВ Сервер,что...
    Привет всем, уже несколько часов ковыряюсь не могу построить graph на AVerMedia 505 (не студио) для CaptureCardDefinitions.xml...
    Replies
    3
    Views
    5K
    Hello, i tried to connect MediaPortal and Gotview SAA7134. "Unable to create graph for this device!" In file CaptureCardDefinitions.xml i added <capturecard commercialname="GotView 7134" capturename="GOTVIEW SAA7134 Video Capture" devid="ven_1131&amp;dev_7134&amp;subsys_71345456&amp;rev_01"> <capabilities tv="true"...
    Hello, i tried to connect MediaPortal and Gotview SAA7134. "Unable to create graph for this device!" In file...
    Hello, i tried to connect MediaPortal and Gotview SAA7134. "Unable to create graph for this device!" In file...
    Replies
    0
    Views
    1K
    Запустил портал. После включения компа МП сигнал не обнаружил. Перезагрузил систему вошел в конфигуратор ТВсервера, и запустил сканирование транспондеров, сигнал не пропал, карта начала лочить каналы. Прервал, запустил МП, и все наладилось. Т.е. получается процедурой сканирования удалось где-то выправить ошибку. slgeo, полное...
    Запустил портал. После включения компа МП сигнал не обнаружил. Перезагрузил систему вошел в конфигуратор ТВсервера, и запустил...
    Столкнулся с такой неприятностью. Система Win7, МП 1.1 + последний SVN. Вдруг ни с того ни с сего появилась ошибка "Нет сигала"...
    Replies
    5
    Views
    2K
    Top Bottom