[solved] LAV audio over HDMI not working until I pause then continue a video (1 Viewer)

Statick

Portal Pro
December 25, 2008
124
9
Home Country
United Kingdom United Kingdom
OK I disabled the frame rate changer (I don't ever recall enabling it, but it was enabled), and selected "prefer multi channel audio streams" and now the audio is working properly! not sure which of those was causing the problems but I'm going to guess it was the frame rate changer, as pause/continue would prove that the correct audio stream was already selected

also no idea why it was switching to 32fps as there's no reference to that in the mappings at all (which also leads me to think the problem was caused there)


2017-08-09_165427.png
 

HTPCSourcer

Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    Excellent :)

    Although things are not fully clear. Would you mind re-enabling the refreshrate changer to check if the problem is coming back? You should also take a look at the splitter settings. There is an option "Prefer Audio Stream with the Highest Quality" as well as "Demux sub-streams separately", which I have both ticked.
     

    Statick

    Portal Pro
    December 25, 2008
    124
    9
    Home Country
    United Kingdom United Kingdom
    hm. I have put back both the settings for refresh rate changer, and the prefer multi channel audio streams, but the problem has not come back.

    very odd. at least it's working though!
     

    Users who are viewing this thread

    Similar threads

    Greetings, I’m encountering frequent audio dropouts when watching Netflix through OnlineVideos and while playing music. I’m not encountering any problems with over-the-air tv. Netflix video is not affected, just audio. Music plays fine when played outside of MP through Windows Media Player. Netflix plays fine when played outside of...
    Greetings, I’m encountering frequent audio dropouts when watching Netflix through OnlineVideos and while playing music. I’m not...
    Greetings, I’m encountering frequent audio dropouts when watching Netflix through OnlineVideos and while playing music. I’m not...
    Replies
    0
    Views
    773
    Hello!!! I use a handy app called catchin' sync to roughly check the AV sync of audio/video on my HTPC/TV. It's not as accurate as a dedicated opto-electronic calibrator but it's more than adequate for this application and much better than trying to do things by eye (even when the lack of sync is massively obvious, subjective...
    Hello!!! I use a handy app called catchin' sync to roughly check the AV sync of audio/video on my HTPC/TV. It's not as accurate as...
    Hello!!! I use a handy app called catchin' sync to roughly check the AV sync of audio/video on my HTPC/TV. It's not as accurate as...
    Replies
    0
    Views
    345
    Recently I have been trying to reduce or eliminate juddering on my system. I notice it particularly with: Horizontal panning (e.g. in travel or nature documentaries) Horizontal "ticker tape" news feeds (e.g. "Sky News" channel) Vertically scrolling programme credits (e.g. "Mock the Week") I originally had my Nvidia screen-config set...
    Recently I have been trying to reduce or eliminate juddering on my system. I notice it particularly with: Horizontal panning (e.g...
    Tinkering with using MadVR. I'm still running a 1080p TV, but have plenty of old DVD rips that I haven't updated yet, and my next...
    Replies
    15
    Views
    5K
    MP1 MP2 Music on Headphones DE
    Update the latest version of Pure Audio installed ok but did not change this problem:(
    Update the latest version of Pure Audio installed ok but did not change this problem:(
    If I plug headphones into the jack on my HTPC and play music the audio continues to play through the speakers via the AVR and I get...
    Replies
    9
    Views
    3K
    Thanks @CyberSimian! I delved deeper into this issue and especially the "Silent Stream Bug" you mentioned. I downloaded different pieces of software that claimed to do like you said: keeping the DA-convertors "alive" by sending a non-audible signal periodically. Turned out this was NOT the thing happening in my AV-receiver. While...
    Thanks @CyberSimian! I delved deeper into this issue and especially the "Silent Stream Bug" you mentioned. I downloaded different...
    I'm having a strange one here ... it seems to have started after getting a new Sony 4k TV, and manifests itself by refusing to...
    Replies
    9
    Views
    1K
    Top Bottom