[fixed] Live-TV: Fast forward and rewind leads to picture freeze (1 Viewer)

tom78

Portal Pro
August 10, 2007
149
5
Germany Germany
Hello

As mentioned above, when playing live TV (SD; don't know if HD too) and pressing the rewind button on the remote, the picture freezes, but rewind is ongoing. The same when pressing fast forward.
on rewind this begins with 2x-speed, on fast forward it happens at 8x speed (2x and 4x works as expected)
Timeshift on Disk or in Ramdrive has no influence.
 

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    tom78 (or anyone else seeing this problem), did this work OK on an earlier version of MP (1.1.0 or 1.1.1) ?

    Does it also happen when playing recorded TV or other video ?

    Tony
     

    tom78

    Portal Pro
    August 10, 2007
    149
    5
    Germany Germany
    AW: Live-TV: Fast forward and rewind leads to picture freeze

    @
    infinite.loop
    Ok, i'll check the codecs when i'm at home.

    @ Owlsroost
    I noticed this issue also in 1.1.0 and 1.1.1 but did never see this with 1.0.2
    But since 1.0.2 a lot has changed in my configuration.

    I made an update of Mainboard, Processor, Operating System AND MP at once.


    New test results:
    - i changed the codecs to the windows7-built-in dtv, but this has no effect; the problem persists.
    - i have the same problem when i'm watching a recorded tv-show
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    I think the problem exists in MP 1.1.0 as well.

    There have been some changes in the TV fast-forward implementation in MP 1.2.0 - this is why it works for x2 & x4, but the Win7 audio renderer won't handle higher rates so MP falls back to the older 'repeated skip-step' FFWD/REW method - and this seems to be broken :confused:

    Can anyone else confirm this problem ?

    Tony
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    I can cofirm this problem. Fasten than 4x FFWD dont work under Win7. If the problem is the audio renderer is it possible to deactivate this while FFWD/REW?
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    I can cofirm this problem. Fasten than 4x FFWD dont work under Win7. If the problem is the audio renderer is it possible to deactivate this while FFWD/REW?
    It wont be only the audio renderer. Just think about a H264 decoder that wont support IFrame decoding only when speeds are over 4x. Your CPU / GPU will just not be able to decode H264 at 32x speeds. The issue is not so simple as it sounds but it affects all the directshow filters in the graph (and not all are under our own control).
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    I can cofirm this problem. Fasten than 4x FFWD dont work under Win7. If the problem is the audio renderer is it possible to deactivate this while FFWD/REW?
    It wont be only the audio renderer. Just think about a H264 decoder that wont support IFrame decoding only when speeds are over 4x. Your CPU / GPU will just not be able to decode H264 at 32x speeds. The issue is not so simple as it sounds but it affects all the directshow filters in the graph (and not all are under our own control).
    Agreed, but the basic MP issue is that the fallback FFWD/REW method (used when the renderer refuses higher rates) doesn't work sometimes/always with EVR - I can reproduce the problem with MP 1.1.0 under Vista every time.

    I'm looking at the MP player code at the moment....

    Tony
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    I can cofirm this problem. Fasten than 4x FFWD dont work under Win7. If the problem is the audio renderer is it possible to deactivate this while FFWD/REW?
    It wont be only the audio renderer. Just think about a H264 decoder that wont support IFrame decoding only when speeds are over 4x. Your CPU / GPU will just not be able to decode H264 at 32x speeds. The issue is not so simple as it sounds but it affects all the directshow filters in the graph (and not all are under our own control).
    Agreed, but the basic MP issue is that the fallback FFWD/REW method (used when the renderer refuses higher rates) doesn't work sometimes/always with EVR - I can reproduce the problem with MP 1.1.0 under Vista every time.
    I wouldn't be the 1st time when there is a bug in MP code :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    S IPTV from online m3u8 for Aussie Live TV General Support 9
    K Flickering live TV playback Newcomers Forum 3
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    404 How to turn off narration on live tv General 2
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    G Live Tv friert ein Allgemeines Support- und Diskussionsforum 47
    U [solved] Beginner needs help recording live TV General 19
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    rbo Fehlermeldung im Live-TV TV / Streaming 6
    R Pixellation on live TV every few seconds General Support 11
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    S [solved] Live TV subtitle issue if not using 100% font General 31
    S [solved] Live TV playing stopped General 13
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    H Live TV info OSD not displaying number of audio channels General Support 3
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    porky996t Still Unable to play Live or Recorded TV General Support 4
    Similar threads

























    Top Bottom