[fixed] live Tv freeze - 15- --> 30+ helps (1 Viewer)

FreakyJ

Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #1
    MediaPortal Version: 1.2.0 Beta
    MediaPortal Skin: Default
    Windows Version: Windows 7 x64
    CPU Type: AMD Athlon x2 245 Processor, 2900MHZ
    HDD: WDC 2TB
    Memory: 2GB DDR3
    Motherboard:
    Video Card:
    Video Card Driver:
    Sound Card:
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Cinergy C HD + CI
    1. TV Card Type: DVB-C
    1. TV Card Driver:
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec:
    MPEG2 Audio Codec:
    h.264 Video Codec:
    Satelite/CableTV Provider:
    HTPC Case:
    Cooling:
    Power Supply:
    Remote: IMon Pad
    TV: Samsung
    TV - HTPC Connection: HDMI


    Hello :)

    While I'm watching Tv sometimes video + audio freezes, sometimes it continues after some time (1 - 2 min) again, but most of the time I have to skip back some seconds and than some seconds forward again >_>

    I guess this is due some corruption in the ts stream, but shouldn't MP recover from such a corruption without any user interaction?

    I only have a log file atm, where MP recovered without user interaction after some seconds, but I will add a second one if the other issue will occur :)

    Hopefully someone can help :)

    Time to have a look at: 18:11 ;)
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Hi,

    This situation has been improved considerably since the release of the beta. If you are able to download and compile SVN, it would be worth trying.

    Best wishes,

    Mark
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #3
    AW: live Tv freeze - 15- --> 30+ helps

    thanks for the answer, I've updated my SVN but I can't build the filters :(
    I'm getting tons of:
    Error 80 error C1083: Cannot open include file: 'streams.h': No such file or directory M:\Programmieren\C#\MediaPortal\Mediaportal\DirectShowFilters\TsReader\source\TsReader.cpp 32
    And I don't know where I have to set the path.. I know streams.h is located here:
    M:\Programmieren\C#\MediaPortal\Mediaportal\mediaportal\Core.cpp\mpc-hc_subs\src\BaseClasses

    Maybe someone can provide me the TsReader.ax or I have to wait until the next version of MP is released^^
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #5
    AW: live Tv freeze - 15- --> 30+ helps

    sure, I saw the binaries, but I wasn't sure if these are the newest SVN versions or just some old stuff from x revisions back, for example the last MP Version xD
    But thanks for the information, will replace my TsReader.ax now :p And will report back^^
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi FreakyJ

    I hope you are well. :)
    The errors that I'm seeing here are:

    27-07-2011 18:11:08.600 [af4]Pes 0-0-1 fail
    and
    27-07-2011 18:11:08.759 [af4]Pes header 0-0-1 fail
    I've seen this quite a lot recently and it is starting to bother me. For an example, see -->this<-- thread. In summary, the stream is either encrypted or corrupt... or TsReader is somehow loosing its place on channel change. This behaviour could be specific to certain channels or maybe a certain CAM... I'm not sure at this point. Please do let us know how you go with the updated TsReader...

    mm
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #7
    AW: live Tv freeze - 15- --> 30+ helps

    Hi,

    I'm well, hope you too :p

    I saw this errors, but they weren't really meaningful to me xD

    I attached two logfiles from the new TSReader, I had no problems yet, but these freezes aren't so often, one or two times a day, but only if you are watching Tv for quite a long time :p

    I will let you know if something improved or not, but I think I will need a week or so of testing :)

    And I would say it isn't cam related, because I tried it with MDAPI and with my CI, I've got with both these freezes...

    greets =)
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #8
    AW: live Tv freeze - 15- --> 30+ helps

    Update:

    Had a view minutes ago a short freeze, MP recovered after ~2 seconds => so far so good, I will keep you updated :p

    Log attached, issue happened ~21:00

    Note: CI + Cam used, channel encrypted
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #9
    AW: live Tv freeze - 15- --> 30+ helps

    okay, I did some further investigation... and the main problem still exists.

    I watched for a week now Tv with my CAM (Alphacrypt Classic) and had some freezes, but MP continued Tv after ~5 seconds.
    Today I switched MDAPI on and my Fritzbox crashes from time to time (still waiting for the new Firmware, so normally I'm using my Cam atm, but that is another topic...)
    I had a crash ~10 +/- 1 minute O'Clock and the Tv stream couldn't decrypted anymore, it is clear that MP freezes, but at 10:02:05 MP continued decrypting and one minute later MP still didn't continued, so I switched 15 seconds back, and MP continued the stream from this position. That means that the TS file was okay at this point, but TsReader didn't recognized that the stream is fine again.

    Second thing I did (still on MDAPI):
    Had LiveTv runnung, ejected the card => MP freezes (at ~10:16) => reinserted card => MP still freezes (waited until ~10:18) => switched 15 seconds back => MP continued

    Third thing I did:
    Had LiveTv runnung, ejected the card (~10:20) => MP freezes (at ~10:20) => reinserted card, this time into the cam => MP still freezes (waited until ~10:22) => switched 15 seconds back => MP continued

    Fourth thing I did:
    Had LiveTv runnung, ejected the card (~10:24) (card was in cam) => MP freezes (at ~10:24) => reinserted card into the cam => MP still freezes (waited until ~10:26) => switched 15 seconds back => MP continued

    I know I ejected the card manually, but I have sometimes this issues during normal live Tv with my cam, I guess there is than a decrypting error and MP didn't find the right point to start again... And my opinion is that MP should recover from an corrupt stream... I hope the logs and my description of the problem is useful for you :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    404 [solved] Live TV...video and audio freeze General Support 20
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    K MP1.24 HDHomeRun Quatro DVT2 - Pixelation on live TV General Support 1
    S IPTV from online m3u8 for Aussie Live TV General Support 9
    K Flickering live TV playback Newcomers Forum 3
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    H random black screen live tv and videos (amended) General Support 0
    404 How to turn off narration on live tv General 2
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    G Live Tv friert ein Allgemeines Support- und Diskussionsforum 47
    U [solved] Beginner needs help recording live TV General 19
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    rbo Fehlermeldung im Live-TV TV / Streaming 6
    R Pixellation on live TV every few seconds General Support 11
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    S [solved] Live TV subtitle issue if not using 100% font General 31
    S [solved] Live TV playing stopped General 13
    H Live TV info OSD not displaying number of audio channels General Support 3
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    Similar threads

























    Top Bottom