[fixed] - Mantis 0003548: Set #itemtype on grouped database view pages not working?

Discussion in 'MediaPortal 1.2.0 BETA' started by Lbr_Lion, June 26, 2011.

  1. Lbr_Lion

    Lbr_Lion Extension Designer

    Joined:
    July 19, 2008
    Messages:
    243
    Likes Received:
    186
    Gender:
    Male
    Ratings:
    +204 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    MediaPortal Version: 1.2.0 SVN 27989
    MediaPortal Skin: Frames
    Windows Version: Windows 7 SP1
    CPU Type: AMD E-350 (Zacate)
    HDD: OCZ 120GB
    Memory: 4GB DDR3
    Motherboard: Asus E35M1-M PRO
    Video Card: AMD HD6310
    Video Card Driver: 8.861
    Sound Card: Realtec ALC887
    Sound Card AC3: Optical out (SPDIF)
    Sound Card Driver: 6.0.1.6196
    1. TV Card: Digital Everywhere FloppyDTV
    1. TV Card Type: DVB-C
    1. TV Card Driver: beta
    MPEG2 Video Codec: Cyberlink PDVD10
    MPEG2 Audio Codec: AC3Filter 1.63b
    h.264 Video Codec: Cyberlink PDVD10
    Satelite/CableTV Provider: Ziggo
    TV: Sony 32W5500
    TV - HTPC Connection: HDMI

    Hello,

    The property #itemtype seems not to work as described in mantis 3548 (And Wiki) in SVN 27989.

    I am using the default MusicViews.xml and want to use the #itemtype property in my skin for this, but when I go to My Music and select as view 'Album Artists (Index)', the #itemtype property still displays 'Album Artists' instead of 'Groups'



    Maybe I misunderstand the update or is it broken?

    Thanks
     

    Attached Files:

    • Music View.jpg
      Music View.jpg
      File size:
      129.2 KB
      Uploaded:
      June 26, 2011
      Views:
      76
    • Index.jpg
      Index.jpg
      File size:
      106.7 KB
      Uploaded:
      June 26, 2011
      Views:
      86
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. jameson_uk
    • Team MediaPortal

    jameson_uk Retired Team Member

    Joined:
    January 27, 2005
    Messages:
    7,258
    Likes Received:
    2,228
    Gender:
    Male
    Occupation:
    Data Warehousing Consultant
    Location:
    Birmingham
    Ratings:
    +2,405 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Doh. I think the code is missing a return statment... I will check and fix in the morning
     
  4. jameson_uk
    • Team MediaPortal

    jameson_uk Retired Team Member

    Joined:
    January 27, 2005
    Messages:
    7,258
    Likes Received:
    2,228
    Gender:
    Male
    Occupation:
    Data Warehousing Consultant
    Location:
    Birmingham
    Ratings:
    +2,405 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Thanks for pointing out my stupid mistake :oops:

    Should be working in r27992
     
  5. Lbr_Lion

    Lbr_Lion Extension Designer

    Joined:
    July 19, 2008
    Messages:
    243
    Likes Received:
    186
    Gender:
    Male
    Ratings:
    +204 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Thanks, it works now as is should be :)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!