mce ir blaster not flashing (1 Viewer)


New Member
October 27, 2005
Hi guys, I have been following media portal since day 1 with great interest, but have run into a little problem which I may actually need help with (particularly from Smirnoff re: his plugin)

I have tried today to set up a media portal machine with an external set top box but cant get the irblaster to flash whatsoever. The machine is running mce 2005 so I know the blaster functions 100% as it has been my main mce machine for the last year and a bit. I set up a few "external" channels for the tv tuner in mediaportal, gave them the appropriate number for the set top box etc....

stuff I have tried:
myblaster.exe into /mediaportal folder
myblaster.dll into plugins/process folder
mediaportal version 0.1.3
learn all the remote codes. no problem
select "test" blaster does not flash (tried in both ports)

tried mediaportal 0.2 beta, blaster does not flash
tried mediaportal 0.1.2 blaster does not flash (all have the same results, learning seems to be ok)

tried different machine (which has different tuners) flash.

start mce2005, confirm blaster is still functioning ok

replace blaster (clutching at straws here) (I have 3 spares) none of them flash
replace receiver (also, 3 spares) none of them make the blaster flash. All the receivers are of the same vintage, mce2004 versions but I have mce2005 remotes. FTDI232am, VID 045E, PID 006D, MS1874XQ

If anybody can help I would appreciate it greatly.

running with /gumbo option and pressing test immediately does not make the blaster flash....weird huh? (right now I couldnt care if the stb changes channel or not, I just want to make the little ir blaster flash:))


<edit> I have added the "forceport 2" entry to mediaportal.xml but still the problem remains...Anybody got a hammer? :)

myblaster.exe /dump=
27/10/2005 21:11:46 Form1.LoadConfig: Collection was modified; enumeration operation may not execute.
27/10/2005 21:11:46 Device.FindDevice: \\?\usb#vid_045e&pid_006d#ms1874xq#{7951772d-cd50-49b7-b103-2baac494fc57}
27/10/2005 21:11:52 Blaster.FinalizePacket:


New Member
October 27, 2005
ok, didnt see this mentioned anywhere, but it would appear that if you have winlirc set up to change external channels (which is default on a 0.1.3 install) then myblaster doesnt function.

to correct, go to setup-->remotes-->winlirc and remove the check for changing external channels.

yay! my little blaster light flashes now, but very weak compared to when running mce, plus the stb refuses to even acknowledge it. I think the code learning is still iffy for me, as the "test" function doesnt work...does anybody know where I can get the codes that mce uses for channel changing? It has to be stored somewhere.

Users who are viewing this thread

Top Bottom