MCE Remote + Windows 7, not all buttons working!? (1 Viewer)

rasmuskarlsen

Portal Pro
October 9, 2008
235
12
Denmark Denmark
Hey i have a little problem... I'm not sure if it's related to newest Mediaportal or Windows 7 x64...

But the problem is that all my buttons on the MCE remote is not working any more... Ex. Play Pause, Stop, Forward etc etc etc... In fact the only buttons which are now working is:
Power PC, Botton up, Button Down, button Left, Button right, OK, Mute :mad:

So how can i get my buttons to work again!??

EDIT: If i use LM Remote Keymap, to view the commands beeing send to the computer, when pressing buttons on the remote... I can see the program recieves All the above mentioned buttons that does not work perfectly...

So if that program recieve the STOP, START, REW Etc Etc perfectly... It must be Mediaportal which is not working!??
 

Gixxer

Retired Team Member
  • Premium Supporter
  • August 18, 2007
    1,383
    41
    35
    Spain
    Spain Spain

    rasmuskarlsen

    Portal Pro
    October 9, 2008
    235
    12
    Denmark Denmark
    What is that!? And what should i download!?
    i was going to give a detailed explanation but i guess i will take the easy way as you did...

    https://forum.team-mediaportal.com/ir-server-suite-irss-165/ir-server-suite-documentation-26837/

    Read!

    But why can't i just install a Vista driver? Or if it's mediaportal which is not working properly (which i think it is) is there going to be an update on mediaportal? Because it was working perfect in v. 1.0.0.0.

    LM Remote Keymap can pickup signals from the MCE remote just fine... (Every button on the MCE remote gets recognized with correct assigned "keymap" Stop, Play, Volume, 1, 2, 3 etc etc etc...
    So as far as i can see the computer can recieve the commands from the IR. But NOT pass them through to Mediaportal!?

    I have just tested my MCE Remote on Windows 7 Media Center, with standard Windows 7 drivers... And the buttons work perfectly now!!!! Therefore there must be a big BUG in Mediaportal, letting mediaportal only pick up command from the following buttons:

    OK, Navigation (Up, down, right, left), mute and Power On/down!!
     

    chefkoch

    Retired Team Member
  • Premium Supporter
  • October 5, 2004
    3,130
    1,630
    Dresden / Munich / Maastricht
    Germany Germany
    What is that!? And what should i download!?
    i was going to give a detailed explanation but i guess i will take the easy way as you did...

    https://forum.team-mediaportal.com/ir-server-suite-irss-165/ir-server-suite-documentation-26837/

    Read!

    But why can't i just install a Vista driver? Or if it's mediaportal which is not working properly (which i think it is) is there going to be an update on mediaportal? Because it was working perfect in v. 1.0.0.0.

    LM Remote Keymap can pickup signals from the MCE remote just fine... (Every button on the MCE remote gets recognized with correct assigned "keymap" Stop, Play, Volume, 1, 2, 3 etc etc etc...
    So as far as i can see the computer can recieve the commands from the IR. But NOT pass them through to Mediaportal!?

    I have just tested my MCE Remote on Windows 7 Media Center, with standard Windows 7 drivers... And the buttons work perfectly now!!!! Therefore there must be a big BUG in Mediaportal, letting mediaportal only pick up command from the following buttons:

    OK, Navigation (Up, down, right, left), mute and Power On/down!!
    This will be fixed in MediaPortal 1.1.0.

    regards
    chefkoch
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,697
    7,081
    Sydney
    Australia Australia
    Country flag
    rasmuskarlsen, did you ever solve this problem?

    I just upgraded to Win7 x64 from x86 and noticed that the same buttons also dont work. Worked fine in Win7 x86. Im using MP 1.2 Beta.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,697
    7,081
    Sydney
    Australia Australia
    Country flag
    Problem solved, was the built in IR receiver on my Fusion case...it was interfering with my standalone MCE receiver. I figured I disabled it but it wasn't! Why do they ship expensive cases with rubbish receivers!
     

    markku_maenpaa

    Portal Member
    March 30, 2005
    12
    1
    Hi all,

    Similar problem was driving me crazy as well. I had XP PRO based MP with original Microsoft MCE remote & receiver. It worked fine. I made a new MP with Windows 7 PRO X64 and suddenly the same remote & receiver would not work correctly. As I noticed that builtin IR receiver with Antec Fusion cases was causing similar trouble I began checking out the hardware in my machine. I have a BlackGold BGT3620 dual tuner card and it seems it has also a IR receiver builtin. It did not come with any remote, so I did not think of it at first. There was no way to disable it from driver level. Here is what I did: I removed the Microsoft receiver. After that I disabled all HID devices (except USB mouse) I could find. One thing I could not disable was the ehome receiver itself (no option for it). After I disabled all HID devices I put the MS receiver back in and remote started working as it should.

    I hope this helps some of you.

    Markku
     

    flow87

    Portal Pro
    January 15, 2009
    312
    3
    Germany
    Germany Germany
    Problem solved, was the built in IR receiver on my Fusion case...it was interfering with my standalone MCE receiver. I figured I disabled it but it wasn't! Why do they ship expensive cases with rubbish receivers!
    I have also an antec fusion IR and an mce remote. how do i get that config to work properly?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T Can Emprex 3009ARF III MCE Remote Control be used to toggle Fullscreen/Windowed mode?? Remotes 7
    F MCE Remote has no focus General 6
    brena MCE Remote Disable Volume Mapping Input / Output interfaces 0
    T How to add missing buttons IR Server Suite (IRSS) 0
    B iPhone app for MCE remote General Support 2
    F Somethings changed - mce remote General Support 9
    N [Finished] [MP2-789] MCE remote control Recorded TV and My Pictures buttons do not work MediaPortal 2 17
    H MP 1.21 Volume OSD for 1039 MCE remote and MCE keyboard not working 1.21 74
    azzuro MCE remote and Azerty keyboard other Input / Output interfaces 2
    Spaldo Bose universal remote with MP Input/Output Interfaces 2
    E Getting ortek mce remote to work better MediaPortal 1 Talk 13
    T MCE remote double keypress up and down General 1
    Volker [Suche] RC6 MCE IR-Empfänger Marktplatz 2
    V Some Issues with MP2 (ex MCE User) General 1
    P The elusive "MCE Replacement Driver" for Vista / Win7 IR Server Suite (IRSS) 0
    D PS3 Bluetooth Remote Remotes 1
    henrysinn Remote - W10 Gyro by Pepper Jobs General 8
    G Remote control suggestions? MediaPortal 1 Talk 16
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    TLD Can not watch tv from remote clients Television (MyTV frontend and TV-Server) 19
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    D Full fuctional htpc - Silverstone Case - Digital Devices Cine S2 - SSD - IR Remote For Sale 1
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    S Remote button to change audio and subtitle on / off General 10
    Similar threads

























    Top Bottom