Mediaportal crash if I select a scrambled TV-channel which I don't have access to. (1 Viewer)

johnzered

Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    TV-Server Version: RC 1
    MediaPortal Version: RC 1
    MediaPortal Skin:
    Windows Version:
    CPU Type:
    HDD:
    Memory:
    Motherboard:
    Video Card:
    Video Card Driver:
    Sound Card:
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Floppy DTV
    1. TV Card Type: DVB-C
    1. TV Card Driver:
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec:
    MPEG2 Audio Codec:
    h.264 Video Codec:
    Satelite/CableTV Provider:
    HTPC Case:
    Cooling:
    Power Supply:
    Remote:
    TV:
    TV - HTPC Connection:


    If I try to watch a scrambled TV-channel which I don't have access to. The following error message is displayed:

    My TV - Tune previuos ch.?
    [ Channel Name ]
    Unable to start timeshifting
    Channel is scrambled
    [ YES ] / [ NO ]

    It's ok that I'm informed that I cannot watch this channel, because I don't have access! But I'm unable to click either Yes or No. Usually Mediaportal craches immediately but sometimes I'm able to right mouse click and select previous windows from there but then the error message is still in the foreground.

    Hope somebody findes a fix for this, thanks

    //johnzered
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    At least I'm not alone then!
    Could anyone please have a look at this issue!
    It's really easy to reproduce the error if the logs ain't telling you anything.

    //johnzered
     

    ronilse

    Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    johnzered, seems like you have problems with old installation to new(TV Engine 2 server blaster), you should do a clean install & update to latest SVN & test again/attach logs.

    jimbo19 & hoverdonkeyn: No system specs & NO logs = will be deleted

    Regards
    Roy
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Ok, I tried to do a clean install but problem still remains. First I was looking on channel YLE TV2 and then switched to TV1000 then the message "My TV - Tune previuos ch.? ..." then crash.

    Thanks for taking time to investigate!

    //johnzered
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Ok so I have done some more testing and found that this problem only seems to occur if My TV is previously on and I'm selecting a scrambled channel from the epg. There are some other strange issues if I for instance select a scrambled channel in full screen, but let's focus on this one first!

    One more thing is that now with the latest svn it always craches with some of the earlier svns don't exactly remember which of them the focus was somehow set to back to the epg with the yes/no question still at top, as if the yes/no question would have been a "normal show" and not a modalpopup?

    //johnzered
     

    ronilse

    Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    Hmm, i too have some issues if i tune to a fta channel -> scrambled channel(with the CI ripped out) -> pop up -> yes. Old fta channel comes up play for 10 sec & then freeze, so not exactly same as yours but guess MP handling does something wrong & what we see it's due to setup/hw/equipment...

    There is a Mantis entry about fta -> scrambled & not able to decode & back again & it's not solved yet. I'm gonna follow it up since i can repro some of it.

    Regards
    Roy
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Okay that's sounds more like the other issues I said I had in full screen mode. So here's my description of my fullscreen issues which is very similar to that in Mantis and yours. If I tune in a fta channel then switch to another fta channel and then a scrambled channel. The yes/no message appear and now I can choose yes, but then MP plays what's in the buffer from the two earlier channels and when it reaches the point where I tried to tune to the scrambled channel TV picture freezes. I then tried to switch to a fta channel but nothing happend the only thing that is working is to go back to MY TV menu and switch TV off and then on again and then I can continue to watch tv.

    Please note that this is when I'm in fullscreen mode and the other issue I described in earlier posts is when I tune in from the epg.

    //johnzered
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Hello again,

    I've made some progressing in when and where this occurs, its in this method: public static bool ViewChannelAndCheck(Channel channel) on line 2420 there's an if statement checking if active window is tvfullcreen and if it isn't then shows the message in a new thread, and it's here where it goes wrong because when it start from a new thread the parent id is set to tvguide but when you select a channel to watch inside tvguide it goes to fullscreen so then the modaldialog is not in front and therefore its not possible to select yes/no. The best solution in my opinion would be it there was just an okdialog and then it would return to tvguide I haven't found out how to do this but. The way I have managed to solve this which isn't very elegant is to in the if statement put an or activewindow equals tvguide like this: if ((GUIWindowManager.ActiveWindow == (int)(int)GUIWindow.Window.WINDOW_TVFULLSCREEN) || GUIWindowManager.ActiveWindow == (int)(int)GUIWindow.Window.WINDOW_TVGUIDE) but then if you click yes it returns to the previous channel in fullscreen mode

    does anybody have any thoughts about how to get it back to tvguide? Or maybe an even better solution to this?

    Edit: Forgot to mention the cs-file is TVHome.cs


    //johznered
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    U [solved] MediaPortal crashing on startup General Support 10
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    ajs Trakt crashed Mediaportal if no Internet in home lan Trakt 2
    Y MediaPortal/MP Configuration crashes after update 1.21 Pre Release 3
    A MediaPortal crashes when stepping through DVR-MS files Listen Music 2
    G 1.18.0 Mediaport 1.18 crash on WIndows 10 Pro for Workstations Archive 11
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Rob Hexenmeister Mediaportal Properties #plot etc... General Support 3
    Similar threads

























    Top Bottom