MediaPortal doesn´t restart when resuming from Standby | Page 2

Discussion in '1.0 final and SVN Builds' started by Ragendorf, December 26, 2008.

  1. Ragendorf

    Ragendorf Portal Pro

    Joined:
    March 24, 2008
    Messages:
    531
    Likes Received:
    21
    Occupation:
    Starverkäufer
    Location:
    Braunschweig
    Ratings:
    +22 / 0
    Home Country:
    Germany Germany
    Hey Simone,

    it occures a new Error.

    "Objekt erwartet". Do you need the complete Error Message?

    --Jens--


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. chemelli
    • Premium Supporter

    chemelli Retired Team Member

    Joined:
    September 28, 2006
    Messages:
    6,159
    Likes Received:
    1,126
    Gender:
    Male
    Occupation:
    Activation Manager - Cloud Services
    Location:
    Trento, Italy
    Ratings:
    +1,127 / 0
    Home Country:
    Italy Italy
    yes please

    Simone
     
  4. seco
    • Team MediaPortal

    seco Development Group

    Joined:
    August 7, 2007
    Messages:
    1,579
    Likes Received:
    897
    Gender:
    Male
    Ratings:
    +1,234 / 4
    Home Country:
    Finland Finland
    Show System Specs
    Line: 17
    Char: 1
    Error: Expected statement
    Code: 800A0400
    Source: Microsoft VBScript compilation error
     
  5. chemelli
    • Premium Supporter

    chemelli Retired Team Member

    Joined:
    September 28, 2006
    Messages:
    6,159
    Likes Received:
    1,126
    Gender:
    Male
    Occupation:
    Activation Manager - Cloud Services
    Location:
    Trento, Italy
    Ratings:
    +1,127 / 0
    Home Country:
    Italy Italy
    Again an update on previous post !

    Simone
     
  6. Ragendorf

    Ragendorf Portal Pro

    Joined:
    March 24, 2008
    Messages:
    531
    Likes Received:
    21
    Occupation:
    Starverkäufer
    Location:
    Braunschweig
    Ratings:
    +22 / 0
    Home Country:
    Germany Germany
    It looks like 75% are done.

    The new Script doesn´t throw an Exception and MediaPortal is ended after Standby, but it don´t restarts.

    Think youre on a good way.

    :D

    --Jens--
     
  7. chemelli
    • Premium Supporter

    chemelli Retired Team Member

    Joined:
    September 28, 2006
    Messages:
    6,159
    Likes Received:
    1,126
    Gender:
    Male
    Occupation:
    Activation Manager - Cloud Services
    Location:
    Trento, Italy
    Ratings:
    +1,127 / 0
    Home Country:
    Italy Italy
    please try it manually from a cmd.exe:

    Code (Text):
    1.  
    2. cscript restart.vbs
    3.  
    If it works, try running "cscript /H:CScript" and then double click on it again. This should switch the default interpreter from Wscript to Cscript.

    Also report what version of Cscript/Wscript you are running.

    Simone
     
  8. seco
    • Team MediaPortal

    seco Development Group

    Joined:
    August 7, 2007
    Messages:
    1,579
    Likes Received:
    897
    Gender:
    Male
    Ratings:
    +1,234 / 4
    Home Country:
    Finland Finland
    Show System Specs
    With "cscript restart.vbs" MP disappears, but the process is not killed and MP doesn't start up.

    I have to reboot to get rid of MediaPortal.exe process

    Same goes with "cscript /H:CScript" and then "restart.vbs"

    Windows Script Host Version 5.7
     
  9. chemelli
    • Premium Supporter

    chemelli Retired Team Member

    Joined:
    September 28, 2006
    Messages:
    6,159
    Likes Received:
    1,126
    Gender:
    Male
    Occupation:
    Activation Manager - Cloud Services
    Location:
    Trento, Italy
    Ratings:
    +1,127 / 0
    Home Country:
    Italy Italy
    Disappears but is not killed ? Interesting behaviour

    What about using "Wscript restart.vbs" ? And if it works try also "cscript /H:Wscript" and then "restart.vbs"

    Simone
     
  10. seco
    • Team MediaPortal

    seco Development Group

    Joined:
    August 7, 2007
    Messages:
    1,579
    Likes Received:
    897
    Gender:
    Male
    Ratings:
    +1,234 / 4
    Home Country:
    Finland Finland
    Show System Specs
    I noticed that I don't have to restart MP anymore after standby so I stopped trying to get this script working.

    Killing MP process has always (like since 0.2.3) been problematic for me in both XP and Vista, many times when kill MP through task manager the MediaPortal.exe process stays but MP disappears, and only way to get rid of the process is a reboot. And when the process is jammed, Windows shutdown takes VERY long, I don't know why this is.
     
  11. tamvegas
    • Premium Supporter

    tamvegas MP Donator

    Joined:
    June 20, 2008
    Messages:
    169
    Likes Received:
    29
    Location:
    Las Vegas, NV
    Ratings:
    +30 / 1
    Home Country:
    United States of America United States of America
    I don't know anything of the scripting etc, but I had the same behavior a week ago on MP 1.0.
    MP icon and process would not shut down. Had to reboot.

    Turns out it was a plugin that caused the behavior. XMSharp.
    XMSharp always appeared to work perfectly except there would be no audio of the stations. After I removed the plugin, MP comes back from standby beautifully!

    Don't know if this applies but the locking of MP in process made me think I'd post it.

    In fact, after setting the TVServer to re-initilize on resume my wake-up times got much shorter. Literally 5 seconds after hitting power, my screens there and within 15 everything is useable. Surprised the heck out of me.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!