Mediaportal exits with an exception (1 Viewer)

a.dimuzio

Portal Member
November 2, 2004
32
0
Hi everybody,
since a couple of days I'm having a major issue with MediaPortal, mainly using the TV module.

My config is:
Mediaportal 0.2RC2
OS WindowsXP
NVidia FX5200
AMD 2400+
1GB RAM

When I start Mediaportal, either it exits as soon as I enter the TV module or the video playback freezes (and I have to kill MediaPortal manually).

In the log (mediaportal.log and errors.log) I found this exception:

Code:
15/2006 10:34:39 AM Planescene(768,576,768,576,110929664,False,16):Unhandled exception in Error in the application. Microsoft.DirectX.Direct3D    at Microsoft.DirectX.Direct3D.Device.PresentInternal(tagRECT* sourceRectangle, tagRECT* destRectangle, IntPtr overrideWindow)
   at Microsoft.DirectX.Direct3D.Device.PresentInternal(tagRECT* sourceRectangle, tagRECT* destRectangle, Control overrideWindow)
   at Microsoft.DirectX.Direct3D.Device.Present()
   at MediaPortal.Player.PlaneScene.InternalPresentSurface(Int32 width, Int32 height, Int32 arWidth, Int32 arHeight, Boolean InRepaint)
2/15/2006 10:34:39 AM Planescene(768,576,768,576,110929664,False,16):Unhandled exception in Error in the application. Microsoft.DirectX.Direct3D    at Microsoft.DirectX.Direct3D.Device.PresentInternal(tagRECT* sourceRectangle, tagRECT* destRectangle, IntPtr overrideWindow)
   at Microsoft.DirectX.Direct3D.Device.PresentInternal(tagRECT* sourceRectangle, tagRECT* destRectangle, Control overrideWindow)
   at Microsoft.DirectX.Direct3D.Device.Present()
   at MediaPortal.Player.PlaneScene.InternalPresentSurface(Int32 width, Int32 height, Int32 arWidth, Int32 arHeight, Boolean InRepaint)

I can't remember having done something in particular in the last few days (no video driver update, no hardware changes, no OS updates, no new codecs), maybe I changed video resolution or NView settings, but I can't remember.

Does anybody have an idea of the problem and how I can solve it?
 

a.dimuzio

Portal Member
November 2, 2004
32
0
I'm still fighting with this issue.

I tried to install the latest NVidia Driver, to remove some hotfixes for .net framework 1, but still nothing.

Another strange thing I noticed is that when I try to compress a recorded program into mpeg (this has always been working on my box) mediaportal exits (this time without exception) after having written a random quantity of data in the target file.

Any idea/suggestion on what I can try?
 

Users who are viewing this thread

Similar threads

If it keeps annoying me enough I'll have to help you with that :whistle: That's weird, because video locks up first with audio still playing for a few more seconds before MediaPortal restarts, but this will give me a few more avenues to test for. The main difference is that when I was on 1.19-1.21 without this issue that it was HTPC...
If it keeps annoying me enough I'll have to help you with that :whistle: That's weird, because video locks up first with audio...
I've been dealing with weird crashes. The display would go into a checkerboard, or mainly a giant purple banner across the screen...
Replies
8
Views
811
Exception: System.ArgumentException: Illegal characters in path. Check out the path, it seems the pathis a symbol that is not permitted in Windovs.
Exception: System.ArgumentException: Illegal characters in path. Check out the path, it seems the pathis a symbol that is not...
I have an issue where MediaPortal is crashing on a regular basis. When I run it in debug mode, it seems to work fine, but when I...
Replies
14
Views
3K
I tested to upgrade to 1.4.0 once again with increased memory (256 MB) in BIOS and it seems that the issue was resolved :) I need to evaluate a bit more since I noted some lag but I guess that is because bad signal on that particular channel.
I tested to upgrade to 1.4.0 once again with increased memory (256 MB) in BIOS and it seems that the issue was resolved :) I need...
Hi, I updated to 1.4.0 on both server and clients. Unfortunately I got problems with the most important client. After a fresh...
Replies
8
Views
1K
Hallo, ich habe neuerdings Probleme nach einem Resume. Folgendes Szenario: Abends wird MePo in den Resume geschickt. TV wird vorher gestopt. Morgens um 8:45 startet der HTPC zwecks EPG update und wird um 9:00 wieder in den Schlaf geschickt. Um diese Zeit gibt es folgenden Fehler im Log: [2014-09-05 09:00:00,963] [Log ] [MPMain ]...
Hallo, ich habe neuerdings Probleme nach einem Resume. Folgendes Szenario: Abends wird MePo in den Resume geschickt. TV wird vorher...
Hallo, ich habe neuerdings Probleme nach einem Resume. Folgendes Szenario: Abends wird MePo in den Resume geschickt. TV wird vorher...
Replies
0
Views
847
That's a good news :) I have look log and no clue about it but it's good to know that some windows update broke something
That's a good news :) I have look log and no clue about it but it's good to know that some windows update broke something
MediaPortal Version: 1.7.0 Description if I upgrade the NVidia drivers to either version 334 then I get the following error...
Replies
24
Views
5K
Top Bottom