[confirm] - Mediaportal not working with dvb-s2 HD channels with SR 30000

Discussion in 'MediaPortal 1.2.0 ALPHA' started by mylle, December 22, 2010.

  1. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark
    Hi Guys,

    This has been driving me crazy and i have been blaming the problem on Digital Devices so far but i now really think that it is a MediaPortal issue.

    I am using DVB-S and until I started using digital devices hardware i have had no problems with HD channels with symbolrate 30000 on THOR 1degree west.

    However when i startet using the DD cine S2 dual i startet to have massive frame drops and continuity errors on HD channels with symbolrate 30000 which i never had on my hauppauge Nova S2 and tt-s3200.



    I figured that it had to be the drivers or hardware and blamed it on them until i tried DVBviewer where eveything is smooth as silk..........

    The tsreader log shows massive continuity errors and so does the tvserver when using the "manual control" timeshifting and SR30000 channel. HD channels with 25000, 27500, 28000 works perfect.

    So while the SR30000 channels are working perfect on DVBviever and NOT in MediaPortal on the same machine and with the same codecs i figure there must be a bug in MediaPortal.

    There are no errors in the tvserver logs but quite alot in the client logs so i have attached those. I could also upload a recorded .ts sample if needed.

    Also Transedit is showinw NO dropped packets!

    Please advice and let me know if you need more logs.

    regards
    Jacob
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hi mylle

    Got your PM :)
    I suspect the problem may be with DVB-S2 support for DigitalDevices cards. There is no specific support for this at present, and CAM/CI support for these cards has only just been added as you're probably aware. Hauppauge tuners have specific code for supportting DVB-S2 which is why I think it works/worked on the NOVA S2. Are you able to test any DVB-S transponders with >= SR30000 to see if the problem is isolated to DVB-S2? Also, can you please post your TV Server logs...
     
  5. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark
    Hi mm1352000,

    All HD channels on thor 1degrees east is S2 but all the HD s2 channels with a symbolrate below 30000 works with no problem. I have attached tvserver logs but i dont see anything weird in them.

    Thanks for taking the time to look at this :)

    regards
    Jacob
     

    Attached Files:

    • tvserver.zip
      File size:
      4.5 KB
      Uploaded:
      December 23, 2010
      Views:
      77
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Thanks for that. You're right, there doesn't appear to be anything wrong there. Please can you try the following:

    1. Open TV Server configuration.
    2. Go to the TV channels section.
    3. Select a channel from Thor 1deg W with SR30000.
    4. Click edit.
    5. Select the tuning detail and click edit.
    6. Try setting the following modulation values and then tune the channel to see if the stuttering goes away:
    - ModNotSet
    - ModNotDefined
    - Mod8psk (default)
    - Mod8Vsb
    - Mod8psk2
    7. Also try setting Pilot to off and then retry each of the above modulations.

    Please post TV Server logs for your testing so that I can confirm that the correct modulation values are being tested. Not too many people have to use these settings so I want to make sure they work ;)

    I'm going to take a look at the video...

    [Edit: the video stutters for me too so that rules out codecs...]
     
  7. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark
    Hi mm1352000

    logs for every setting as you requested.

    regards
    Jacob
     
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    None of the settings fixed the stuttering?
     
  9. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark
    And here are logs from a working HD channel SR25000.
     

    Attached Files:

  10. mylle

    mylle Portal Pro

    Joined:
    April 14, 2005
    Messages:
    574
    Likes Received:
    54
    Location:
    Denmark
    Ratings:
    +68 / 0
    Home Country:
    Denmark Denmark
    no :(
     
  11. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hi again

    Didn't notice you were using m*api. How are you descrambling these channels in DVBViewer? Can you test any unscrambled channels?

    [Edit: I wonder if there is a problem in the TsReader since there are a number of PES and header errors in the TsReader logs. That happens for SR < 30000 as well as SR = 30000 so I'm not sure about that. Also, I know very little about TsReader so I won't be able to help with that.]
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!